Profiter D'une Carte Ati Pour épauler Le Cpu (1 Viewer)

WhyMe

Portal Member
July 26, 2008
718
12
France France
Ayééééééé, j'ai trouvééééééééééééééééééé !!!!!

Le DXVA sous WMP11 çà marche !!!!!
Plus besoin de MPCHC, et donc MP est full opérationnel, d'la balle !!!!

Je fais un tuto ds la soirée ;)

:mad:@@:
 

waskol

Portal Pro
October 16, 2008
79
6
France France
:super:

Tu lis quoi du coup avec WMP11 ???
Ne me dis pas que les Blu-ray passent avec quand même ! :nuts:
 

WhyMe

Portal Member
July 26, 2008
718
12
France France
J'ai pas de BR, j'ai juste un sample de BR et çà passe sans pb ( en même tps çà passait déjà sans pb sans le DXVA )
Bah je lis tout ce que je lisais déjà avant ( donc tout ) mais avec prise en charge du DXVA pour le H264 et le VC-1 ( pas testé avec du MPEG2 )

Et pareil, la 2400pro n'est utilisée qu'à 2-3%, donc même avec un CPU vraiment faiblard çà peut tourner très facilement ( bon par contre çà va devenir dur de tester sur du petit vu que je n'ai plus que du dual core sur mes plates formes pcie, mais bon je vais bien trouver ;) )

Bon pas le tps de faire un truc propre, donc en gros il faut :
. le filtre DirectShow de MPC <a href="http://sourceforge.net/project/showfiles.php?group_id=170561" target="_blank">http://sourceforge.net/project/showfiles.php?group_id=170561</a> ( mpchc_x86_v1.2.908.0_MPCVideoDec.zip )
. RadLightFilter <a href="http://www.videohelp.com/tools/RadLight_Filter_Manager" target="_blank">http://www.videohelp.com/tools/RadLight_Filter_Manager</a>
. enregister le filtre de MPC avec RadLightFilter et passer sa priorité en MERIT_PREFERRED + 255
. que la source soit du MKV ( pas testé avec autre chose pour le moment )
. que le flux MP4 soit au bon format "Level 4.1 DXVA Compliant" ( si c'est pas le cas on peut modifier avec un p'tit outil dont j'ai oublié le nom )
. désactiver les autres filtres pour les formats H264/VC-1 genre CoreAVC / FFDSHOW
La page source : <a href="http://nwgat.wordpress.com/2009/01/11/hard...edia-player-11/" target="_blank">http://nwgat.wordpress.com/2009/01/11/hard...edia-player-11/</a>

Et tout ceci avec des outils gratos !
 
G

GlouKirikou

Guest
<div class='quotetop'>CITATION(WhyMe @ 25 Mar 2009, 22:03 ) <{POST_SNAPBACK}></div>
J'ai pas de BR, j'ai juste un sample de BR et çà passe sans pb ( en même tps çà passait déjà sans pb sans le DXVA )
Bah je lis tout ce que je lisais déjà avant ( donc tout ) mais avec prise en charge du DXVA pour le H264 et le VC-1 ( pas testé avec du MPEG2 )

Et pareil, la 2400pro n'est utilisée qu'à 2-3%, donc même avec un CPU vraiment faiblard çà peut tourner très facilement ( bon par contre çà va devenir dur de tester sur du petit vu que je n'ai plus que du dual core sur mes plates formes pcie, mais bon je vais bien trouver ;) )

Bon pas le tps de faire un truc propre, donc en gros il faut :
. le filtre DirectShow de MPC <a href="http://sourceforge.net/project/showfiles.php?group_id=170561" target="_blank">http://sourceforge.net/project/showfiles.php?group_id=170561</a> ( mpchc_x86_v1.2.908.0_MPCVideoDec.zip )
. RadLightFilter <a href="http://www.videohelp.com/tools/RadLight_Filter_Manager" target="_blank">http://www.videohelp.com/tools/RadLight_Filter_Manager</a>
. enregister le filtre de MPC avec RadLightFilter et passer sa priorité en MERIT_PREFERRED + 255
. que la source soit du MKV ( pas testé avec autre chose pour le moment )
. que le flux MP4 soit au bon format "Level 4.1 DXVA Compliant" ( si c'est pas le cas on peut modifier avec un p'tit outil dont j'ai oublié le nom )
. désactiver les autres filtres pour les formats H264/VC-1 genre CoreAVC / FFDSHOW
La page source : <a href="http://nwgat.wordpress.com/2009/01/11/hard...edia-player-11/" target="_blank">http://nwgat.wordpress.com/2009/01/11/hard...edia-player-11/</a>

Et tout ceci avec des outils gratos ![/b]
J'ai suivi les instructions mais cela ne marche toujours pas: Ecran noir (voir <a href="http://www.mp-fr.com/forums/index.php?show...st&p=49976)" target="_blank">[url]http://www.mp-fr.com/forums/index.php?show...st&p=49976)[/url]</a>
J'ai bien installé le filtre MPC - Video Decoder. J'ai vérifié avec GraphEdit que le flux des données transite bien. D'ailleurs j'ai le même flow de données lorsque que j'utilise MPC-HC avec lequel je peux lire sans pb mes videos au format H264.
Une suggestion?
*** EDIT ***
J'ai joint une copie d'écran de graphEdit.[attachment=1403:MP_Video...aph_Edit.jpg]
 

WhyMe

Portal Member
July 26, 2008
718
12
France France
Ton fichier est bien lu avec MPCHC ?
Si c'est le cas, çà veut dire que le fichier est bon ( level 4.1 max )
Moi aussi hier soir j'ai eu un écran noir pendant un temps, je n'avais que le son.
Le filtre MPC n'était pas encore enregistré il me semble.
Cà voudrait dire que c'est la même chose pour toi : le filtre est pas ou mal enregistré.

EDIT : non je dis une bétise : çà ne marchait pas car mon fichier était en level 5.1 et que j'avais configuré le filtre uniquement pour les formats DXVA, donc il n'y avait plus aucun filtre enregistré pour décoder le flux vidéo
 

WhyMe

Portal Member
July 26, 2008
718
12
France France
<div class='quotetop'>CITATION(framug @ 26 Mar 2009, 09:43 ) <{POST_SNAPBACK}></div>
@WhyMe : Ce serait sympa que tu nous fasses un ptit truc bien propre et bien détaillé à ce sujet. ;)[/b]
Vi c'est au programme ;)


Perso j'ai jamais utilisé graphedit ...
J'essaie d'avancer sur le sujet ce midi ( bah ouais faut bien bosser qd même un peu la journée ;) )
 
G

GlouKirikou

Guest
<div class='quotetop'>CITATION(WhyMe @ 26 Mar 2009, 11:52 ) <{POST_SNAPBACK}></div>
Vi c'est au programme ;)


Perso j'ai jamais utilisé graphedit ...
J'essaie d'avancer sur le sujet ce midi ( bah ouais faut bien bosser qd même un peu la journée ;) )[/b]
J'ai continué à investiguer sur ma problèmatique. Voici la synthèse:
- MP en mode fenêtré: Ecran noir à la visualisation film HD encodé en H.264
- MP en plien écran: Visualisation correct film HD encodé en H.264 (je suppose que le DXVA est actif).

Ce constat m'a emmené à la reflexion suivante: Est-ce que MP fonctionne avec le mode VMR9 en Direct3D Fullscreen. Cette page de configuration me dit oui:
[attachment=1409:MP_Video..._setting.jpg]
Si oui alors est-il nécessaire? La réponse est oui car si je désactive le paramètre "Use exclusive mode" j'ai une erreur me disant une impossibilité de lire la vidéo "skipping track". Cela expliquerait pourquoi je ne peux pas utiliser mon player extern MP-HC qui lui n'est pas configuré en mode "Direct3D Fullscreen". Ce mode est trop contraignant. De plus je m'aperçois que le resize de la vidéo est complètement faux. Mais ça c'est un autre problème.

Ma question: est-il possible d'utiliser le filtre DirectShow de MPC sans être en mode "Direct3D Fullscreen"?

A j'oubliais j'ai aussi le problème des sous-titres qui ne s'affichent pas. Voici les log associés à ce problème:
[attachment=1410:MediaPortal_log.txt]
 

azzuro

Test Group
  • Team MediaPortal
  • May 10, 2007
    9,360
    4,987
    France - IDF
    France France
    Country flag
    WhyMe je te rappelle que j'ai une petite config semprom 2800 socket FSB 333 Avec 1.5 GO ram DDR @FSB400 ATI 3650 AGP
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom