[confirm] PS++ not preventing standby (1 Viewer)

doveman

Portal Pro
February 12, 2008
2,326
178
United Kingdom United Kingdom
Country flag
I was using PS++ with 1.4 and it was working OK (with Windows in control of standby) but after updating to 1.5, it keeps going to standby whilst I'm watching videos, even if I add Mediaportal to the list of processes that should prevent standby.

There doesn't seem to much about PS++ in the TVService.log but Mediaportal.log shows

[2013-08-25 15:28:29,346] [Error ] [MPMain ] [ERROR] - PS: Cannot connect to local tvservice to load settings

and a lot of

[2013-08-25 15:28:33,532] [Log ] [MPMain ] [INFO ] - PS: Cannot register client's PowerScheduler as RemoteStandbyHandler / RemoteWakeupHandler: Unable to connect to the remote server
 

tCC

Portal Pro
December 1, 2008
131
6
Netherlands Netherlands
Had a lot of "powerscheduler++" problems when upgraded to v1.5 as well (system did not wake for recordings), but an install within the extention installer solved all my problems.
 

doveman

Portal Pro
February 12, 2008
2,326
178
United Kingdom United Kingdom
Country flag
Had a lot of "powerscheduler++" problems when upgraded to v1.5 as well (system did not wake for recordings), but an install within the extention installer solved all my problems.

Thanks, that seems to have helped and at least it shows Mediaportal is preventing standby in TV Server config now if I add it to the processes list.

Weirdly, when I installed it from the Extensions installer it didn't say PS++ was already installed and that I needed to uninstall it first, it just went straight ahead with the install so it doesn't seem to have recognised it was installed.
 

michael_t

Portal Pro
November 30, 2008
1,258
813
Germany Germany
Same here
This is because PS++ is not installed. It is now part of MediaPortal and therefore does not show up in MPEI installed extensions. You should not install PS++ as an extension (you can do it with the MP pre-release, since this is a 1.4.x version, but you won't be able to do it with MP 1.5).

Michael
 

michael_t

Portal Pro
November 30, 2008
1,258
813
Germany Germany
I was using PS++ with 1.4 and it was working OK (with Windows in control of standby) but after updating to 1.5, it keeps going to standby whilst I'm watching videos, even if I add Mediaportal to the list of processes that should prevent standby.

There doesn't seem to much about PS++ in the TVService.log but Mediaportal.log shows

[2013-08-25 15:28:29,346] [Error ] [MPMain ] [ERROR] - PS: Cannot connect to local tvservice to load settings

and a lot of

[2013-08-25 15:28:33,532] [Log ] [MPMain ] [INFO ] - PS: Cannot register client's PowerScheduler as RemoteStandbyHandler / RemoteWakeupHandler: Unable to connect to the remote server
Please no cross-posting. I already answered your request in the PS++ thread and suggested to make a restart of the tvservice and recollect logs. I did not recommend you to install PS++ on the MP 1.5 pre-release version. This is no supported scenario.
So please reinstall 1.5 (to get rid of the installed PS++ and to restart the tvservice), set the client log level to "Debug", wait until the system goes to standby when you are watching video and then send the logs.

Michael
 
Last edited:

matejdro

Portal Pro
May 28, 2010
361
16
Slovenia Slovenia
Yeah similar problem here. Upgraded from 1.4 with PS++ installed manually to 1.5 Pre-release.

First I had to manually re-activate PowerScheduler on TV server plugins page which was not the case with previous version (previously it reverted to regular PS each time, but it was pre-enabled). Anyway, settings are still here so I guess it is not problem.

Real problem is that my HTPC just went into standby despite "Do not put computer to sleep while MediaPortal client is not running" is checked and mediaportal was not turned on at a time.

I would provide logs but there aren't any (This is related to TV server and those logs are practically empty - did not watch TV with 1.5 yet).

EDIT: I just noticed that "Wakeup / Standy Status" section is empty despite there are blocking processes running. I think process based anti-standby is messed up. Attached image.
 

Attachments

Last edited:

doveman

Portal Pro
February 12, 2008
2,326
178
United Kingdom United Kingdom
Country flag
Please no cross-posting. I already answered your request in the PS++ thread and suggested to make a restart of the tvservice and recollect logs. I did not recommend you to install PS++ on the MP 1.5 pre-release version. This is no supported scenario.
So please reinstall 1.5 (to get rid of the installed PS++ and to restart the tvservice), set the client log level to "Debug", wait until the system goes to standby when you are watching video and then send the logs.

Michael

Yeah sorry. So i reinstalled 1.5 and that seems to have sorted it out.

Now with media playing, TV Server config shows this is preventing standby (as well as the Realtek audio driver but I had to set an override for that as otherwise programs like Jitsi prevent it sleeping just by being loaded, as they seem to activate the audio driver) and it didn't go to sleep whilst watching videos.

After the video finished, I left it and the EPG grabber started and that seems to prevent standby with the "Do not sleep whilst grabbing EPG" option ticked, so that seems to be working. It went to standby some time later, presumably when the EPG grab had finished.

After resuming, I started a download with OnlineVideos and it went to standby whilst that was still in progress (at 82%). After resuming again, the download doesn't continue so I'll have to start that from scratch, so I think PS++ should prevent standby whilst MP is downloading as well as when media is playing. I could probably achieve this by setting the "Do not sleep whilst the network is active" option but I'm not sure how low I'd need to set it, or if sometimes there's pauses in the download caused by server bandwidth issues and maybe PS++ would allow standby when this happens, so it would probably be better if it just prevented standby whilst downloads are active, irrespective of the current KB/s.
 

Vasilich

Test Group
  • Team MediaPortal
  • August 30, 2009
    3,393
    1,170
    Germany, Mayence
    Russian Federation Russian Federation
    Country flag
    PS++ should prevent standby whilst MP is downloading
    not sure if ps++ has any idea what this particular plugin (in this case OnlineVideos) is doing ATM. PlayVideo is a special mode (declared and used in MP), and this "downloading smth" isn't.
    michael, correct me please if i'm wrong.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom