Questions about auto approve when importing (1 Viewer)

Dj_Moren

Portal Pro
November 7, 2009
171
25
Hello,

I readed the FAQ for the automatically approved results but i don't understand it at all. I have done many test with no solution. My question with an example:
I have a movie: Lock & Stock [BD25][1080p x264 DTS 768][1998].mkv
I have modified the scrapper to search with title before the first "[" so it searchs for "Lock & Stock". Also i have modified it to search for same year taking last 4 numbers, so it searchs for 1998. This is always good, it always founds the correct result. But rarely auto approves it. If i see the log i can see this:

Code:
19-May-2013 15:06:42 Debug [ DataProviderManager]: SEARCH: Title='Lock & Stock [BD25] 768]', Provider='FilmAffinity.com (IMDb.es) Josu ESTRICTO', Version=2.0.5, Number of Results=1
19-May-2013 15:06:42 Debug [	  MovieSignature]: MATCHING: 'lock stock bd25 768' WITH: 'Lock & Stock' RESULT: TitleScore=9, YearScore=0, ImdbMatch=False, AlternateTitleUsed=False, AlternateTitle='', AutoApprove=False


Why is it trying to match 'lock stock bd25 768' with 'Lock & Stock'?
Is there any way to say to the importer just to automatically import when ONLY 1 result is found?

Thank you community!!
 

RoChess

Extension Developer
  • Premium Supporter
  • March 10, 2006
    4,433
    1,895
    You have to adjust the noise filter to remove the [BD25] and [1080p x264 DTS 768] from the title, while keeping the '1998' info intact.

    As it stands now, "Lock & Stock [BD25][1080p x264 DTS 768][1998]" is turned into

    title = lock stock bd25 768
    year = 1998

    The noise filter is done with complicated regular expressions, so expanding it to support your filenames to clean them up is not easy for everybody. Let me know if this syntax applies to all your files, or if there is a variation between them. If they are all "Title [useless][more useless][year].ext" then it is easy, but if you have slight variations, then RegExp will break. So provide as much info as possible and I'll show you what to do.

    PS: Your title is 9 characters different (hence the titlescore) from the title found with scraper-script. Unless you adjust your import slider to reckless, that is never going to be auto-approved. But this should auto-resolve itself with a good noise-filter.
     
    Last edited:

    Dj_Moren

    Portal Pro
    November 7, 2009
    171
    25
    So the reckless will auto approve every result if the result numer is only one? Or the titlescore has to be a minimun number or percentage?
    Mi films are generally (as a regular expression):
    If it is a file: Title [useless]*[year].ext
    For example: "Lock & Stock [BD25][1080p x264 DTS 768][1998].mkv" or "Lock & Stock [1080p BDRip][1998].mkv" or "Lock & Stock [1998].mkv"...
    If it is a folder (BDs or folders with video and subtitles) its the same without extension: Titlte [useless]*[year]
    For example: "Lock & Stock [BD25][1080p x264 DTS 768][1998]" or "Lock & Stock [1080p][1998]" or "Lock & Stock [1998]"...

    Thank you for your help RoChess
     

    RoChess

    Extension Developer
  • Premium Supporter
  • March 10, 2006
    4,433
    1,895
    Ok just *ADD* the following at the end of the existing noise filter you can find in MovPic advanced settings:

    Code:
    |(?:\[(?:(?!\d{4}\])[^]]+)\]\s*)+
    Did not run an actual test myself in MovPic, but it works in Expresso so should be good.
     

    Dj_Moren

    Portal Pro
    November 7, 2009
    171
    25
    hmmmmm thank you. That worked for thet film. I have tried with another film, "TPB AFK The Pirate Bay Away from Keyboard [1080p DTS-5.1-Swedish+(US_sub)][2013]", and hasn't been auto approved despite having same file format:

    Code:
    19-May-2013 21:22:39 Debug [ DataProviderManager]: SEARCH: Title='TPB AFK The Pirate Bay Away from Keyboard -5 1-Swedish+(US sub)]', Provider='FilmAffinity.com (IMDb.es) Josu ESTRICTO', Version=2.0.5, Number of Results=1 
    19-May-2013 21:22:39 Debug [	  MovieSignature]: MATCHING: 'tpb afk the pirate bay away from keyboard 5 1 swedish us sub' WITH: 'TPB AFK: The Pirate Bay Away from Keyboard' RESULT: TitleScore=19, YearScore=0, ImdbMatch=False, AlternateTitleUsed=False, AlternateTitle='', AutoApprove=False

    Thank you RoChess
     

    RoChess

    Extension Developer
  • Premium Supporter
  • March 10, 2006
    4,433
    1,895
    By putting this RegExp at the end and seperating it with '|' from the existing one, the default expression takes precendence. So it causes a false positive on some parts and then the expression I've made fails.

    So change: (original one)|(the one i gave you)

    into: (the one i gave you)|(original one)

    So restore the original noise filter and then prefix it with:
    Code:
    (?:\[(?:(?!\d{4}\])[^]]+)\]\s*)+|
     

    Users who are viewing this thread

    Top Bottom