Recorded TV Freezes following screen size change (MP 1.13 final)

tonewheelkev

Portal Pro
February 10, 2012
356
18
Leeds
Country flag
This has just started to occur following recent upgrade to 1.13 final.

20 secs after freezing.....audio stops.
Frozen screen can only be removed using taskmanager.

Have included logs......wish I could make some sense of them myself...but 'hey-ho'!
 
Last edited:

mm1352000

Development Group
  • Team MediaPortal
  • September 1, 2008
    21,541
    113
    Country flag
    Heya

    I'm not clear where the problem actually is in the log files.

    I see you enter the TV section, and TV starts (or tries to start) as per your configuration:
    [2015-12-26 12:48:10,337] [Log ] [MPMain ] [INFO ] - TVHome:OnPageLoad
    ...
    [2015-12-26 12:48:10,743] [Log ] [MPMain ] [INFO ] - tv home init:BBC One HD
    [2015-12-26 12:48:10,743] [Log ] [MPMain ] [INFO ] - TVHome.ViewChannelAndCheck(): View channel=BBC One HD

    I say "tries" because I see this error, and so I'm not sure if TV actually ran successfully:
    [2015-12-26 12:48:11,930] [Error ] [MPMain ] [ERROR] - DirectShowUtils: failed filter DirectSound: LG TV-3 (2- NVIDIA High Definition Audio) not found

    ~100 seconds later you stop TV:
    [2015-12-26 12:49:47,330] [Log ] [MPMain ] [INFO ] - Main: Stopping media

    ~15 seconds later some kind of screen and/or audio output change occurs:
    [collapse]
    [2015-12-26 12:50:01,655] [Log ] [MPMain ] [INFO ] - Main: Audio Renderer NVIDIA High Definition Audio removed
    [2015-12-26 12:50:02,445] [Log ] [MPMain ] [INFO ] - Main: Audio Renderer NVIDIA High Definition Audio removed
    [2015-12-26 12:50:02,665] [Log ] [MPMain ] [INFO ] - Main: Video Device or Screen Generic PnP Monitor removed
    [2015-12-26 12:50:02,675] [Log ] [MPMain ] [INFO ] - Main: Video Device or Screen Generic PnP Monitor connected
    [2015-12-26 12:50:02,686] [Log ] [MPMain ] [INFO ] - Main: Audio Renderer LG TV-3 (NVIDIA High Definition Audio) removed
    [2015-12-26 12:50:04,852] [Log ] [MPMain ] [INFO ] - Main: Screen MP OnDisplayChange is displayed on changed from \\.\DISPLAY1 to \\.\DISPLAY2
    [2015-12-26 12:50:04,937] [Log ] [MPMain ] [INFO ] - Main: Video Device or Screen Generic PnP Monitor removed
    [2015-12-26 12:50:04,953] [Log ] [MPMain ] [INFO ] - Main: Screen MP OnGetMinMaxInfo is displayed on changed from \\.\DISPLAY1 to \\.\DISPLAY2
    [2015-12-26 12:50:06,054] [Log ] [MPMain ] [INFO ] - Main: Screen MP OnDisplayChange is displayed on changed from \\.\DISPLAY2 to \\.\DISPLAY2
    [2015-12-26 12:50:06,154] [Log ] [MPMain ] [INFO ] - Main: Video Device or Screen Generic PnP Monitor connected
    [2015-12-26 12:50:06,170] [Log ] [MPMain ] [INFO ] - Main: Screen MP OnDisplayChange is displayed on changed from \\.\DISPLAY1 to \\.\DISPLAY2
    [2015-12-26 12:50:06,192] [Log ] [MPMain ] [INFO ] - Main: Screen MP OnGetMinMaxInfo is displayed on changed from \\.\DISPLAY1 to \\.\DISPLAY2
    [2015-12-26 12:50:06,208] [Log ] [MPMain ] [INFO ] - Main: Audio Renderer NVIDIA High Definition Audio removed
    [2015-12-26 12:50:06,223] [Log ] [MPMain ] [INFO ] - Main: Audio Renderer NVIDIA High Definition Audio connected
    [2015-12-26 12:50:06,239] [Log ] [MPMain ] [INFO ] - Main: Audio Renderer NVIDIA High Definition Audio connected
    [2015-12-26 12:50:06,239] [Log ] [MPMain ] [INFO ] - Main: Audio Renderer NVIDIA High Definition Audio connected
    [2015-12-26 12:50:06,254] [Log ] [MPMain ] [INFO ] - Main: Audio Renderer RX-V771-3 (NVIDIA High Definition Audio) connected
    [2015-12-26 12:54:06,036] [Log ] [MPMain ] [INFO ] - Main: WM_POWERBROADCAST (PBT_POWERSETTINGCHANGE)
    [2015-12-26 12:54:06,036] [Log ] [MPMain ] [INFO ] - Main: The user activity timeout has elapsed with no interaction from the user
    [2015-12-26 14:50:06,358] [Log ] [MPMain ] [INFO ] - Main: WM_POWERBROADCAST (PBT_POWERSETTINGCHANGE)
    [2015-12-26 14:50:06,358] [Log ] [MPMain ] [INFO ] - Main: The display is off
    [2015-12-26 17:25:53,972] [Log ] [MPMain ] [INFO ] - Main: WM_POWERBROADCAST (PBT_POWERSETTINGCHANGE)
    [2015-12-26 17:25:53,972] [Log ] [MPMain ] [INFO ] - Main: The display is on
    [2015-12-26 17:25:53,972] [Log ] [MPMain ] [INFO ] - Main: WM_POWERBROADCAST (PBT_POWERSETTINGCHANGE)
    [2015-12-26 17:25:53,972] [Log ] [MPMain ] [INFO ] - Main: User is providing input to the session
    [2015-12-26 17:26:02,072] [Log ] [MPMain ] [INFO ] - Main: Audio Renderer NVIDIA High Definition Audio removed
    [2015-12-26 17:26:02,072] [Log ] [MPMain ] [INFO ] - Main: Screen MP OnDisplayChange is displayed on changed from \\.\DISPLAY2 to \\.\DISPLAY2
    [2015-12-26 17:26:02,119] [Log ] [MPMain ] [INFO ] - Main: Audio Renderer NVIDIA High Definition Audio removed
    [2015-12-26 17:26:02,119] [Log ] [MPMain ] [INFO ] - Main: Screen MP OnGetMinMaxInfo is displayed on changed from \\.\DISPLAY1 to \\.\DISPLAY2
    [2015-12-26 17:26:02,204] [Log ] [MPMain ] [INFO ] - Main: Video Device or Screen Generic PnP Monitor removed
    [2015-12-26 17:26:02,219] [Log ] [MPMain ] [INFO ] - Main: Audio Renderer RX-V771-3 (NVIDIA High Definition Audio) removed
    [2015-12-26 17:26:03,635] [Log ] [MPMain ] [INFO ] - Main: Screen MP OnDisplayChange is displayed on changed from \\.\DISPLAY2 to \\.\DISPLAY1
    [2015-12-26 17:26:03,651] [Log ] [MPMain ] [INFO ] - Main: Video Device or Screen Generic PnP Monitor connected
    [2015-12-26 17:26:03,651] [Log ] [MPMain ] [INFO ] - Main: Screen MP OnDisplayChange is displayed on changed from \\.\DISPLAY1 to \\.\DISPLAY1
    [2015-12-26 17:26:03,666] [Log ] [MPMain ] [INFO ] - Main: Screen MP OnGetMinMaxInfo is displayed on changed from \\.\DISPLAY1 to \\.\DISPLAY1
    [2015-12-26 17:26:04,606] [Log ] [MPMain ] [INFO ] - Main: Audio Renderer NVIDIA High Definition Audio removed
    [2015-12-26 17:26:04,637] [Log ] [MPMain ] [INFO ] - Main: Audio Renderer NVIDIA High Definition Audio connected
    [2015-12-26 17:26:04,684] [Log ] [MPMain ] [INFO ] - Main: Audio Renderer NVIDIA High Definition Audio connected
    [2015-12-26 17:26:04,706] [Log ] [MPMain ] [INFO ] - Main: Audio Renderer NVIDIA High Definition Audio connected
    [2015-12-26 17:26:04,722] [Log ] [MPMain ] [INFO ] - Main: Audio Renderer LG TV-3 (NVIDIA High Definition Audio) connected[/collapse]

    After this it looks like you go into the guide briefly, followed by the recorded TV section, and select a Downton Abbey recording to play:
    [2015-12-26 17:26:52,561] [Log ] [MPMain ] [INFO ] - PlayRecording:E:\Recordings\Downton Abbey - ITV HD - 2015-12-25.ts - using rtsp mode:False

    Again, I'm not sure whether that was successful:
    [2015-12-26 17:27:00,342] [Error ] [MPMain ] [ERROR] - DirectShowUtils: failed filter DirectSound: LG TV-3 (2- NVIDIA High Definition Audio) not found

    In any case, it looks like you seek within the recording a couple of times:
    [collapse]
    [2015-12-26 17:27:04,812] [Log ] [MPMain ] [INFO ] - TsReaderPlayer:seekabs:1238873750 start:0 end:72038160000
    [2015-12-26 17:27:04,914] [Log ] [MPMain ] [INFO ] - TsReaderPlayer: pos: 1238873750 start:0 end:72038160000
    [2015-12-26 17:27:04,917] [Log ] [MPMain ] [INFO ] - TsReaderPlayer seek done:1
    [2015-12-26 17:27:04,920] [Log ] [MPMain ] [INFO ] - TSReaderPlayer: current pos:123.887375 dur:7203.816
    [2015-12-26 17:27:07,964] [Log ] [MPMain ] [INFO ] - TsReaderPlayer:seekabs:1116909584 start:0 end:72027420000
    [2015-12-26 17:27:08,051] [Log ] [MPMain ] [INFO ] - TsReaderPlayer: pos: 1116909584 start:0 end:72027420000
    [2015-12-26 17:27:08,054] [Log ] [MPMain ] [INFO ] - TsReaderPlayer seek done:1
    [2015-12-26 17:27:08,057] [Log ] [MPMain ] [INFO ] - TSReaderPlayer: current pos:111.6909584 dur:7202.742[/collapse]

    Then what appears to be a screen size change occurs:
    [2015-12-26 17:27:11,256] [Log ] [MPMain ] [INFO ] - D3D: Back Buffer Size set to: 1813x1020

    I see you switch from full screen to windowed mode:
    [2015-12-26 17:27:12,384] [Log ] [MPMain ] [INFO ] - D3D: Switching from full screen to windowed mode

    5 minutes later it looks like the screen size changes back to what it was before (???):
    [2015-12-26 17:32:00,457] [Log ] [MPMain ] [INFO ] - D3D: Back Buffer Size set to: 1920x1080

    ...and you switch back to full screen:
    [2015-12-26 17:32:01,615] [Log ] [MPMain ] [INFO ] - D3D: Switching from windowed mode to full screen

    ~20 minutes later the screen size changes back to the weird 18**x1020 resolution:
    [2015-12-26 17:49:06,409] [Log ] [MPMain ] [INFO ] - D3D: Back Buffer Size set to: 1813x1020

    Again you switch to windowed mode:
    [2015-12-26 17:49:07,623] [Log ] [MPMain ] [INFO ] - D3D: Switching from full screen to windowed mode

    Finally it appears like the recording ends:
    [2015-12-26 17:50:36,916] [Log ] [MPMain ] [INFO ] - g_Player.OnStopped()

    ...and the log comes to a fairly abrupt end shortly afterwards.

    I'm left uncertain as to exactly when you think "recorded TV freezes", and whether when you say "freezes" you mean playback (ie. the video) stops or MP itself becomes unresponsive somehow.

    Please clarify. :)
     

    tonewheelkev

    Portal Pro
    February 10, 2012
    356
    18
    Leeds
    Country flag
    Well.....by 'freezing'....I do mean that MP becomes unresponsive.....then can only be 'killed' via taskmanager.

    ....and it's now happening with live TV
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,541
    113
    Country flag
    Which version of MP were you using prior to MP 1.13 final?

    Are you certain the issue is related to the MP update?
    I'm not sure if you're aware, but there have been "random freeze" issues with recent NVidia drivers:
    https://forum.team-mediaportal.com/threads/nvidia-driver-issue-since-358-87.132823/

    Some people are reporting that the driver version you appear to be using now (latest 361.43) is okay again, but the driver is very new and the reports are less than a week old so the situation isn't clear. Point is: if you're using the latest NVidia driver then MP isn't the only thing that has changed on your system recently. Hence my question. I'm wondering whether what you're seeing is more of the same known NVidia issue, or actually an issue with the MP 1.13 release. Further to the point: of the top of my head I can't think of anything that we changed (at least in the final release) which would be able to cause a problem like this.
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,541
    113
    Country flag
    Was using 1.13 Pre......before going to final!!
    Right, so even more reason for me to doubt this has anything to do with MP. I refer you to the change list:
    https://issues.team-mediaportal.com/secure/ReleaseNote.jspa?version=11805&styleName=&projectId=10505&Create=Create&atl_token=B4EP-HW6A-0D29-NTZG|f2e05d8ac1a1e88783cd9e440454954e0dab0af5|lin

    At this point I'm not sure what to suggest to you, though I do think you should look into that "failed filter DirectSound: LG TV-3 (2- NVIDIA High Definition Audio) not found" thing. If you're using HDMI for audio, there's a potential connection between that, the reported NVidia driver issues, and the fact that MP appears to lock up when trying to stop playback.
     

    tonewheelkev

    Portal Pro
    February 10, 2012
    356
    18
    Leeds
    Country flag
    Was using 1.13 Pre......before going to final!!
    Right, so even more reason for me to doubt this has anything to do with MP. I refer you to the change list:
    https://issues.team-mediaportal.com/secure/ReleaseNote.jspa?version=11805&styleName=&projectId=10505&Create=Create&atl_token=B4EP-HW6A-0D29-NTZG|f2e05d8ac1a1e88783cd9e440454954e0dab0af5|lin

    At this point I'm not sure what to suggest to you, though I do think you should look into that "failed filter DirectSound: LG TV-3 (2- NVIDIA High Definition Audio) not found" thing. If you're using HDMI for audio, there's a potential connection between that, the reported NVidia driver issues, and the fact that MP appears to lock up when trying to stop playback.
    Not at all sure how that change list helps me.....:(
    I didn't experience the earlier nvidia driver problem.....as far as I'm aware

    Very frequent occurence....both in windowed and full screen modes

    Switching from live TV to recorded TV....at 17.35......MP locks/becomes unresponsive/(freezes!!)
    Logs attached
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,541
    113
    Country flag
    Thanks for your patience.

    Another person has reported what appears to be a similar issue:
    https://forum.team-mediaportal.com/threads/mp-1-13-final-freezes.133166/

    Interestingly it's another NVidia GPU in that case.

    Not at all sure how that change list helps me.....:(
    I only linked it to point out that the difference between PR and final was only meant to be a dozen well-tested and safe bug fixes. There's nothing which stood out as a potential cause. Having said that, the person in the other thread was able to provide log files for both PR and final for us to compare. The comparison suggested the possibility that the 4720 change may be the cause of the difference. Investigation is ongoing...
     

    TreeInSeattle

    New Member
    December 28, 2015
    2
    1
    58
    Country flag
    Similar issue with MP 1.13 Final here. No problems running windowed or in MiniTV Mode and I can get into Full Screen, but any action in Full Screen with input device (mouse or keyboard) and the display freezes while the audio continues for a bit. (Using aMPdroid at least allows volume control, but that's via MPExtended.)

    Win 10.0.10586, Intel i7-4770 CPU, Intel HD Graphics 4600 GPU, Shader 5.0, OpenGL 4.3, OpenCL 1.2 DirectX 12.0

    Attaching Watchdog generated logs, though it sounds as if there's a lead being followed.
     
    Top Bottom