Recorded TV to NAS no longer working after Windows build 1803 (1 Viewer)

Javelin

MP Donator
  • Premium Supporter
  • December 27, 2006
    43
    6
    Nth Richmond NSW
    Home Country
    MediaPortal Version: 1.19.0

    Description
    I have a standalone Mediaportal setup with recording to a NAS. Timeshifting is to a local drive. This has been a stable setup for several years however after after Windows updated to 1803 Recorded TV is no longer working properly. 1803 also created problems viewing video on my NAS but I have been able to resolve that issue.

    Since the update the following problems have been experienced:

    Scheduled recordings will start but not stop.
    Only one of multiple simultaneous recording will work
    Unable to record from multiple channels simultaneously
    Recorded programs are only viewable if you keep Mediaportal on the channel while recording
    If you change channels recording will show up in Recorded TV with 0:00 duration and you cannot watch them after they have finished.
    Unable to stop TV service without shutting down the computer if stuck on a scheduled recording

    While recording a program you can view/timeshift etc but this would be from the time shift buffer.

    After recording has finished however most shows are not viewable, timestamp usually says 0:00

    Usually 1 of multiple simlutaneous recordings will work but not always

    When Mediaportal does record it creates the recording on my NAS in the correct folder but most of the time this does not happen.

    I am am almost certain the problems have been created by build 1803 and the change of several network features by Microsoft.

    To test my theory I set up a folder for Recorded TV on the local PC and hey presto Recorded TV works perfectly. Can record from several channels simultaneously, scheduled recordings start and stop when they're supposed to etc so it definitely has something to do with network access.

    I have TvService running under an account with credentials that match my NAS so that is not the problem.

    I mentioned earlier that I couldn't access any videos on my NAS. I was able to rectify this by substituting the
    IP of my NAS into the path for my video folders e.g. \\192.168.1.100\Media Centre\Media Portal\ instead of \\Diskstation\Media Centre\Media Portal\

    I thought I might be able to do the same for Recorded TV but you cannot type the path in for Recorded TV you can only select if from and explorer tree inside TVServer Setup. (Is there a workaround to this)

    Preliminary logs attached, in the process of creating further logs with scheduled recording etc. Will attach these when complete.

    Any help / suggestions will be appreciated.

    Steps to Reproduce:
    Manual and scheduled recordings.

    Scheduled recordings will start but not stop.
    Only one of multiple simultaneous recording will work
    Unable to record from multiple channels simultaneously
    Recorded programs are only viewable if you keep Mediaportal on the channel while recording
    If you change channels recording will show up in Recorded TV with 0:00 duration and you cannot watch them after they have finished.
    Unable to stop TV service without shutting down the computer if stuck on a scheduled recording
     

    Attachments

    • MediaPortalLogs_22_05_18__20_23.zip
      1.8 MB · Views: 44

    Javelin

    MP Donator
  • Premium Supporter
  • December 27, 2006
    43
    6
    Nth Richmond NSW
    Home Country
    Further logs
     

    Attachments

    • MediaPortalLogs_25_05_18__20_23.zip
      3.2 MB · Views: 39
    • MediaPortalLogs_27_05_18__14_10.zip
      3.5 MB · Views: 42

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,330
    3,792
    Lehmden
    Home Country
    Germany Germany
    Country flag
    Hi.
    (Is there a workaround to this)
    It probably is... The path is stored inside the TV Database in table "card" (separate for every used tuner card)...
    But I haven't tested if changing name to IP in this table will work for MP so you better do a backup before trying to manipulate the database directly...
     

    Javelin

    MP Donator
  • Premium Supporter
  • December 27, 2006
    43
    6
    Nth Richmond NSW
    Home Country
    Rather than manipulating a database to achieve my goal I have added the line "DISKSTATION 192.168.2.101" to the hosts file in windows which appears to essentially achieve what I needed. Use IP address of NAS in network path for Recorded TV

    This has predominantly fixed all the erratic behaviour with Recorded TV except that some scheduled recordings won't stop. When this happens it isn't even possible to stop the TVService without shutting down the PC.

    I have 2 sets of logs attached as well as some screen shots taken in services.msc. The first set of logs was collected while Mediaportal was still stuck on a recording. I then opened TV Server Configuration and navigated to Manual control where I tried to stop the service. This caused TV Server Configuration to hang for several minutes then crash.

    I then opened services.msc where TVService had a status of stopping. I also received an error message while in services.msc.
    Services.msc Error Message.PNG

    Servies.msc - TVService status.PNG

    I then generated the second set of logs.

    The recording that was stuck was Frasier.
     

    Attachments

    • MediaPortalLogs_28_05_18__18_45.zip
      3.2 MB · Views: 40
    • MediaPortalLogs_28_05_18__18_59.zip
      3.1 MB · Views: 39

    regeszter

    Retired Team Member
  • Premium Supporter
  • October 29, 2005
    5,335
    4,954
    Home Country
    Hungary Hungary
    Your logs are full of this. Try to fix that first. :)

    [2018-05-28 18:45:12,051] [Log ] [scheduler thread] [DEBUG] - DeleteRecordingOnDisk: '\\DISKSTATION\Media Centre\TV Recordings\ELEVEN\Everybody Loves Raymond\Everybody Loves Raymond - 2018-05-19_3.ts'
    [2018-05-28 18:45:12,051] [Log ] [scheduler thread] [DEBUG] - - deleting 'C:\ProgramData\Team MediaPortal\MediaPortal TV Server\thumbs\Everybody Loves Raymond - 2018-05-19_3.jpg'
    [2018-05-28 18:45:12,066] [Log ] [scheduler thread] [ERROR] - RecordingFileHandler: Error while deleting a recording from disk: Could not find a part of the path 'C:\ProgramData\Team MediaPortal\MediaPortal TV Server\thumbs\Everybody Loves Raymond - 2018-05-19_3.jpg'.
    [2018-05-28 18:45:12,066] [Log ] [scheduler thread] [INFO ] - diskmanagement: Delete episode TvDatabase.Channel Everybody Loves Raymond Saturday, May 19, 2018 10:16:07 AM
     

    Javelin

    MP Donator
  • Premium Supporter
  • December 27, 2006
    43
    6
    Nth Richmond NSW
    Home Country
    Okay, I haven't been able to spend any time on this lately due to work. Long story short The TV service just stopped working completely. Ended up doing a clean install of Mediaportal. Uninstalled MP removed all files & registry entries then reinstalled. Still have the same problem with scheduled recordings not stopping. Got two recording that have been going for close to 24 hours now. Its funny because some recording start and stop exactly when they're supposed to. Tried Mediportal 2. Have to say great work guys. Unfortunately it doesn't have episodes management for recorded TV which is a must for me so I'm stuck with MP1 for the time being.

    Logs attached.
     

    Attachments

    • MediaPortalLogs_03_06_18__17_02.zip
      3.5 MB · Views: 40

    Users who are viewing this thread

    Similar threads

    Thanks for the advice. Before trying it, I think i will try the slightly less drastic approach which mm recommended for the new message in this post. Wish me luck!
    Thanks for the advice. Before trying it, I think i will try the slightly less drastic approach which mm recommended for the new...
    For several days now, none of my scheduled tv recordings have been made, but there are no errors in the logs. NO channels are...
    Replies
    7
    Views
    1K
    "TV Server" can produce logs with various levels of detail. The level that has the most detail is DEBUG level, but this is not the default. So the first thing that you need to do is start "TV Server Config" and change the log level to DEBUG; see this page in the Wiki. Actually, I run my HTPC with the log level set to DEBUG all of the...
    "TV Server" can produce logs with various levels of detail. The level that has the most detail is DEBUG level, but this is not the...
    Hi Folks, Are there any TV recording logs available in MP2, and if so could someone let me know where to look? I have a weird...
    Replies
    1
    Views
    300
    Could be that a sudden powercut corrupts the database, or give all your pcs a new ipadres, or several more things that can break up a running mediaportal setup. Without the logs however, I don't have a clue on what exactly is wrong...
    Could be that a sudden powercut corrupts the database, or give all your pcs a new ipadres, or several more things that can break up...
    Hi there, I'm a happy long time user and am currently using MP 1.25. Up until now I had no issues with my setup. Yesterday...
    Replies
    1
    Views
    326
    Well it's been a couple of days and we've had no more unable to play errors .
    Well it's been a couple of days and we've had no more unable to play errors .
    I've just upgraded the motherboard, CPU, ram, boot drives and PSU in my TV Server (always on), and am now having intermittent...
    Replies
    8
    Views
    888
    Thank you for performing this test, and confirming @joecrow 's suspicion as to the cause of the problem. In principle the same problem exists with other EPG sources, such as the broadcast EPG that I use with DVB-T/T2. When a programme first appears in the EPG (7 days ahead of its broadcast time), some programmes have a generic...
    Thank you for performing this test, and confirming @joecrow 's suspicion as to the cause of the problem. In principle the same...
    TV Server 1.25. Windows 10. This has been an issue for many years, if not since inception, and I hoped it would be resolved...
    Replies
    10
    Views
    1K
    Top Bottom