[confirm] Recursive slideshow is not working in random (1 Viewer)

Svensk

MP Donator
  • Premium Supporter
  • December 21, 2012
    6
    6
    Germany Germany
    Country flag
    I have a heavy problem. For the moment I have 1.5.0 PR on my HTPC. When i start "Diashow - Alle Ordner -recursive slideshow" the random slideshow is a "chronicle slideshow" that means the program starts always with the oldest "ordner" file. It takes up to one hour at least until the program reach the newest picture "ordner". If I start recursive picture slideshow again, the program is starting with the same old file. This problem showed up for the first time with the 1.3.0 PR version. I hope you have or find a solution for this problem. Alternative could you make it possible to create picture playlists inside in MEPO as it is with music. Tanks a lot.
     

    catavolt

    Design Group Manager
  • Team MediaPortal
  • August 13, 2007
    12,800
    9,216
    Lanzarote
    Germany Germany
    Country flag
    Sorry, but I can´t confirm that issue.
    I organized my picture folders to have one parent folder "Bilder", this folder has 68 subfolders named differently (e.g. "Urlaub in xyz" or Bilder von xyz".
    If I´m in the view to see all those subfolders and press "Diashow (alle Ordner)", the slideshow ALWAYS starts with a random picture from a random folder and continues like that.
    Pls verify that your configuration is set to "Diashows in zufälliger Reihenfolge" in Settings -> Pictures -> Slideshow (see screenshot below).

    16-07-25.jpg
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,433
    10,254
    France
    France France
    Country flag
    Hi,

    Can you disable or remove : (HTPCInfoPlugin) ?
    Also i see a lot of fileexistentcache (maybe ou can disable it for testing) in MP CONFIG.

    But first can you try by starting MP in debug mode (it will run MP without all plugins and see if it's better).

    When working on Picture, the random slideshow for me start 1 hour after click on item (because it was list all folder and all items to create a sort of playlist).
    I change that to first load the first jpg find and when MP find a folder, it anaylse it etc. etc..

    With this new code, it take few sec to start compared to one hour.

    But for you it seems that it does the reverse (i don't understand why and that not logic lol)
     

    Svensk

    MP Donator
  • Premium Supporter
  • December 21, 2012
    6
    6
    Germany Germany
    Country flag
    Hi,
    thank for answer! I did remove : (HTPCInfoPlugin)! But I did not understand what you mean with "Also i see a lot of fileexistentcache (maybe ou can disable it for testing) in MP CONFIG". So I did nothing!
    However I send you the "simple" Debug report.
    Thanks an have a nice weekend.
     

    Svensk

    MP Donator
  • Premium Supporter
  • December 21, 2012
    6
    6
    Germany Germany
    Country flag
    Hi, ich habe heute folgendes gemacht: 1) komplette Deinstallation von MEPO - 2) Installation von 1.4.0 - Random funktioniert nicht -alles wie gehabt - 3) wieder komplette Deinstallation - 4) Installation von 1.3.0 Beta - Random funktioniert perfekt - 5) Upgrade auf 1.3.0 RC - Random funktioniert wieder nicht mehr - 6) wieder komplette Deinstallation - 7) wieder Installation von 1.3.0 Beta - Random funktioniert perfekt - 8) Upgrade auf 1.3.0 Final Version - Random funktioniert wieder nicht mehr! Was soll ich sonst noch tun? Einen Tipp?!! HG
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,433
    10,254
    France
    France France
    Country flag
    Tip will be able to reproduce the issue :)
    So i think, we need to have the same folder struture that you have.
    Could you test with less folder ? and see if it take time to start ?
    Another solution, will be to have your folder for testing. Surely something is wrong in code and lead to sort of loop but i can't reproduce it.

    Will try to look again your log but can you describe your folder structure ?

    like :

    C:\Pictures\1990\August\DAY1
    C:\Pictures\1990\August\DAY2
    etc. ?

    Thanks.
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,433
    10,254
    France
    France France
    Country flag
    But I did not understand what you mean with "Also i see a lot of fileexistentcache (maybe ou can disable it for testing) in MP CONFIG"..


    Like explain Catavolt (you can disable it from gui) and you can also disable from Mediaportal configuration tool :


    filecache.jpg
     

    Svensk

    MP Donator
  • Premium Supporter
  • December 21, 2012
    6
    6
    Germany Germany
    Country flag
    Many thanks for your interim report.

    I did the following:

    1) I totally removed MEPO 1.3.0 Beta and then I did a new installation of the 1.4.0 version

    2) The Condition that the new "Random" is functioned that all images are sorted in a big main folder and with other “subfolder”

    a. One main folder / E: All my pictures

    b. “subfolders” for the single years / started with 1950

    c. Other “subfolder” - the respective months / Jan. - Dec

    d. Other “subfolder” for the different activities during the single months

    3) Under this condition the new "Random" functions after the following principle

    a. There are always opened some folders in the background

    b. From these folders there are images shown in accidental order and after always returning resort at these folders

    c. After some time another folder is opened in the background and then the images of this folder flow in onto the Random show.

    d. After which principle this runs off I could not understand - but because it is - and with so many photos (60.000) - a very protracted procedure. This works in a sort of “chronicle way” this means in reality perhaps it 4 or 5 hours till the system reach the year 2013!! I never tested it, but I guess it will!!!!

    4) In comparison with that this was better up to the version 1.3.0 Beta used Random procedures around a lot; it was absolutely insignificant how many big main folders were it and how many “subfolder”. This Random was really a Random. It was a coloured kaleidoscope from my 60,000 photos. Why was this Random procedures suddenly changed by the version 1.3.0 Beta to version 1.3.0 PR? Can this not be cancelled then?

    5) Then I got another idea – I pushed the bottom in “MEPO Configuration under “Picture database / Update Database from selected share”. The total amount of my entire picture (60,000) was loaded into the file “picture – No 1 – 99”.

    Before I started “recursive slideshow / or in German “Diashow alle Ordner) I used the bottom “View / File structure” and picked “date” and then I started the recursive slideshow. Under these conditions the slideshow works perfectly.

    6) Of it independently would suggest being able to create the possibilities also picture-playlists as it is already possible with Music.

    Manythanks!

    Svensk
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,433
    10,254
    France
    France France
    Country flag
    Hi,

    Thanks for information :)
    I think i start to got it and i think i misunderstand the issue lol.

    I was thinking that it take hour to display the first picture after running Recursive slideshow.
    But in fact it start directly but not the order you want right ?

    I rework that part because before (depend of how is stored your picture with subfolder), for me it was taking quite 45 min to start to display the first picture, you imagine that, wait 45 min before see the first picture ? lol

    About picture-playlist, it's surely a good idea but i don't think so this will be implemented. (by me @ least but if someone want to try to code it, it's welcome).

    So i will read again your post to be sure that i fully understand you (you know i'm french :p)
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    ajs [fixed] 5029: Add the ability to choose the type of pause for designers in the slideshow MediaPortal 1 4
    J Slideshow Screensaver Feature Requests 0
    J Screensaver Slideshow? General 7
    Rob Hexenmeister ITV Player still not working for me OnlineVideos 2
    V Do you have to have a smart tv for it to work? Newcomers Forum 4
    M WTV Files does not play on client, MPEG files works well General 0
    D Does Schedules Direct work with mp 1.24? General Support 3
    J [solved] Blu-ray disc playback does not work. Bugreports 13
    P MP2: US user, OTA - can NOT get SchedulesDirect plugin to work on MP1 or MP2 --> how do I get OTA schedule? General 5
    ratata [solved] Can't get two virtual IPTV cards to work side by side... General Support 6
    S TV-Server MP1 - Automatic search doesn't work Installation, configuration support 2
    T [solved] Green Button start MP not working....but box ticked in config. General Support 1
    mickb [solved] Mediaportal Stops working General Support 5
    C Importer works super slow My TVSeries 5
    D [solved] Movie artwork download stopped working Submit: Bug Reports 9
    A 1.24.0 CD art grabber not working in Shares view 1.24 Pre Release 17
    RoChess Random GPU crash leads to MePo restart, but works fine afterwards MediaPortal 1 14
    Dark Eyes Updated to Windows 10, now TVServer won't work Installation, configuration support 1
    D [solved] EPG Buddy for MP2 - Does it work? General 5
    D Please help with getting Schedules Direct to work Newcomers Forum 10
    B MP 1.23 First time click TV or Recorded TV fails, 2nd ... it will work General Support 5
    M MP 2.2.3 Unable to play .ts recordings and MediaPortal stops working for TV viewing General 31
    rsbrux IR has stopped working Remotes 4
    thepahakurki TVDB import not working My TVSeries 3
    Rob Hexenmeister Work arounds for an alternative home screen General Support 3
    Similar threads

























    Top Bottom