MP2 - V2.3.2 MP2 - V2.3 [fixed] Reimport Recording Has Dead Interface (1 Viewer)

Tomkon

MP Donator
  • Premium Supporter
  • January 27, 2021
    37
    1
    Home Country
    United States of America United States of America
    Country flag
    MP2 Version
    2.3.1
    Before you create this bug report:
    1. Make sure that your system (Windows, codecs and drivers) is up to date, matching the Requirements and you've filled in your System Specs.
    2. Have a look at our MediaPortal Wiki! Maybe the solution is already there.
    3. Have a look at our Jira (Bug and Issue Tracker)and the threads in this section, maybe your problem is already known.
    4. Search the forums for your problem, it's very likely that someone else already encountered the same problem.

    Please always include log files with your Bug Report!
    Check out our Wiki: Bug Reports and Log Files

    ==================================================================

    Describe the Problem you encounter as detailed as possible! "It does not work" won't help the team to understand the problem.
    Description: Running MP2.3.2. The Reimport menu screen has no option to select a menu item.
    I am using the WMC commands with a universal remote, no mouse & keyboard used.







    Describe as detailed as possible the steps that are required to encounter the issue. This info is critical for the team to understand the problem.
    Steps to Reproduce:
    1) Go to Recordings
    2) Highlight a recording
    3) Use "Info" button on remote to bring up "Media item actions" menu
    4) Select "Reimport" and a "Select the correct match" menu appears
    5) You can use the up/down buttons to select "Auto Match" or "Manual Search" but nothing happens when selected by using remote "Ok" button
    6) Use remote "Exit" button to close menu








    .
     

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,432
    2,641
    Stuttgart
    Home Country
    Germany Germany
    Country flag
    Reimport is a function to fix incorrectly imported items. It uses online sources to find a match according to the media item name. I guess that the name of your media item has simply no online match.
    There are no log files, so I can not say more or try to reproduce the issue. I do not know the name of your recording.
     

    Tomkon

    MP Donator
  • Premium Supporter
  • January 27, 2021
    37
    1
    Home Country
    United States of America United States of America
    Country flag
    The name of the recording is "Sunday Today With Willie Geist". It's a NBC weekly news program that has been on for years, I would assume there would be some online info available. I have tried other recordings and the same thing occurs.

    So the "Select the correct match" interface might be running but does not indicate anything or close when it is done? I really don't think it is doing anything because there is no change in the interface, I can select Auto and instantly use the up/down keys to move to the other selection. I would assume that if it was doing some processing you would see that quick flicker when some apps launch a procedure, or the interface would not respond for a second or two while processing.

    The only reason I was trying to use Reimport was to see if that would allow me to delete the recording (separate bug report).
     

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,432
    2,641
    Stuttgart
    Home Country
    Germany Germany
    Country flag
    The name of the recording is "Sunday Today With Willie Geist". It's a NBC weekly news program that has been on for years, I would assume there would be some online info available. I have tried other recordings and the same thing occurs.
    Which online sources do you have enabled? I searched a few like "TVDB" and nothing is found for this show. The online sources are focused on movies and series, not for TV-shows or similar. For recordings the best way to have good data is to set up the EPG I think.
    I'm not recording anything myself, just my thoughts.

    So the "Select the correct match" interface might be running but does not indicate anything or close when it is done? I really don't think it is doing anything because there is no change in the interface, I can select Auto and instantly use the up/down keys to move to the other selection. I would assume that if it was doing some processing you would see that quick flicker when some apps launch a procedure, or the interface would not respond for a second or two while processing.
    For manual search you need to find the ID from the online source anyway, which seems not to be available for this show.
    For auto search we might improve it in a way, that "no result" is displayed, if a search is completed without result. @henso, for movies and episodes I see always "searching" with the spinning circle at first. For recordings I do not see it, is it really searching?
     

    Tomkon

    MP Donator
  • Premium Supporter
  • January 27, 2021
    37
    1
    Home Country
    United States of America United States of America
    Country flag
    I went to "Series import settings", could not find a setting for TV specifically. Then to "Online sources to allow during import", and Fanart.tv & TVDB.com are selected.

    I then went and checked that Blue Bloods & Blacklist had entries at TVDB, which they do. I then checked the Reimport function for those recordings and same thing happened, nothing.

    Suggestion: Adding an Ok button to interface like many of MP2 other interfaces would help, and displaying what was found or a spinning circle would be helpful too.
     

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,432
    2,641
    Stuttgart
    Home Country
    Germany Germany
    Country flag
    I then went and checked that Blue Bloods & Blacklist had entries at TVDB, which they do. I then checked the Reimport function for those recordings and same thing happened, nothing.
    Yeah, it seems generally not to work for recordings, I can confirm it meanwhile. @henso might take a look when he finds time.
    The problem could be, that recordings can be episodes or movies, so the reimporter does not know where to look and which settings to consider (we have seperate online scrapper settings for series and movies).

    You could try to copy the recording to the series import folder once and try the reimport function.

    Suggestion: Adding an Ok button to interface like many of MP2 other interfaces would help, and displaying what was found or a spinning circle would be helpful too.
    The spinning circle is immediatly coming for movies and series. The OK button is intentially not there. While typing text the search results are updated and you can pick the result out of the list without writing the full name (try once with movies e.g.).
     

    henso

    Development Group
  • Team MediaPortal
  • February 16, 2012
    2,331
    817
    Home Country
    Denmark Denmark
    Country flag
    For recordings I do not see it, is it really searching?
    If there is no episode information in the recording (meaning no episode information in the EPG), then no search would be done. I updated it, so now it will search for movies automatically but if there was no episode information available in the EPG, a manual search is now possible.
     

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,432
    2,641
    Stuttgart
    Home Country
    Germany Germany
    Country flag
    @Tomkon
    The reported issue was fixed. The fix will be part of next release. If you are interested I might create a test version and provide the link by message.
     

    Users who are viewing this thread

    Similar threads

    Have you checked if any anti-virus program could have locked the file so it can't be deleted?
    Have you checked if any anti-virus program could have locked the file so it can't be deleted?
    Before you create this bug report: Make sure that your system (Windows, codecs and drivers) is up to date, matching the...
    Replies
    6
    Views
    746
    Thanks @high, bug report options look good now.
    Thanks @high, bug report options look good now.
    Before you create this bug report: Make sure that your system (Windows, codecs and drivers) is up to date, matching the...
    Replies
    8
    Views
    524
    Workaround:- Use the close "x" button in the top right hand corner of the screen and MP2 should restart without need to reboot.
    Workaround:- Use the close "x" button in the top right hand corner of the screen and MP2 should restart without need to reboot.
    Before you create this bug report: Make sure that your system (Windows, codecs and drivers) is up to date, matching the...
    Replies
    2
    Views
    443
    Just repeated the fast forward freeze issue and captured the logs.
    Just repeated the fast forward freeze issue and captured the logs.
    Before you create this bug report: Make sure that your system (Windows, codecs and drivers) is up to date, matching the...
    Replies
    1
    Views
    462
    I remember that the home content was not always up to date. One situation I think can cause this is during import as the list only update after the import is completed. Maybe we could have the force behavior during import only and after it completes the home content should always be up to date?
    I remember that the home content was not always up to date. One situation I think can cause this is during import as the list only...
    Before you create this bug report: Make sure that your system (Windows, codecs and drivers) is up to date, matching the...
    Replies
    6
    Views
    649
    Top Bottom