Reproducable Crash (1 Viewer)

Branksome

MP Donator
  • Premium Supporter
  • February 1, 2012
    92
    18
    84
    Bournemouth
    Home Country
    United Kingdom United Kingdom
    When I try and schedule a recording on (mainly) BBC One HD, MePo will crash. Presumably something has become corrupted

    Sequence: EPG, Select BBC One HD, scroll down list and select a programme, press OK to record, when button changes to Don't Record press back and back again and Crash! ("MediaPortal has had to close.."

    Also, instead of pressing OK to record, I just press back, the same thing will happen. I have also tried using a MePo client on my WinXP Netbook and the same thing happens to MePo on the Netbook

    I first encountered a problem on Monday when I noticed that the scheduled list of programmes for that day was not quite right. It looked to me as if the broadcaster might have made a schedule change. I deleted the entry and tried to schedule the program ("Not the 9o'clock news extra") again. MePo did not crash. It appeared to behave correctly except that the programme would not appear in the list of scheduled programmes in spite of trying several times. Instead I scheduled the recording successfully on BBC One (non-HD)

    I attach the logs. By the way, I have the Titan skin, MP 1.3

    Tom
     

    Branksome

    MP Donator
  • Premium Supporter
  • February 1, 2012
    92
    18
    84
    Bournemouth
    Home Country
    United Kingdom United Kingdom
    Thanks mm

    Now this is embarrassing. Having struggled with this problem for 2 days I can now no longer reproduce it. And I am sorry to have taken up anyone's time. Presumably this was some sort of data base corruption which has cleared itself

    Tom
     

    Branksome

    MP Donator
  • Premium Supporter
  • February 1, 2012
    92
    18
    84
    Bournemouth
    Home Country
    United Kingdom United Kingdom
    An error that preceeded the crash I had last week has happened again. This involves trying to schedule a recording of the same programme -"Have I got news for you extra" on BBC One HD. (In my first entry above I gave the wrong name to the programme). Before I put MePo into debug mode, I would go through the process of setting the recording but it would not show up in the Schedule of Recordings. I then put MePo into debug mode and this time when I tried to schedule the recording it indicates that this programme is already scheduled for recording (ie the record button is already set to Don't Record). However, the programme is still not listed in the schedule of recordings

    What seemed to happen last week was that the difficulty in scheduling a programme on BBC One HD became more persistent over a couple of days and then led to a crashing each time. But then the problems went away

    I attach the logs created as a result of running in debug mode

    Tom
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,577
    8,223
    Home Country
    New Zealand New Zealand
    Hello Tom

    From what I can see in the log files, MP seems to think you have a series recording set up:
    2013-05-04 14:04:35.566292 [Debug][MPMain(1)]: TVProgammInfo_OnRecordProgram - programm = Have I Got a Bit More News for You(ID:2521089) on 1090 06/05/2013 23:00:00 - 06/05/2013 23:45:00
    2013-05-04 14:04:35.598294 [Debug][MPMain(1)]: TVProgramInfo.CreateProgram: program = Have I Got a Bit More News for You(ID:2521089) on 1090 06/05/2013 23:00:00 - 06/05/2013 23:45:00
    2013-05-04 14:04:35.602294 [Debug][MPMain(1)]: TVProgramInfo.CreateProgram - series schedule found ID=1804, Type=2
    2013-05-04 14:04:35.604294 [Debug][MPMain(1)]: - schedule= Have I Got a Bit More News for You on 1090 08/04/2013 22:35:00 - 08/04/2013 23:20:00 ID=1804
    2013-05-04 14:04:36.098322 [Debug][MPMain(1)]: TVProgramInfo.CreateProgram - conflicts.Count = 0 - notViewable.Count = 0
    2013-05-04 14:04:36.100322 [Debug][MPMain(1)]: TVProgramInfo.CreateProgram - UnCancleSerie at 06/05/2013 23:00:00
    2013-05-04 14:04:36.296334 [Debug][(8)]: PS: Inspecting WakeableWakeupPlugins:
    2013-05-04 14:04:36.488345 [Debug][(8)]: PS: Inspecting WakeableStandbyPlugins:
    2013-05-04 14:04:36.491345 [Debug][(8)]: PS: Check if user interface is idle
    2013-05-04 14:04:36.495345 [Debug][(8)]: PS: User interface is idle
    2013-05-04 14:04:36.497345 [Debug][(8)]: PS: Check whether the next event is almost due
    2013-05-04 14:04:36.750360 [Debug][MPMain(1)]: TVProgammInfo_OnRecordProgram - programm = Have I Got a Bit More News for You(ID:2521089) on 1090 06/05/2013 23:00:00 - 06/05/2013 23:45:00
    2013-05-04 14:04:36.753360 [Debug][MPMain(1)]: TVProgammInfo.CancelProgram - programm = Have I Got a Bit More News for You(ID:2521089) on 1090 06/05/2013 23:00:00 - 06/05/2013 23:45:00
    2013-05-04 14:04:36.756360 [Debug][MPMain(1)]: - schedule = Have I Got a Bit More News for You on 1090 08/04/2013 22:35:00 - 08/04/2013 23:20:00 ID=1804
    2013-05-04 14:04:36.758360 [Debug][MPMain(1)]: ProgramID = 2521089 ScheduleID = 1804

    On the TV Server side, the schedule seems to have been created correctly too:
    2013-05-04 14:04:35.612294 [MPMain(1)]: GetConflictingSchedules: Schedule = Have I Got a Bit More News for You on 1090 06/05/2013 23:00:00 - 06/05/2013 23:45:00 ID=0
    2013-05-04 14:04:35.627295 [MPMain(1)]: GetConflictingSchedules: Cards.Count = 5
    2013-05-04 14:04:35.670298 [MPMain(1)]: AssignSchedulesToCard: schedule = The Graham Norton Show on 1090 06/05/2013 23:45:00 - 07/05/2013 00:30:00 ID=1924
    2013-05-04 14:04:35.684299 [TvClient-TvHome: HeartBeat transmitter thread(11)]: RemoteControl - Connected
    2013-05-04 14:04:35.745302 [MPMain(1)]: AssignSchedulesToCard: free on card 1, ID = 5
    2013-05-04 14:04:35.771304 [MPMain(1)]: AssignSchedulesToCard: schedule = Have I Got a Bit More News for You on 1090 06/05/2013 23:00:00 - 06/05/2013 23:45:00 ID=0
    2013-05-04 14:04:35.786304 [MPMain(1)]: AssignSchedulesToCard: card 1, ID = 5 has schedule = The Graham Norton Show on 1090 06/05/2013 23:45:00 - 07/05/2013 00:30:00 ID=1924
    2013-05-04 14:04:36.084321 [MPMain(1)]: AssignSchedulesToCard: free on card 1, ID = 5

    So I'm a bit confused, and wondering if it is possible that this is a schedule display issue.

    Are you able to grab a screenshot of the various steps?

    mm
    PS: there was no crash in the above test, right? I didn't see any evidence of a crash, but just wanted to make sure.
     

    Branksome

    MP Donator
  • Premium Supporter
  • February 1, 2012
    92
    18
    84
    Bournemouth
    Home Country
    United Kingdom United Kingdom
    Thanks mm for responding

    I also thought that I had previously set up a series recording but when it was not displayed on the scheduled list (last week and this) I assumed I was mistaken and tried to set up a one off recording

    You are correct there is currently no crash. I am guessing but last week when I kept trying over and over to set up a recording for this programme this might have created a situation resulting in a reproducible crash. I can confirm that the HD recording did not happen

    I attach screen shots. There is something wrong with the screen that displays the list of incidences of the programme. There are a number of different regional versions of BBC One HD and quite a lot of regional versions of the standard definition version of BBC One. But looking at the display, most of the station names are not being displayed

    I also had a problem with possibly the only other programme I had set up as a series recording - The Graham Norton Show. This did appear in the list of scheduled recordings but for the last two weeks it did not record. I have now cancelled the series recording and scheduled a one off recording of the repeat on Monday night.

    The other programme (Not the 9 o'clock news) should appear on the scheduled list above The Graham Norton Show for tomorrow night but as you can see it is not appearing. I can confirm that last week the recording did not take place
     

    Attachments

    • Record1.PNG
      Record1.PNG
      837.8 KB
    • Record2.PNG
      Record2.PNG
      832.7 KB
    • Record3.PNG
      Record3.PNG
      858.7 KB

    Users who are viewing this thread

    Top Bottom