[Resolved] Stuttering on HD channels (direct profile) (1 Viewer)

mrmojo666

MP Donator
  • Premium Supporter
  • January 24, 2006
    601
    180
    Turin
    Home Country
    Italy Italy
    Hi,

    i want to share my experience and eventually find a way to resolve my problem.

    Firstly i want to let you know that i can't recompress HD tv stream due of my poor tvserver cpu, so i've created a new streaming profile DIRECT also for android.
    Direct profile working perfect in web mode using browser on windows pcs. So i can exclude problems with wifi .

    Problems are coming when i try to watch tv (specially hd but also sd sometimes) using ampdroid.

    Sd channels are working ok using internal android player
    HD channels stutter and i get no audio using internal player (it doesn't support AC3 sound)

    i tried to play using external player mxplayer or vplayer.
    both give me stutter on HD channels and recording but audio is OK
    I thought my zenithink tablet is not powerful enought to manage HD streams but.....

    if i try to play the same recording files directly using mxplayer from a network share they are smooth like silk (so it is not a tablet hw problem, or else tablet side)

    So i think there is a problem with ampdroid or eventually with the mpextend streaming server with high bitrate streams.

    How can i proceed to understand where the problem is ?

    thank you
     
    Last edited:

    DieBagger

    Retired Team Member
  • Premium Supporter
  • September 11, 2007
    2,516
    1,276
    38
    Austria
    Home Country
    Austria Austria
    Hi,

    i want to share my experience and eventually find a way to resolve my problem.

    Firstly i want to let you know that i can't recompress HD tv stream due of my poor tvserver cpu, so i've created a new streaming profile DIRECT also for android.
    Direct profile working perfect in web mode using browser on windows pcs. So i can exclude problems with wifi .

    Problems are coming when i try to watch tv (specially hd but also sd sometimes) using ampdroid.

    Sd channels are working ok using internal android player
    HD channels stutter and i get no audio using internal player (it doesn't support AC3 sound)

    i tried to play using external player mxplayer or vplayer.
    both give me stutter on HD channels and recording but audio is OK
    I thought my zenithink tablet is not powerful enought to manage HD streams but.....

    if i try to play the same recording files directly using mxplayer from a network share they are smooth like silk (so it is not a tablet hw problem, or else tablet side)

    So i think there is a problem with ampdroid or eventually with the mpextend streaming server with high bitrate streams.

    How can i proceed to understand where the problem is ?

    thank you
    If the direct stream is not working with the external player the issue is most likely on the MPExtended side... Hows the cpu usage on the server during streaming? You can also try the "Direct" profile (not "vlc direct"), that just reads the file without any usage of vlc/ffmpeg -> no seeking.
     

    mrmojo666

    MP Donator
  • Premium Supporter
  • January 24, 2006
    601
    180
    Turin
    Home Country
    Italy Italy
    Hi,

    i want to share my experience and eventually find a way to resolve my problem.

    Firstly i want to let you know that i can't recompress HD tv stream due of my poor tvserver cpu, so i've created a new streaming profile DIRECT also for android.
    Direct profile working perfect in web mode using browser on windows pcs. So i can exclude problems with wifi .

    Problems are coming when i try to watch tv (specially hd but also sd sometimes) using ampdroid.

    Sd channels are working ok using internal android player
    HD channels stutter and i get no audio using internal player (it doesn't support AC3 sound)

    i tried to play using external player mxplayer or vplayer.
    both give me stutter on HD channels and recording but audio is OK
    I thought my zenithink tablet is not powerful enought to manage HD streams but.....

    if i try to play the same recording files directly using mxplayer from a network share they are smooth like silk (so it is not a tablet hw problem, or else tablet side)

    So i think there is a problem with ampdroid or eventually with the mpextend streaming server with high bitrate streams.

    How can i proceed to understand where the problem is ?

    thank you
    If the direct stream is not working with the external player the issue is most likely on the MPExtended side... Hows the cpu usage on the server during streaming? You can also try the "Direct" profile (not "vlc direct"), that just reads the file without any usage of vlc/ffmpeg -> no seeking.

    do you mean rtsp mode in ampdroid ?

    the strange part is that the direct profile is smooth when it is used in webmpextend page.

    On the server the cpu is almost free , like i'm watching tv by normal MP
     

    DieBagger

    Retired Team Member
  • Premium Supporter
  • September 11, 2007
    2,516
    1,276
    38
    Austria
    Home Country
    Austria Austria
    do you mean rtsp mode in ampdroid ?

    the strange part is that the direct profile is smooth when it is used in webmpextend page.

    On the server the cpu is almost free , like i'm watching tv by normal MP

    No, in the xml file where the streaming profiles are defined you'll find a "direct" streaming profile... Add a target "android" and it will show up on your device as profile...
     

    mrmojo666

    MP Donator
  • Premium Supporter
  • January 24, 2006
    601
    180
    Turin
    Home Country
    Italy Italy
    do you mean rtsp mode in ampdroid ?

    the strange part is that the direct profile is smooth when it is used in webmpextend page.

    On the server the cpu is almost free , like i'm watching tv by normal MP

    No, in the xml file where the streaming profiles are defined you'll find a "direct" streaming profile... Add a target "android" and it will show up on your device as profile...

    exactly what i did to get direct profile on my android device. i made a copyof the lines of direct profile for web and changed to android .
     

    mrmojo666

    MP Donator
  • Premium Supporter
  • January 24, 2006
    601
    180
    Turin
    Home Country
    Italy Italy
    tested again:
    1) Hd tv recording played by mxplayer from net share
    video smooth audio ok, server cpu less than 5%
    2) Hd tv recording played by mxplayer from ampdroid vlc direct profile
    video choppy and pixelation, sound choppy and on server cpu is over 70% and vlc wrapper dind't stop after ampdroid stop playing
    3) HD tv recording played by mxplayer from ampdroid Direct profile (created from web direct profile)
    video choppy and pixelalation, sound choppy and on server cpu under 10%
    also i tried to modify in streaming profliles xml file the max bandwith node to 15000 , but nothing changed

    that's all

    thankyou for any help
     

    mrmojo666

    MP Donator
  • Premium Supporter
  • January 24, 2006
    601
    180
    Turin
    Home Country
    Italy Italy
    HI,
    i was wondering if you are buffering the stream on sd or other place before to send to external player and if you don't do that when using internal player. i've read in the ampdroid code there is a class named DownloadStreamToSDCard.
    I'm asking because i see when i use the internal player i get no audio (because of lack of decoding ac3) but hd channels video is smooth.

    Maybe could be a performance problem of my sd card or internal flash memory of my zenithink tablet.

    thank you
     

    DieBagger

    Retired Team Member
  • Premium Supporter
  • September 11, 2007
    2,516
    1,276
    38
    Austria
    Home Country
    Austria Austria
    HI,
    i was wondering if you are buffering the stream on sd or other place before to send to external player and if you don't do that when using internal player. i've read in the ampdroid code there is a class named DownloadStreamToSDCard.
    I'm asking because i see when i use the internal player i get no audio (because of lack of decoding ac3) but hd channels video is smooth.

    Maybe could be a performance problem of my sd card or internal flash memory of my zenithink tablet.

    thank you
    No, that method is for debugging purposes...
     

    Users who are viewing this thread

    Top Bottom