[WiP] Rework of SQLite wrapper (1 Viewer)

Sebastiii

Development Group
  • Team MediaPortal
  • November 12, 2007
    16,434
    10,256
    France
    France France
    Country flag
    I'm not @ home so i have tested on my laptop with most on MyVideo, i will try MP TvSeries :)
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,434
    10,256
    France
    France France
    Country flag
    I have made some test and configuration crash when movpic scan my folder (related to sql interop) :(
     

    DieBagger

    Retired Team Member
  • Premium Supporter
  • September 11, 2007
    2,516
    1,276
    36
    Austria
    Austria Austria
    I cannot confirm this, all is working well with your binaries (only databases.dll and sqlite ones) on a 1.2.3 install...

    I didn't do any stress-testing yet but i strongly suspect that it will greatly improve stability when it comes to multiple access / nas access.
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,434
    10,256
    France
    France France
    Country flag
    Ok maybe the bin is not enough lol
    I have installed by the installer and it's here i get the error, i will retry on fresh install again.
    Thanks.

    Just get the crash (with only bin change)

    Code:
    >    ntdll.dll!_ZwRaiseException@12()  + 0x12 bytes   
        ntdll.dll!_ZwRaiseException@12()  + 0x12 bytes   
        mscorwks.dll!operator new[]()  + 0x25 bytes   
        ntdll.dll!_RtlEnterCriticalSection@4()  + 0x16a38 bytes   
        SQLite.Interop.dll!7353801b()   
        [Frames below may be incorrect and/or missing, no symbols loaded for SQLite.Interop.dll]   
        SQLite.Interop.dll!7353b2e4()   
        mscorwks.dll!Thread::DecPreventThreadAbort()  + 0x6 bytes   
        mscorwks.dll!CRWLock::StaticPrivateDestruct()  + 0x153 bytes
     

    DieBagger

    Retired Team Member
  • Premium Supporter
  • September 11, 2007
    2,516
    1,276
    36
    Austria
    Austria Austria
    I think this only happens on x64 environments... On the x64 htpc I also had issues, on the x86 notebook everything worked fine...
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    CyberSimian [Action Required] Rework TV/Radio recordings screen MediaPortal 1 23
    ajs Shared-Cache Mode for SQLite DBs... MediaPortal 1 2
    J Database schema General 0
    Similar threads



    Top Bottom