[Bug] RTSP Issue : Radio Multi Seat (French Provider : FREE ) (1 Viewer)

azzuro

Test Group
  • Team MediaPortal
  • May 10, 2007
    9,914
    5,563
    France - IDF
    Home Country
    France France
    JIRA MP1-4153

    MediaPortal Version: 1.4.0 Pre-Release

    Description
    2. radio rtsp stream don't work with Dedicated server

    @EdG found bug when Radio (RTSP provider) is used with Dedicated server + Client (multi-seat) only, audio is played 2-3 sec, after no sound ...
    Ts reader from 1.4. pre release
    Log Server Radio 1 + dump.zip
    LOG RADIO CLIENT 1.zip

    Edit : also tested with Tsreader073 : same issue
    log Server Radio 2 - tsreader073.zip
    LOG RADIO CLIENT 2 tsreader073.zip
    original Thread :
    https://forum.team-mediaportal.com/threads/m-4441-rtsp-issue-french-provider-free.118930/


    Steps to Reproduce:
    Start Radio in multi-seat with RTSP Radio stream ( Provider tested : Free.fr)

    Files for TEST :
    M3u FREEBOX TEST FILES.rar
    MPIPTVSourceIni.zip

    RTSP Stream for test:
    http://download.wavetlan.com/SVV/Media/RTSP/darwin-index.htm
    Tweaks :
    Clean Log command.rar : Command line for Stop tvservice, clean all log MP + Tv server, restart Tv service (need Admin rights for work)
    stop-restart tv service.rar Command line for Stop / restart tvservice but need User Action for restart Tvservice
     

    Attachments

    • MPIPTVSourceIni.zip
      1.1 KB
    • M3u FREEBOX TEST FILES.rar
      6.5 KB
    • Clean Log command.rar
      222 bytes
    • stop-restart tv service.rar
      136 bytes
    Last edited:

    azzuro

    Test Group
  • Team MediaPortal
  • May 10, 2007
    9,914
    5,563
    France - IDF
    Home Country
    France France
    • Thread starter
    • Moderator
    • #2
    Last test from PM
    INFORMATION : I DON'T HAVE RE-SCANNED, ONLY TRY TO PLAY CHANNEL IN DATABASE
    ALLTEST IS LIVE STREAMING

    I. SingleSeat
    SingleSeat Radio dump .rar
    SingleSEAT.zip
    1.RADIO :
    nothing when start radio channel

    2.TV CHANNEL
    - Slow baudrate (AAC) : start with sound bug (tsreader issue?!?)
    - Medium baud (MPEG-L2) : play fine
    - HD (AAC) : start with sound bug (tsreader issue?!?)

    II. Dedicated + Client
    dedicated server.zip
    dedicated radio dump.rar
    client 1st test.zip
    client 2nd test TV + RADIO.zip
    1.RADIO :
    1st test : trying to start Radio : MP no longer responds
    2nd test : No possible to read stream

    2.TV CHANNEL
    - Slow baudrate (AAC) : start with sound working (DIVX AAC codec)
    - Medium baud (MPEG-L2) : play fine
    - HD (AAC) : start and play with artefact (maybe Wifi limite)

    TESTED WITH GEORGIUS MP-IPTV FILTER
    Maybe there is problem with data in stream. I created filter version which removes from stream everything what doesn't have specified allowed PIDs (of course, except reserved PIDs and NULL packets). Try attached version, first on single-seat system, then on MP client (live and recorded stream).​
    Fichiers attachés:
    MPIPTVSource.zip >>> don't use this, search on next post (#3) for last Filter
     
    Last edited:

    georgius

    Retired Team Member
  • Premium Supporter
  • October 31, 2010
    1,376
    654
    Bratislava
    Home Country
    Slovakia Slovakia
    TESTED WITH GEORGIUS MP-IPTV FILTER
    Maybe there is problem with data in stream. I created filter version which removes from stream everything what doesn't have specified allowed PIDs (of course, except reserved PIDs and NULL packets). Try attached version, first on single-seat system, then on MP client (live and recorded stream).​
    Fichiers attachés:
    Use attached filter version, previous one doesn't preserve PCR in stream which leads that channel wasn't detected or is not playable.
     

    Attachments

    • MPIPTVSource.zip
      156.4 KB

    EdG

    Portal Member
    April 8, 2012
    12
    6
    45
    Home Country
    France France
    Hello georgius, hello azzuro and MP team guys

    I will test this evening. At this time I can't because still at work.
     
    Last edited:

    georgius

    Retired Team Member
  • Premium Supporter
  • October 31, 2010
    1,376
    654
    Bratislava
    Home Country
    Slovakia Slovakia
    Hello,



    So here are the logs for the latest mpiptvsource



    /*------- 1 --------*/

    I tried first on MP server + MP client on the same pc :

    server logs : logs_server_for_single_seat_FREE_TV_RADIOS.zip

    MP client logs : logs_client_1_single_seat.zip


    When I started MP client, it first starts on my dvb-t.

    Then I swiched on DVB-IP filter for a rtsp channel from FREE (only SD because cannot have HD channel due to my poor ISP bitrate) => it works good

    Then I tried several rtsp radios from FREE.

    It works good, but i tried to swich radio channel => OK, I can hear radio except that at the 4th radio switch, the MP server shutdown (bug ?).



    NB : On server configuration, when i tried to click on "preview" button for a radio channel, nothing happens (no preview windows to hear radio) and the server stops.



    /*------- 2 --------*/I tried then on MP dedicated server + MP clien on another pc :

    server logs : logs_dedicated_server_FREE_TV_RADIOS.zip


    MP client logs : logs_client_2_with_dedicated_server.zip


    On the 2nd client, I tried first a tv rtsp channel from FREE => it works good again

    Then I tried a rtsp radio channel from FREE => radio sound for 2-3 seconds then nothing

    When I tried to switch to another radio channel, the server shutdown (bug again ?)





    My hardware configuration is the following :

    MP server + 1st MP client installed on WinXP - core i5

    2nd MP client installed on WinXP - Athlon II X2
     

    georgius

    Retired Team Member
  • Premium Supporter
  • October 31, 2010
    1,376
    654
    Bratislava
    Home Country
    Slovakia Slovakia
    @EdG, can you post complete logs from TV server (complete I mean that you use Export all currently present logs option in MediaPortal Debug-Mode)? The crash message of TV server should be logged in application eventlog.
     

    azzuro

    Test Group
  • Team MediaPortal
  • May 10, 2007
    9,914
    5,563
    France - IDF
    Home Country
    France France
    • Thread starter
    • Moderator
    • #7
    system spec : Workstation


    I. SingleSeat

    1.RADIO :
    Listen : Working
    Record : don't work, have same issue as multi-seat client, the recorded channel play 2-3 sec and stop(crash)

    PS : DRR is activated : Start Radio channel change Refresh rate of screen / Stop playing : re-change R-R :mad: (@Sebastiii) need open her own thread
    PS2 : during STOP playing/record Radio channel, Tv serveur crash with your last commit.

    2.TV CHANNEL
    - Slow baudrate (AAC) : OK

    My next test is with the last testing build
     

    Attachments

    • single seat Radio TSreader073.zip
      274 KB
    • Recorded TV.rar
      2.1 MB
    • radio dump.rar
      2.7 MB

    azzuro

    Test Group
  • Team MediaPortal
  • May 10, 2007
    9,914
    5,563
    France - IDF
    Home Country
    France France
    • Thread starter
    • Moderator
    • #8
    system spec : Workstation
    MP Build : 1.4 2013-05-14
    Step For install filter :

    CMd.exe net stop tvservice
    copy-paste Filter in TVServeur folder
    CMD.exe net start tvservice

    Nothing else
    Tv-setup no started / only MP

    I. SingleSeat

    1.RADIO :
    Listen : Working
    Record : don't work, have same issue as multi-seat client, the recorded channel play 2-3 sec and stop(crash)
    Now Working

    PS2 : during STOP playing/record Radio channel, Tv serveur crash with your last commit.
    Now Working
    PS3 : @Developers why Tv Record files appear in Radio record menu?

    Concluse since previous post :
    bad installation of MPIPTV filter ?!?

    2.TV CHANNEL
    - Slow baudrate (AAC) : OK

    Next test multi seat with old MP build and newer build
     

    Attachments

    • dump Radio+tv.rar
      11.6 MB
    • MP log Build 2013-05-14 - filter 2013-05-13.zip
      313 KB
    • Recorded TV-Radio.rar
      3.6 MB

    EdG

    Portal Member
    April 8, 2012
    12
    6
    45
    Home Country
    France France
    Here are my logs with Export all currently present logs option in MediaPortal Debug-Mode


    For MP server + client on same machine :
    http://dl.free.fr/grj7t5XuY

    For MP server used with MP client on a different machine :
    http://dl.free.fr/hylQznufr
    For MP client on the 2nd machine :
    http://dl.free.fr/ilMEe9zun

    I also keep logs manually as on my previous message (same tests). I got exactly the same issues (with tv server crashs) :
    http://dl.free.fr/bMBa8IXuJ

    I realised that I did not try to record, but azzuro did it.
     

    azzuro

    Test Group
  • Team MediaPortal
  • May 10, 2007
    9,914
    5,563
    France - IDF
    Home Country
    France France
    • Thread starter
    • Moderator
    • #10
    can you describe for each test, what is work , what is broken ?
    because i don't understand if you have issue :confused:
     

    Users who are viewing this thread

    Top Bottom