ruutu.fi | Page 4

Discussion in 'OnlineVideos' started by micko, September 7, 2015.

  1. micko

    micko Portal Pro

    Joined:
    May 27, 2006
    Messages:
    258
    Likes Received:
    24
    Ratings:
    +51 / 0
    Home Country:
    Finland Finland
    Show System Specs
    Ruutu.fi stops playing after 4 minutes of time. Evr.log is showing that stream has ended. Ruutu.fi is working in MP2 onlinevideos.
    Both logs attached:



    MediaPortalLogs_17_09_16__07_37.zip
    7.33 Playing started
    7:37 End of stream?

    MP2 Logs.zip
    7:41 Playing started
    7:48 I stopped the video
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. doskabouter
    • Premium Supporter

    doskabouter Community Plugin Dev

    Joined:
    September 27, 2009
    Messages:
    2,769
    Likes Received:
    735
    Location:
    Nuenen
    Ratings:
    +1,085 / 1
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Is that consistent behavior? Mp1 and Mp2 are using the same backend as far as I know.
    Can you get a mpurlsourcesplitter.log from a successful run in Mp2? For convenience, please delete that file before testing, then it's much smaller.
    Preferably the same video as the one that ended prematurely in the Mp1 run
     
  4. micko

    micko Portal Pro

    Joined:
    May 27, 2006
    Messages:
    258
    Likes Received:
    24
    Ratings:
    +51 / 0
    Home Country:
    Finland Finland
    Show System Specs
    My wife told this problem has existed few weeks now. She told that some videos will play till the end ok, but there is more of those problematic ones.
    Now I played same video in Mp1 and Mp2 (mpurlsourcesplitter.logs attached). MP1 stopped video after 4 minutes and I stopped MP2 video after 10minutes.
     
  5. doskabouter
    • Premium Supporter

    doskabouter Community Plugin Dev

    Joined:
    September 27, 2009
    Messages:
    2,769
    Likes Received:
    735
    Location:
    Nuenen
    Ratings:
    +1,085 / 1
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Looking at your log, it isn't clear for me what could be the problem here.
    Perhaps @offbyone can tell if there's any significant difference between onlinevideos for MP1 and MP2 regarding this, and maybe @georgius could tell why in MP1 it want's to read Frag1..Frag132, and in MP2 it ends fine after reading Frag131, and why the 404 stops playback (I assume that if it plays until frag131 it would play a lot longer than 4 minutes)

    Sorry I can't be more helpful than this...
     
    • Like Like x 1
  6. micko

    micko Portal Pro

    Joined:
    May 27, 2006
    Messages:
    258
    Likes Received:
    24
    Ratings:
    +51 / 0
    Home Country:
    Finland Finland
    Show System Specs
    No worries doskabouter. Thank you again for everything you’ve done.

    Btw, I just noticed this in the first MP1 mediaportal.log I sent:
    [2016-09-17 07:33:04,784] [Log ] [MPMain ] [DEBUG] - VMR9: Repainting -> Playing, Frames: 61
    [2016-09-17 07:34:37,766] [Log ] [PoolThread44] [DEBUG] - ThreadPool.ProcessQueue() : quitting (inUse:0, total:2)
    [2016-09-17 07:37:01,921] [Log ] [MPMain ] [INFO ] - Main: WM_POWERBROADCAST (PBT_POWERSETTINGCHANGE)
    [2016-09-17 07:37:01,921] [Log ] [MPMain ] [INFO ] - Main: The user activity timeout has elapsed with no interaction from the user

    [2016-09-17 07:37:09,950] [Log ] [MPMain ] [INFO ] - VideoPlayer9: Cleanup DShow graph

    I have to study this further later on this week.. That power broadcast message had come just few seconds before "stream" has ended. All power saving settings should be disabled, but I will check them.
     
  7. doskabouter
    • Premium Supporter

    doskabouter Community Plugin Dev

    Joined:
    September 27, 2009
    Messages:
    2,769
    Likes Received:
    735
    Location:
    Nuenen
    Ratings:
    +1,085 / 1
    Home Country:
    Netherlands Netherlands
    Show System Specs
    That could very well be the cause. if the network card is suspended, then there's no more data to be received.
    And that fits perfectly with MP1 not working and MP2 working.
    Good luck investigating the power settings!
     
  8. te3hpurp
    • Team MediaPortal

    te3hpurp Retired Team Member

    Joined:
    September 23, 2008
    Messages:
    903
    Likes Received:
    181
    Gender:
    Male
    Occupation:
    Senior Software Architect
    Location:
    Rovaniemi
    Ratings:
    +228 / 0
    Home Country:
    Finland Finland
    Show System Specs
    Hi

    I Just noticed that I have same problem with MP1. I Will Look Power event also. For Me it looks more random than 4 minutes or so.

    Br,
     
  9. te3hpurp
    • Team MediaPortal

    te3hpurp Retired Team Member

    Joined:
    September 23, 2008
    Messages:
    903
    Likes Received:
    181
    Gender:
    Male
    Occupation:
    Senior Software Architect
    Location:
    Rovaniemi
    Ratings:
    +228 / 0
    Home Country:
    Finland Finland
    Show System Specs
    Okay,

    Have tested now for a multiple times and playback seems to stops at "decryption of segment fragments failed"

    Br,
     
    • Informative Informative x 1
  10. te3hpurp
    • Team MediaPortal

    te3hpurp Retired Team Member

    Joined:
    September 23, 2008
    Messages:
    903
    Likes Received:
    181
    Gender:
    Male
    Occupation:
    Senior Software Architect
    Location:
    Rovaniemi
    Ratings:
    +228 / 0
    Home Country:
    Finland Finland
    Show System Specs
    Hi.

    @georgius



    I wonder if this could cause that problem with ruutu.fi as it is made in 11.8.2016 and it's last change in code that
    affects to the same place, that we see in logs:

    https://github.com/MediaPortal/MediaPortal-1/commit/ad285836c3e011b96e45394054e5bf5e36f9e847


    Code (Text):
    1. 21-09-2016 16:19:46.918 [1d8c] [{87C0ED20-D1D6-4E72-B34E-4C2C50C453D3}] [Verbose] MPUrlSourceSplitter_Protocol_Afhs: instance 'Main': CurlDebug(): CURL message: 'Connected to nelonenmedia-ondemand02.nelonenmedia.fi (8.254.228.78) port 80 (#1)'
    2. 21-09-2016 16:19:46.918 [1d8c] [{87C0ED20-D1D6-4E72-B34E-4C2C50C453D3}] [Verbose] MPUrlSourceSplitter_Protocol_Afhs: instance 'Main': CurlDebugCallback(): sent HTTP header: 'GET /40/online/video/video_episode_115125740.smil/media_b1800000.abst/Seg1-Frag392 HTTP/1.1
    3. Range: bytes=0-
    4. Host: nelonenmedia-ondemand02.nelonenmedia.fi
    5. Accept: */*
    6.  
    7. '
    8. 21-09-2016 16:19:49.883 [1d8c] [{87C0ED20-D1D6-4E72-B34E-4C2C50C453D3}] [Verbose] MPUrlSourceSplitter_Protocol_Afhs: instance 'Main': CurlDebug(): received HTTP header: 'HTTP/1.1 404 Not Found'
    9. 21-09-2016 16:19:49.883 [1d8c] [{87C0ED20-D1D6-4E72-B34E-4C2C50C453D3}] [Verbose] MPUrlSourceSplitter_Protocol_Afhs: instance 'Main': CurlDebug(): received HTTP header: 'Date: Wed, 21 Sep 2016 13:19:47 GMT'
    Br,
     
  11. te3hpurp
    • Team MediaPortal

    te3hpurp Retired Team Member

    Joined:
    September 23, 2008
    Messages:
    903
    Likes Received:
    181
    Gender:
    Male
    Occupation:
    Senior Software Architect
    Location:
    Rovaniemi
    Ratings:
    +228 / 0
    Home Country:
    Finland Finland
    Show System Specs
    • Thank You! Thank You! x 1

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!