Software Encoder - AMD Avivo (2 Viewers)

pyro2k8

New Member
August 24, 2012
2
0
32
Germany Germany
Hi everyone,

I'm new here and I wanted to try Mediaportal because I'm not really satisfied with Windows MCE, so I'll come straight to the point:

I installed Mediaportal 1.2 as a Server and can't scan for channels because a software encoder is missing (analogue TV-Card: Hauppauge HVR 3300). So I tried to install the AMD Media Encoder (old name was ATI Avivo) as mentioned in the wiki, but I cant install it. Mediaportal does not recognize the actual version of the AMD Media Encoder. I found out that the reason is something like the actual version does not use DirectShow (is this correct?). So I downloaded some old versions and tried just to install the avivo.msi. Till now I tried following versions:
- 6.10
- 10.11
- 11.12
- 12.8

I also tried the 32 Bit version although I use Win 7 x64! While the install process I always get the same error (except 12.8, which I can't use anyway as I mentioned above): "atimpenc.dll could not be registered" and another .dll file. Installing the complete package I am getting some warnings, Graphedit (SO FAR I can judge that) and Mediaportal does not recognize the Encoder after installing it. I searched half the web and cant find anything useful about it. Perhaps anyone of you has an idea.

My system specs and some other things which could be useful...:
- AMD Fusion E-350
- 4Gb Ram
- Win 7 x64
- CoreAVC installed

Tell me if you need additional informations and thanks for helping!

Greetings from Germany,
Tim
 

pyro2k8

New Member
August 24, 2012
2
0
32
Germany Germany
I just fixed the problem! Wanted to know you how!

First of all to everyone who want to use the ATI AVIVO Software Encoder for Mediaportal:
ATI calles the AVIVO Package "AMD Media Codec Package" now. You can get the new package on this site: http://support.amd.com/us/gpudownload/Pages/index.aspx. If you filled in all informations change to tab "Optional Downloads". Important: Version 12.8 is NOT recognized by Mediaportal! So you need an older version too! I installed Version 12.8 completely and additionally, I installed the avivo64.msi of the ATI Media Encoder Package version 11.2. You can get this or any other old version by searching for a download at google.

By installing the avivo64.msi of the version 11.2 you will perhaps get an error like: "atimpenc.dll couldnt registered". Fix this by opening the command window (administrator rights) and type in:
regsvr32.exe "PATH TO YOUR atimpenc.dll"

For example it could look like that:

C:\>regsvr32.exe "C:\Program Files\Common Files\ATI Technologies\Multimedia\atimpenc.dll"

Be sure that your path is correct, otherwise you will get an error.

Restart your pc if your GUI of Mediaportal crashes after that.

After that, your Mediaportal installation should recognize the ATI MPEG Video & Audio Encoder at the General Tab!

Have fun!
 

yeahman45

Portal Member
December 31, 2013
42
1
35
US Minor Outlying Islands US Minor Outlying Islands
I just fixed the problem! Wanted to know you how!

First of all to everyone who want to use the ATI AVIVO Software Encoder for Mediaportal:
ATI calles the AVIVO Package "AMD Media Codec Package" now. You can get the new package on this site: http://support.amd.com/us/gpudownload/Pages/index.aspx. If you filled in all informations change to tab "Optional Downloads". Important: Version 12.8 is NOT recognized by Mediaportal! So you need an older version too! I installed Version 12.8 completely and additionally, I installed the avivo64.msi of the ATI Media Encoder Package version 11.2. You can get this or any other old version by searching for a download at google.

By installing the avivo64.msi of the version 11.2 you will perhaps get an error like: "atimpenc.dll couldnt registered". Fix this by opening the command window (administrator rights) and type in:
regsvr32.exe "PATH TO YOUR atimpenc.dll"

For example it could look like that:

C:\>regsvr32.exe "C:\Program Files\Common Files\ATI Technologies\Multimedia\atimpenc.dll"

Be sure that your path is correct, otherwise you will get an error.

Restart your pc if your GUI of Mediaportal crashes after that.

After that, your Mediaportal installation should recognize the ATI MPEG Video & Audio Encoder at the General Tab!

Have fun!
thx for the instructions! i had problems with the codec and with your commands, it's working fine now! thx
 

Achilleas

Portal Member
December 15, 2012
15
0
35
Greece Greece
Country flag
Hi! I can't find "ATI Media Encoder Package version 11.2" on google for download so that I have video & audio encoder working.
Since I know it's free, can someone please post the ATI encoders here for download or direct me to where I need to download these encoders?
Thank you!
 

Vasilich

Test Group
  • Team MediaPortal
  • August 30, 2009
    3,393
    1,170
    Germany, Mayence
    Russian Federation Russian Federation
    Country flag
    wikipedia says
    In 2011 Avivo is renamed to AMD Media Codec Package,[1] an optional component of the AMD Catalyst software. The last version is released in August 2012.[2] As of 2013, the package is no longer offered by AMD.
    https://en.wikipedia.org/wiki/ATI_Avivo
    so you need to find latest catalyst driver that works for you and contains media encoder package. Note that it works only on quite old Radeon cards.
     

    Achilleas

    Portal Member
    December 15, 2012
    15
    0
    35
    Greece Greece
    Country flag
    wikipedia says
    In 2011 Avivo is renamed to AMD Media Codec Package,[1] an optional component of the AMD Catalyst software. The last version is released in August 2012.[2] As of 2013, the package is no longer offered by AMD.
    https://en.wikipedia.org/wiki/ATI_Avivo
    so you need to find latest catalyst driver that works for you and contains media encoder package. Note that it works only on quite old Radeon cards.
    I've already downloaded the latest "AMD Media codec package" and installed it from the website. As pyro2k8 says here on the first post, Mediaportal DOES NOT recognise the newer AMD encoders, only the old ATI ones.

    So I would be grateful if anyone is willing to share this old encoder with me
     

    Vasilich

    Test Group
  • Team MediaPortal
  • August 30, 2009
    3,393
    1,170
    Germany, Mayence
    Russian Federation Russian Federation
    Country flag
    do you really want to fiddle with such an old driver/software? instead of taking other MPEG encoder?
    I would suggest to change name of ATI encoder in MP database - table 'softwareencoder' entries with idEncoder = 11 and 23. Write there exact names of filters as these appear in your system.
    @mm1352000 would this work? i haven't found any GUID or string with encoder names in code, so i assume the names in DB are exact the filter names in system.
     

    Achilleas

    Portal Member
    December 15, 2012
    15
    0
    35
    Greece Greece
    Country flag
    do you really want to fiddle with such an old driver/software? instead of taking other MPEG encoder?
    I would suggest to change name of ATI encoder in MP database - table 'softwareencoder' entries with idEncoder = 11 and 23. Write there exact names of filters as these appear in your system.
    @mm1352000 would this work? i haven't found any GUID or string with encoder names in code, so i assume the names in DB are exact the filter names in system.
    This is far more advanced than I can do. Any detailed guide on how to do this? I'm on the latest mediaportal version and my tv-card is a terratec ht pci hybrid
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 2)

    Top Bottom