SOLVED - 1.4.0 Final - not reading mp3 files without tags?

Discussion in 'General Support' started by AlexT, August 18, 2013.

  1. AlexT

    AlexT Portal Member

    Joined:
    May 2, 2011
    Messages:
    33
    Likes Received:
    57
    Ratings:
    +60 / 0
    Home Country:
    United States of America United States of America
    Show System Specs
    NOTE: Problem solved with Fix-DirectX-Device-for-XP-and-MPC-HC-Engine_v3 which can be found HERE. See post #4 below for details. Thank you patch developers and testers and mm.
    _____

    Clean install of single seat with no TV Server. Presently, I simply use MP as my media player out to the TV and surround sound system. I do have a tv card but not currently installed or needed but have used it with previous versions of MP.
    1. Open MP 1.4.0 Final
    2. Click on MUSIC
    3. Does nothing, MP locks up.
    Logs included are run from DEBUG mode (Report a Bug to Team Mediaporal) but I had to use MediaPortal Configuration (shut down mediaportal and open configuration) to exit out of MP, then cancelled configuration. Went back into DEBUG mode and Export all currently present logs. I created a temp folder for music and put several mp3 files in for debug/logging purposes; ie, keep log size down, easier to read since MP loops and logs such.

    According to mediaportal.log, the "locks up" is the MP TagReader attempting to read my mp3 files.

    [Log ] [MPMain ] [WARN ] - TagReader: Empty Title found in file: E:\MUSIC TEMP\ZZ Top – Tush.mp3. Please retag.



    Important to note that my mp3 files are not tagged, they are simply files that are .mp3; ie, no artist or song title information, etc. MP versions before 1.4.0 Final were able to read mp3 files without tags. I prefer to have my mp3 files as such since I do not have portable devices to play the same.

    Screenshot of my Music Tracks Format Mask settings is included, as are other various MUSIC settings tabs. Format is set to filename (with percent signs used on either side). When I select Sorting as Filename, click OK, open MP, close MP, open Configuration again, Sorting shows as Name, not Filename. I do not have internet lookups for music or any other MP feature enabled, do not use thumbnails, etc. I also tried enabling Auto-update DB on changes in shares and clicked on Update database from selected shares with a tick in the box next to the Music Temp folder with the mp3 files. Made no difference but did inclue database file created by MP as separate zip. I have tried various settings in the MUSIC settings area that in some way might have effect but no change (doesn't hurt to try, right? lol).

    music_tracks_format_mask.jpg player_settings.jpg play_settings.jpg now_playing.jpg playlist_settings.jpg

    Final thoughts: at this point, I'm assuming the problem is that 1.4.0 is not reading or is no longer written to read mp3 files without tags; ie, based on what I read in the mediaportal.log file. After installing 1.4.0 for the first time and discovering this, I did a full uninstall of 1.4.0 and did a clean install of 1.3.0 and mp3 files were read, displayed, and played correctly as they always had with 1.3.0 and older versions of MP. I did this a second time just 3 days ago and the same result. It was at this time I checked log files.

    Off-topic note: it has been quite awhile since I have visited (since 1.2.0 Final). Was without internet for quite awhile due to ISP technical issues in area, got back on for x time, and more technical issues r/t ISP again so it really has been awhile. Felt like I needed to explain that, as I was starting to get involved more in the forum at that time. In other words, missed Team-MediaPortal.com. I've just recently upgraded to 1.4.0. THANKS Team-MP :)
     

    Attached Files:

    Last edited: August 18, 2013
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,518
    Likes Received:
    4,730
    Ratings:
    +8,196 / 17
    Home Country:
    New Zealand New Zealand
    Hello and welcome back AlexT :)

    I'm no music expert, but the immediate thought that comes to mind is if your MP3s have no tags then you'd need to use shares view. I mean, if there is no identifying information except the file name, are you saying that you expect MP to load the MP3s into the database based on that info? I don't think MP does that...

    Quick tag to @jameson_uk and @hwahrmann who will know the changes in MP 1.4 and expected behaviour far better than I... :)

    mm

    [edit: Note, I see you're running XP. Please be aware that XP support is being phased out. For stability on MP 1.4 you'll want to install the patch from -->here<--]
     
    Last edited: August 18, 2013
    • Like Like x 1
  4. AlexT

    AlexT Portal Member

    Joined:
    May 2, 2011
    Messages:
    33
    Likes Received:
    57
    Ratings:
    +60 / 0
    Home Country:
    United States of America United States of America
    Show System Specs
    Thanks, mm for taking the time to read and reply. And for the point-to on the patch.

    I do not expect MP to develop a database from filenames. I should have stated that the only reason I enabled Auto-update database and clicked on Update database... was to see if MP was even recognizing the mp3 files 'as' files. A view of the database file via Notepad2 did show the location and filenames correctly of the 29 mp3 files (again, no tags) I copied into a temp folder for troubleshooting. That was the only purpose of that step. In previous versions of MP, I never had to do anything other than goto MUSIC feature, click on the folder I wanted, and even with over 600 mp3 files, it only took a couple of seconds for it to open, and any file played fine. I have never had an issue with MUSIC before. Please note that XMPlay has no issue with tagless mp3 files.

    I do have Views set to Shares.

    music_setting_mp_view.jpg

    I just did some more troubleshooting or experimenting, perhaps, lol. You can see in the screenshot that Sort is set to Name, even though I keep trying to set it to Filename in the MP Configuration program. I do select it there but when I open MP and look it is still set to Name, which you can see in above screenshot. Below screenshot simply shows that I am clear on how to set it. lol I should mention that while in MP, I can change Sort to Filename but it doesn't change anything. If I then close MP and then open MP again, Sort still shows as Filename but again, doesn't do anything differently. I then checked in the MP Configuration Program and Sort was still set to Name.

    sort_by_filename.jpg

    So the experiment was to use %name% in the format field in the MP Configuration Program and sort was set to Name since it won't let me use Filename; ie, no choice, as I have explained. I opened MP, clicked on MUSIC TEMP folder and lo and behold there were the 29 songs and their correct durations but! all songs were titled %name%, literally.

    format_name.jpg

    It would not let me play the files, I was only able to scroll through the list but the fact that it resulted in an ordered list, sorted by filename (even though MP Config Prog would not keep that as a setting) and the durations were shown correctly at least showed that, in part, MP was recognizing the tagless mp3 files.

    The only thing I have thought about trying is to again do a full uninstall of 1.4.0, do a clean install of 1.3.0, and retrieve the default playlist file that is created when MP is closed. I assume that I can do so. And then place that file in whatever location 1.4.0 keeps it, open MP, goto MUSIC, and select it in the Playlist area. If the Team would like me to do so and it would help with troubleshooting, then I will.

    And I feel important to say, the reason I am even bringing up this issue is because it is away from the standard or norm from all previous MP versions and I have not read of it being an intended change. It might be important for the programming or programmers (<3 for Team MP) of future MP versions. I say all that because even though I could find a free tag editor and yes, would have to go in and manually tag a lot of mp3 files, I felt my latter point important enough to give back through all this. Hope that all made sense. And of course, sure, I would like to keep my mp3 files tagless. I could even revert back to MP 1.3.0 final but I have great trust in the Team MP and know I should be using the latest/greatest. Plus, I will start using my i7 system eventually for my HTPC needs but am waiting on affording the flat screen tv I want. I run W7 on it but only use for gaming now. I have put off migrating my HTPC needs to it is because my MSI GTX 480 video card only does DVI or HDMI out and W7 does not properly recognizing generic tv's properly anymore; ie, there are adapters for DVI to composite available or I could build one. I digress. ha!

    I think I covered everything I could think of for now. Cheers!
     
    Last edited: August 18, 2013
  5. AlexT

    AlexT Portal Member

    Joined:
    May 2, 2011
    Messages:
    33
    Likes Received:
    57
    Ratings:
    +60 / 0
    Home Country:
    United States of America United States of America
    Show System Specs
    HOLD THE ELEVATOR! STOP THE PRESSES! PROBLEM FIXED & CRISIS DIVERTED!!

    And all thanks to the Fix-DirectX-Device-for-XP-and-MPC-HC-Engine_v3 developers...

    sr.gif

    ...testers, and of course, to the fine individual and team-mediaportal.com member, mm, for showing me to it.

    yfmm.jpg

    Yes, that is correct, fixed my issue completely. No problem with MUSIC reading tagless mp3 files. I am embarrassed because after reading mm's reply and point-to on the patch and after briefly skimming the patch post, I was going to apply the patch (mediaportal.exe) but wanted to get my reply done first. lol, ohhh, hindsight can be a killer. On the brightside (always have to look for one), maybe someone else may have this issue or a similar enough one that they will learn of the patch, apply it, and it may fix their problem. See! All coming up roses! I think that's how it goes.

    After reading through the entire patch thread, it's when I came across a reply from Guzzi that sparked a glimmer of hope that the patch might be my answer, as well...

    Sooo...to show my sincere THANKS to all involved (including any team members who might have read), I spared no expense and rented out the downtown Poughkepsie Basement Theater (seating limited to 22, sorry, and a few might have to share a seat) for tomorrow night AND hired the world famous, Daper Dan - The Dancing Squirrel to perform a Team MediaPortal Appreciation Show.

    tmpas.gif

    You're welcome, see you there...and THANKS again!
     
    Last edited: August 18, 2013
    • Like Like x 2
    • Thank You! Thank You! x 1
    • Agree Agree x 1
  6. Edalex
    • Premium Supporter

    Edalex Community Plugin Dev

    Joined:
    January 3, 2008
    Messages:
    2,898
    Likes Received:
    709
    Gender:
    Male
    Location:
    Saratov
    Ratings:
    +1,223 / 9
    Home Country:
    Russian Federation Russian Federation
    Show System Specs
    • Funny Funny x 1
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!