[SOLVED] The used codec is different from the one set in the configuration (PowerDVD) (1 Viewer)

axlt2002

Portal Pro
September 20, 2012
100
23
43
Italy Italy
Country flag
Hello All,

To watch live TV I have set PowerDVD codec for both standard and HD transmissions. With a big surprise, using GraphStudioNext, I discovered that instead of PowerDVD codec the Windows DVD-DVB codec is instead used (I don't know why I made such test!!!!!). I have then made a try with LAV codecs and all is working perfectly. Summurizing:

- LAV selected in TV settings -> LAV used while playing the channel
- Microsoft DVD-DVB selecetd in TV settings -> Microsoft DVD-DVB used while playing the channel
- PowerDVD13 selecetd in TV settings -> Microsoft DVD-DVB used while playing the channel!!!!

Something wrong with the last but...what? If needed, I will post the logs (not early since I'm actually outside for a business trip). For now, just to know if someone else has the same issue. Thanks! :)


Just edited the post and the title since the issue happens also for the videos and not only for the TV (I suppose it happens also for the other formats).

Please find attached two screens displaying the settings (PowerDVD codec is selected) and the Graph while playing the file (Microsoft DVD-DVB codec is used). Just for info, if I set LAV, LAV is correctly used...it seems an issue with PowerDVD codec...but which issue?

I have attached also the logs!

Thanks for any help!

Settings.png

Graph.png
 
Last edited:

Holzi

Super Moderator
  • Team MediaPortal
  • April 21, 2010
    7,930
    2,234
    Ba-Wü
    Germany Germany
    Country flag
    Do you have PDVD codec installed correctly? Does this codec work in other players?
     

    Owlsroost

    Development Group
  • Team MediaPortal
  • October 28, 2008
    5,538
    5,037
    Cambridge
    United Kingdom United Kingdom
    Country flag
    The problem is that the PDVD video decoder is refusing the connections - note the 'failed' messages:

    Code:
    [2014-03-05 17:06:40,319] [Log    ] [MPMain   ] [DEBUG] - Filter: CyberLink Video Decoder (PDVD13) - try to connect: Video Out
    [2014-03-05 17:06:40,612] [Log    ] [MPMain   ] [DEBUG] - DirectShowUtil: RenderUnconnectedOutputPins Pin Video Out - failed
    [2014-03-05 17:06:40,613] [Log    ] [MPMain   ] [DEBUG] - Filter: CyberLink Video Decoder (PDVD13) - try to connect: ~Closed Caption Out
    [2014-03-05 17:06:40,817] [Log    ] [MPMain   ] [DEBUG] - DirectShowUtil: RenderUnconnectedOutputPins Pin ~Closed Caption Out - failed
    [2014-03-05 17:06:40,818] [Log    ] [MPMain   ] [DEBUG] - Filter: CyberLink Video Decoder (PDVD13) - try to connect: ~Encode Out
    [2014-03-05 17:06:40,999] [Log    ] [MPMain   ] [DEBUG] - DirectShowUtil: RenderUnconnectedOutputPins Pin ~Encode Out - failed
    Do you have PDVD13 installed and licensed ?
     

    axlt2002

    Portal Pro
    September 20, 2012
    100
    23
    43
    Italy Italy
    Country flag
    Thanks for the hints!

    After one day of full immersion in different solutions, the issue has been solved thanks to the installation of SAF (http://hobring.esero.net/saf/binary/)! :cool:

    No necessity to install PowerDVD to use its codecs. I'm going to change the title of the thread removing [BUG?]...in fact nothing related to MediaPortal issues! (y)
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    cladinshadows85 timeshift error <solved> General 2
    F [Solved] Movies View with Thumbnail Layou General Support 4
    squidina [solved] - MediaPortal 1.22 won't start even with new install General Support 4
    J [solved] Lag on client-only PCs General 0
    joecrow [solved] (Solved) Win 10 1809 Woes General Support 4
    L [solved] MovPicNFO mit NAS? Video & DVD 1
    joecrow (Solved) EPG wrong General Support 18
    D [SOLVED] Radio issue in MediaPortal 1.20 Pre-Release 1.20 Pre Release 47
    TheBatfink [solved] Homescreen tile labels are offset Titanius 3
    toricred Configuring TV Server to use NAS General 0
    vvulture Using Windows 10 MediaPortal 1 Talk 8
    atlantic How to use Spotify inside Mediaportal? Listen Music 18
    Megane Too much RAM used (over 2 GB). General Support 18
    doskabouter 1.23.0 MatroskaTagInfo uses the wrong casing for tags Bugreports 27
    D how to disengage from one version of a plugin to use another Newcomers Forum 0
    D I just installed MP 1.23. Which version of Schedules Direct should I use, where do I obtain it from Newcomers Forum 6
    M Can i use my Vu+ Zero 4k Tuner for Mediaportal? General 0
    benicehavefun Using MePo TV Server 1.23 via MPExtended/WebMediaPortal as a Backend for Plex MPExtended 4
    G MP1 TV Server "failed to upgrade the database" using MS Sql Server Installation, configuration support 3
    1gkar Use Alternative Sites to Scrape Series Info My TVSeries 5
    T Can Emprex 3009ARF III MCE Remote Control be used to toggle Fullscreen/Windowed mode?? Remotes 7
    S [solved] Live TV subtitle issue if not using 100% font General 31
    N [Proposal] Make text input using remote control easier MediaPortal 2 4
    T Issues with MediaPortal not starting correctly using versions after 1.20 Final General Support 6
    erika jandova Using SD and MediaPortal 1 Newcomers Forum 4
    Similar threads

























    Top Bottom