some H265 videos stay black, audio is playing (1 Viewer)

Terra

Portal Pro
August 25, 2009
230
56
Austria Austria
Country flag
Hi there,

I am having the issue that some h265 videos only play audio and MP1 only shows a black screen.
I can play those videos without any problems on other PCs or media players even on the same PC, e.g MPC player.

Sometimes the issue can be resolved by restarting the PC or MP1, but it really gets annoying... :/

logs attached

here is the mediainfo of the file in the logs

Video: HVC1 1920x1080 23.976fps [V: hevc main 10, yuv420p10le, 1920x1080 [default]]
Audio: DD+ 48000Hz 6ch 448kbps [A: English [eng] (eac3, 48000 Hz, 5.1, 448 kb/s) [default]]
Subtitle: UTF-8 [S: English [SDH] [eng] (subrip)]
Subtitle: UTF-8 [S: Castilian [spa] (subrip)]
Subtitle: UTF-8 [S: Spanish [spa] (subrip)]
Subtitle: UTF-8 [S: French [fre] (subrip)]
Subtitle: UTF-8 [S: German [ger] (subrip)]
Subtitle: UTF-8 [S: Italian [ita] (subrip)]
Subtitle: UTF-8 [S: Portuguese [por] (subrip)]
Subtitle: UTF-8 [S: Brazilian Portuguese [por] (subrip)]
Subtitle: UTF-8 [S: Polish [pol] (subrip)]
Subtitle: UTF-8 [S: Turkish [tur] (subrip)]
Subtitle: UTF-8 [S: Swedish [swe] (subrip)]
Subtitle: UTF-8 [S: Danish [dan] (subrip)]
Subtitle: UTF-8 [S: Finnish [fin] (subrip)]
Subtitle: UTF-8 [S: Dutch [dut] (subrip)]
Subtitle: UTF-8 [S: Norwegian [nor] (subrip)]
Subtitle: UTF-8 [S: Russian [rus] (subrip)]
Subtitle: UTF-8 [S: Hebrew [heb] (subrip)]
Subtitle: UTF-8 [S: Arabic [ara] (subrip)]
Subtitle: UTF-8 [S: Romanian [rum] (subrip)]
Subtitle: UTF-8 [S: Indonesian [ind] (subrip)]
Subtitle: UTF-8 [S: Vietnamese [vie] (subrip)]
Subtitle: UTF-8 [S: Thai [tha] (subrip)]
Subtitle: UTF-8 [S: Korean [kor] (subrip)]
Subtitle: UTF-8 [S: Chinese (Simplified) [chi] (subrip)]
Subtitle: UTF-8 [S: Chinese (Traditional) [chi] (subrip)]
Subtitle: UTF-8 [S: Japanese [jpn] (subrip)]
Subtitle: UTF-8 [S: No subtitles]

thanks!
 

Attachments

Sebastiii

Development Group
  • Team MediaPortal
  • November 12, 2007
    16,557
    10,376
    France
    France France
    Country flag
    Hi :)

    Can you try by disable or remove AirPlayer plugin?

    Also, I have noticed that MP seems to get the wrong resolution : overlay: dst : (0,-2147483648)-(3840,0)
    So maybe it can be related to your issue, can you upload a sample somewhere?
    Thanks.
     

    Terra

    Portal Pro
    August 25, 2009
    230
    56
    Austria Austria
    Country flag
    Hi :)

    Can you try by disable or remove AirPlayer plugin?

    Also, I have noticed that MP seems to get the wrong resolution : overlay: dst : (0,-2147483648)-(3840,0)
    So maybe it can be related to your issue, can you upload a sample somewhere?
    Thanks.
    I uninstalled the plugin (was not that easy as it was not showing up in the plugin manager). But same situation.
    What I changed now is that I switched LAV to "DXVA2 Native" instead of copy-back and as renderer I switched to MadVR (instead of EVR). So far I have not experienced the issue anymore... :)
     

    badboyxx

    Portal Pro
    June 15, 2012
    718
    94
    Germany Germany
    Country flag
    Temporary I get also this behaviour. I think that it is not related to a specific file format. I noticed that it at least occured on mkv-files. When this behaviour occures, than I get also a black screen on livetv. I have to restart MP to solve that problem.
    By the way I don't use AirPlayer.
     

    Users who are viewing this thread

    Similar threads
    OP Title Forum Replies Date
    Scheibes Mediaportal 2.2 kein H265 Unterstützung? Allgemeines Support- und Diskussionsforum 8
    raffe Trailers via Youtube in Online Videos (for movies and maybe also TV-series) Feature Requests 0
    raffe [solved] [Solved] How to import TV series Videos Not in any online source? General 8
    A [solved] Video playback only successful after second attempt when returning from standby General Support 5
    bta489 Sometimes no image rendered when playing video watch/edit Videos 31
    S External player in MP2 and see videos made with my cam? General 8
    S Be able to see photos and videos together MediaPortal 1 Skins 1
    catavolt [solved] LMH - Wrong Video order Fanart Handler 27
    ajs [WiP] 5058: BlackScreen instead XMas Video :) MediaPortal 1 302
    rainbowforest MP2 - V2.3 Anmeldung Online Video (Streaming provider) Allgemeines Support- und Diskussionsforum 9
    doskabouter 1.26.0 Codec question (unable to play video, lv50 codec) Codecs, External Players 24
    Scheibes MP2 - V2.3 2. Client stops video on 1. Client Submit: Bug Reports 10
    S MP2 - V2.3 MP2 No video General 6
    Sakols No video in channel preview window General Support 12
    P Nach Video Stream muss TVService beendet werden TV / Streaming 0
    O No Video playback on Media Portal 2.2.3 Newcomers Forum 2
    E 1.25.0 Change AVC / AAC Codec for Analog card captured videos Codecs, External Players 0
    N [not reproducible] Online videos not working at all Submit: Bug Reports 1
    R Bug: Video Folders disappear General Support 11
    Stephen O'Kane [SOLVED] TV Stream stuttering - both Video and Audio Watch / Listen Media 14
    B some music videos stutter Watch / Listen Media 0
    I 1.25.0 Videos in HEVC UHD 2160p don't play good watch/edit Videos 8
    CanadianEh MP TV server rebuild with Colossus 2 - Kodi clients receive PMT error when playing videos recoreded by Colossus 2 TV-Server 2
    Rob Hexenmeister Skinning Online Videos question OnlineVideos 2
    A [solved] How to Play All Videos in a List watch/edit Videos 3

    Similar threads

    Top Bottom