Some "m2ts" Videofile will not playing correct. (1 Viewer)


Development Group
  • Team MediaPortal
  • November 12, 2007
    France France
    Country flag
    About this one...
    Can you use the VMR9AlreadyAdded to completely skip the check if a video renderer is already present? For example:
    if (!VMR9AlreadyAdded)
      IPin pinFrom = DirectShowUtil.FindPin(_interfaceSourceFilter, PinDirection.Output, "video");
      if (pinFrom != null)
        // Add video renderer etc.
    It would be a little faster. :)
    Thanks :p


    Development Group
  • Team MediaPortal
  • November 12, 2007
    France France
    Country flag
    It seems that i have a fix (or workaround) for xml issue.
    So i don't know why but dialogProcess.xml need to be loaded on MP start and not just before window (plugin window).
    I have no clue why but it seems that way, the error is no more displayed.
    We really need some skin engine dev for helping :)


    Portal Pro
    May 7, 2012
    Germany Germany
    Country flag
    Hello @Sebastiii ,

    very sorry for the long delay. :sleep:

    After I open the new "message " to the "RSS News plugin" and we got the answert that the RSSPlugin maybe will go out from MediaPortal. I do not follow this problem.

    Today I say your Fix the problem and I have try the last "madVR" MediaPortal Build whis "Titan" Skin:


    Now the " RSS News Plugin" work very well! and the problem from MediaPortal 1,71 is gone too :)

    Thank you very much for this.

    Last edited:

    Users who are viewing this thread

    Similar threads
    OP Title Forum Replies Date
    squizeer Sound only when playing 4k UHD (HEVC 265) Codecs, External Players 0
    T Madvr with GeForce 30xx - can't play SDR content after playing HDR General Support 25
    P 1.26.0 Can't play blu-ray disc Bugreports 1
    doskabouter 1.26.0 Codec question (unable to play video, lv50 codec) Codecs, External Players 24
    W 1.25.0 Blu-ray disks that used to play are no longer playing Watch / Listen Media 2
    joecrow [solved] DVD won't play properly. General Support 11
    M.Hulot MP plays in Internal Blu-ray-Player-mode always first audio stream not the one I chosen in settings General Support 1
    BrownGhost Mepo/MediaInfo takes 59 secunds to open library and start play :o( General Support 27
    I 1.25.0 Videos in HEVC UHD 2160p don't play good watch/edit Videos 8
    CanadianEh MP TV server rebuild with Colossus 2 - Kodi clients receive PMT error when playing videos recoreded by Colossus 2 TV-Server 2
    M [solved] WTV Files does not play on client, MPEG files works well General 1
    A [solved] How to Play All Videos in a List watch/edit Videos 3
    horned_reaper [solved] When playing music Fanart does not shuffle Fanart Handler 20
    horned_reaper [solved] No Fanart when playing Fanart Handler 115
    horned_reaper [solved] When playing music Fanart does not appear immediately after downloading Fanart Handler 272
    B MP 2.2.3 Error playing videos from NAS Submit: Bug Reports 2
    N Play a TV recording needs a double selection - twice ok on remote Television (MyTV frontend and TV-Server) 2
    M MP 2.2.3 Unable to play .ts recordings and MediaPortal stops working for TV viewing General 31
    Z Error when attempting to play Blu Ray General 1
    Rob Hexenmeister Playing with hyperlinkParameter and List Control indexes General Support 2
    C Problem playing videos created on IPhone X and Samsung S9 General Support 2
    2BitSculptor MP 1.23.. music stops playing General Support 6
    C Attempt to play DVD locks up MediaPortal watch/edit Videos 0
    H Unable to play stream - again... Television (MyTV frontend and TV-Server) 2
    B Suddenly MP is unable to play anything Watch / Listen Media 6

    Similar threads

    Top Bottom