[EPG] Some problems with DVB EPG (1 Viewer)

framug
Country flag

Portal Pro
January 31, 2005
4,275
357
South of France
Home Country
France France
  • Thread starter
  • Moderator
  • #1
My config with 8 tuner cards :


zz1.png

Settings with EPG grabbing when TS or record (doesn't work) :

zz2.png

Settings for using a specific tuner (the one with lowest priority) especially for grabbing EPG :

zz3.png

When no TS nor record(s), card(s) with highher priority is used :

zz4.png

BUT when TS :

zz5.png

OR, when record :

zz6.png

THEN, what do you think ?
Are you interested with ?
1/ It seems that grabb when TS or record doesn't work (bug should be fixed by MP devs)..
2/ Using lowest priority card available and/or specific tuner grabng EPG (if set) for grabbing EPG (I could eventually try to do it) ;)
 

framug
Country flag

Portal Pro
January 31, 2005
4,275
357
South of France
Home Country
France France
  • Thread starter
  • Moderator
  • #3
Had you tried to uncheck idle stuff.
@mm1352000 can maybe have an idea on this.
Hello,
Just tested right now, no grab when idle is unchecked (tested all cases, even if TS or record).
I admit I didn't look into the code for the moment.
I just found it by using MP and, as you know, since there is no french xmltv file anymore.
 

CyberSimian
Country flag

Test Group
  • Team MediaPortal
  • June 10, 2013
    1,786
    1,050
    Southampton
    Home Country
    United Kingdom United Kingdom
    I use DVB-T/T2 in the UK, and use the DVB EPG. (I have a TBS 6284 quad tuner card, plus a Pinnacle 2000i dual tuner card, for a total of six tuners.)

    I think that you have not quite understood how the EPG grabbing is supposed to work. I revised the relevant page in the Wiki a few weeks ago, to try to make it clearer how to setup DVB grabbing. So please read this page and let me know if you find any parts that are confusing or unclear.

    When grabbing while watching TV, or grabbing while recording, TV Server grabs the EPG from the tuner that is being used for watching or recording, so in "Manual Control" you will not see a tuner dedicated to grabbing.

    For grabbing while idle, all tuners must be idle in order for grabbing to start. This does seem like a strange restriction, and I don't know why it was implemented in this way.

    You don't need to restrict grabbing to the lowest priority tuner. Grabbing is always lower priority than watching or recording. So if a tuner is being used for grabbing, but is required for watching or recording, the grabbing will stop. Obviously, this condition will arise only when your HTPC has one tuner. If your HTPC has eight tuners and one tuner is grabbing, starting watching or recording will terminate grabbing (even though it does not need to -- see previous paragraph).

    Finally, the refresh interval that you specified (11 minutes) is too short. Did you set that value for testing in order to see what happens? A sensible value would be in the range 1 hour to 24 hours.

    -- from CyberSimian in the UK
     

    CyberSimian
    Country flag

    Test Group
  • Team MediaPortal
  • June 10, 2013
    1,786
    1,050
    Southampton
    Home Country
    United Kingdom United Kingdom
    I thought that it might be useful to describe my setup for EPG grabbing:
    • I use only "grab while timeshifting/recording".
    • I grab from only one channel (a channel that I never watch or listen to, but which resides in a MUX that includes the full EPG).
    • I have scheduled a manual 30-minute recording from this channel for 06:00 hours (when the HTPC is never being used). 30 minutes is long enough to ensure that I receive the full EPG. In the UK, a full EPG takes around 15 minutes to receive, although this varies somewhat from day to day.
    • To receive last-minute updates to the EPG, I could schedule short manual recordings from that channel for other times in the day (e.g. 18:00 hours), although currently I do not do that. By "short" I mean (say) 2 minutes. In the UK, the EPG for the next few hours is broadcast repeatedly, so a 2-minute grab will receive the updates.
    • The channel that I use is actually a radio channel, as this results in tiny recording files that do not consume much space on disk. I delete these files every day or two.
    • MP does not allow scheduling manual radio recordings, so scheduling a manual TV recording is easier. To use a radio channel, you need to schedule a manual TV recording, export the recording schedule, manually edit the xml file to change the channel to the radio channel, and then import the recording schedule.
    -- from CyberSimian in the UK
     

    framug
    Country flag

    Portal Pro
    January 31, 2005
    4,275
    357
    South of France
    Home Country
    France France
    • Thread starter
    • Moderator
    • #6
    When grabbing while watching TV, or grabbing while recording, TV Server grabs the EPG from the tuner that is being used for watching or recording, so in "Manual Control" you will not see a tuner dedicated to grabbing.

    For grabbing while idle, all tuners must be idle in order for grabbing to start. This does seem like a strange restriction, and I don't know why it was implemented in this way.
    @CyberSimian : Than you for your explanations and the wiki link.
    You pointed what I mean, if I understand correctly, with this behaviour, we have to wait for no TS nor record or, if TS or record, the grab is made in the used multiplex.

    You don't need to restrict grabbing to the lowest priority tuner. Grabbing is always lower priority than watching or recording. So if a tuner is being used for grabbing, but is required for watching or recording, the grabbing will stop. Obviously, this condition will arise only when your HTPC has one tuner. If your HTPC has eight tuners and one tuner is grabbing, starting watching or recording will terminate grabbing (even though it does not need to -- see previous paragraph).
    My proposal is to use an unused tuner to grab EPG, in all multiplex.
    By this way, we have more channels populated.

    Finally, the refresh interval that you specified (11 minutes) is too short. Did you set that value for testing in order to see what happens? A sensible value would be in the range 1 hour to 24 hours.
    Default value is 240 minutes.
    With that, I have to wait many hours/day, to have EPG filled.
    Then, I put 11 minutes to have EPG faster, it will be fine tuned after (half an hour, 1 hour, 2 hours, don't know yet).
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom