Stutter / Jitter of GUI scroll text (1 Viewer)

JimmyBoy

Portal Pro
April 18, 2008
107
8
United Kingdom United Kingdom
MediaPortal Version: 1.2.2
MediaPortal Skin: Avalon 1.0.0.0
Windows Version: Windows 7 x86 SP1
CPU Type: AMD Phenom II X2 555 Black Edition 3.2GHz
HDD: Crucial 64GB RealSSD C300 SSD
Memory: OCZ OCZ3BE1600C8LV4GK PC3-12800 / 1x2GB / 1600MHz / DDR3 / AMD Black Edition XTC Kit
Motherboard: Asus M4A88TD-M EVO/USB3 AMD 880G AM3
Video Card: nVidia MSI GeForce GTX 460 Cyclone 1GB
Video Card Driver: 266.58 WHQL
Sound Card: Realtek High Definition Audio (Optical)
Sound Card AC3: Optical
Sound Card Driver: 6.0.1.6069
1. TV Card: BlackGold BGT3595
1. TV Card Type: Hybrid DVB-S / DVB-T
1. TV Card Driver: 09/03/2010,1.0.5.90.1
2. TV Card:
2. TV Card Type:
2. TV Card Driver:
3. TV Card:
3. TV Card Type:
3. TV Card Driver:
4. TV Card:
4. TV Card Type:
4. TV Card Driver:
MPEG2 Video Codec: MPC - MPEG-2 Video Decoder (Gabest)
MPEG2 Audio Codec: Microsoft DTV-DVD Audio Decoder
h.264 Video Codec: Microsoft DTV-DVD Video Decoder
Satelite/CableTV Provider: Astra 19.2°E
HTPC Case: Zalman HD-501
Cooling: CPU - Noctua NH-U9B SE2 Dual Fan, Chassis - 2 x Sharkoon 1000
Power Supply: Be Quiet Special Edition White 600W E7 Modular PSU
Remote: Logitech Harmony 300i & Logitech diNovo
TV: LG 60" (LG60PK250)
TV - HTPC Connection: HDMI


I wouldnt normally be too bothered by this, BUT... I did have the GUI scroll text scrolling as smooth as butter - I mean, there was not one single pause, hickup, jitter, stutter or anything, it was perfect super smooth! Now it is not!, about once a second, the scrolling text will briefly pause! I find this sooooooo annoying! lol, especially as it was 100% smooth before :(

The annoying things is, as far as I am aware nothing has changed (hardware or software) from when it was smooth to it now not being smooth.

Screen is at 50Hz, scroll speed is set to 50 FPS and if I do Shift+1 on GUI then it is always reporting between 46-49 FPS. This should really be consistently closer to 50FPS and this is why I am getting the odd pause but its hard for me to determine exactly where the problem lies. It could be hardware, software, drivers or something completely random.

What I have noticed though through trial and error is, if I open the task manager and kill TvService.exe then my text will once again scroll as smooth as butter. This would indicate to me that TvService is sending out frequent broadcasts which in turn get processed by mediaportal, which in turn causes MP to be busy for a few milliseconds and causes the hiccups in scrolling.

Would anyone be able to give me any pointers and possibly advise on nVidia driver settings, ie Force vsync on/off, tripple buffering on/off, number of pre-buffered frames etc...

Thanks for any help.
 

JimmyBoy

Portal Pro
April 18, 2008
107
8
United Kingdom United Kingdom
Unfortunately not. I didnt get any help here and didnt persue it. I dont really use MediaPortal that much at the moment.
 

blair_haynes

MP Donator
  • Premium Supporter
  • October 26, 2007
    224
    41
    Gisborne
    New Zealand New Zealand
    Ok, I had a quick look at this with no success. I'm not sure where you mean to set the rollspeed to 100.

    When I look in Setup, Screen, I see Horizontal Scroll speed and Vertical Scroll speed which have options between 1 and 5.

    The other option is the refresh rate (in FPS). I have tried many different options here but with no success.

    The problem that I have is that the scrolling text seems to scroll for one second, the pause for what appears to be 0.2 of a second and so on. Very frustrating.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    Stephen O'Kane [SOLVED] TV Stream stuttering - both Video and Audio Watch / Listen Media 14
    B some music videos stutter Watch / Listen Media 0
    I Video Playback Stuttering General Support 45
    limpwhizkid 1.22.0 Stutter and or artifact problem when recording and watching the same live tv channel 1.22 2
    P [solved] Analog FM Radio stutter General 11
    W Playback stuttering after upgrade from MP1 on Windows 7 to MP2 on Windows 10 General 2
    AberDino 4k TV Stutter with RTSP General Support 7
    bta489 [solved] Stuttering playback of edited recordings watch/edit Videos 2
    M VPN: Mediaportal TV-Server ist not using all available bandwidth which results in TV stuttering Newcomers Forum 0
    D [solved] (Micro)Stutter when playing TV General 28
    Stephen O'Kane MP1.20 - Stuttering Recordings (EXP-Upgrage_555_MM_Owlsroost) Watch / Listen Media 1
    J Over the air chanenels stuttering General 0
    M Apollo Lake and Gemini Lake 4K HEVC HDR10 performance General 1
    P Video and audio stutters after playing TV recording for few minutes 1.19 0
    R MP2 GUI Issues General 7
    ajs [fixed] 5022: Improving the MPE Installer, providing nicer GUI :) MediaPortal 1 42
    ajs [fixed] 5015: Improving the MP1 installer, providing nicer GUI :) MediaPortal 1 138
    ltfearme Exception thrown when SetText in GUI Notification dialog Titan Skin Feedback 3
    F GUI incredibly slow Performance General 22
    S Hard crashes in gui when sending to importer Moving Pictures 2
    azzuro [Help Me!] Improve duration times of GUI List items MediaPortal 2 37
    Top Bottom