Syntax error line 1950

Discussion in 'SubCentral' started by powermarcel10, December 8, 2011.

  1. powermarcel10
    • Premium Supporter

    powermarcel10 Retired Team Member

    Joined:
    November 30, 2010
    Messages:
    2,839
    Likes Received:
    789
    Gender:
    Male
    Occupation:
    Callcenter Agent
    Location:
    Groningen
    Ratings:
    +1,028 / 4
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Hi,

    I have a problem with Subcentral/MP TV-series...



    I was downloading a subtitle for a episode of Law and order, but when I was starting the episode I was getting an error: "Syntax error line 1950"

    There was also another subtitle availible, and when downloading that one, everything is fine..

    Do you have any idea?

    Here are all log files..
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. SilentException
    • Premium Supporter

    SilentException Retired Team Member

    Joined:
    October 27, 2008
    Messages:
    2,617
    Likes Received:
    1,125
    Gender:
    Male
    Location:
    Rijeka, Croatia
    Ratings:
    +1,129 / 0
    Home Country:
    Croatia Croatia
    So let me see if I got you correctly.. You downloaded subtitle file from Internet (unknown source) and it didn't work. Then you downloaded another subtitle file from internet (also unknown source) but this one did work. Ummm.. so what's wrong? :) It was obviously error in the subtitle file... Or do you want me to add some AI to SubCentral to automatically fix subtitle file errors? :p

    BTW, saw this in your logs:
    System.ArgumentException: Er is al een item met dezelfde sleutel toegevoegd.
    Looks like there are some errors in your language file (XML). Maybe two translations with the same key?
     
  4. powermarcel10
    • Premium Supporter

    powermarcel10 Retired Team Member

    Joined:
    November 30, 2010
    Messages:
    2,839
    Likes Received:
    789
    Gender:
    Male
    Occupation:
    Callcenter Agent
    Location:
    Groningen
    Ratings:
    +1,028 / 4
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Hi SilentException ,

    thanks for you response..

    Actually, I only want to report it.. The message I get is a windows message, and not a Mediaportal message, so It'not nice.. You said It's a corupted subtitle file, I don't know, maybe it was something else, but I'm happy that the other subtitle file was working fine..

    It was a strange message, so I thought; Let's report it, that's all.. :)

    About the 2 translations with the same key.. What do you mean? There is only one translation for Dutch in the language folder of Subcentral..
     
  5. powermarcel10
    • Premium Supporter

    powermarcel10 Retired Team Member

    Joined:
    November 30, 2010
    Messages:
    2,839
    Likes Received:
    789
    Gender:
    Male
    Occupation:
    Callcenter Agent
    Location:
    Groningen
    Ratings:
    +1,028 / 4
    Home Country:
    Netherlands Netherlands
    Show System Specs
    BTW, here is an up-to-date Dutch language file.. There where missing around 10 strings..
     

    Attached Files:

    • nl.xml
      File size:
      11.9 KB
      Uploaded:
      December 8, 2011
      Views:
      130
    • Like Like x 1
  6. SilentException
    • Premium Supporter

    SilentException Retired Team Member

    Joined:
    October 27, 2008
    Messages:
    2,617
    Likes Received:
    1,125
    Gender:
    Male
    Location:
    Rijeka, Croatia
    Ratings:
    +1,129 / 0
    Home Country:
    Croatia Croatia
    <string Field="NoSubtitlesnFound">Geen ondertitelingen gevonden</string>
    <string Field="NoDownloadmappen">Geen geldige downloadmappen voor deze media gevonden.</string>

    Have wrong keys... NoSubtitlesnFound, NoDownloadmappen.

    There might be more.. still checking...


    Edit: SelectTaals, SelectDownloadmap

    In other words, you shouldn't translate Field= values (keys), only strings...

    Also found cause for error string in log:
    <string Field="Subtitles">Ondertitel(s)</string>
    <string Field="Subtitle">Ondertitel</string>
    <string Field="Subtitles">ondertitelingen</string>

    Translation for "Subtitles" key is defined twice.


    Pls fix it. All fields (keys) should be the same as in en-us. Only translations should differ.
     
  7. seco
    • Team MediaPortal

    seco Development Group

    Joined:
    August 7, 2007
    Messages:
    1,579
    Likes Received:
    897
    Gender:
    Male
    Ratings:
    +1,234 / 4
    Home Country:
    Finland Finland
    Show System Specs
    "Syntax error" is an error in the subtitle file itself and appears when the subtitle file is actually used during the playback -> no SubCentral related.
     
  8. powermarcel10
    • Premium Supporter

    powermarcel10 Retired Team Member

    Joined:
    November 30, 2010
    Messages:
    2,839
    Likes Received:
    789
    Gender:
    Male
    Occupation:
    Callcenter Agent
    Location:
    Groningen
    Ratings:
    +1,028 / 4
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Thanks..

    Very strange, all those errors in the file.. I know that I have only to translate the strings.. Did I make this file?? Maybe a long time ago when I didn't know anything about Mediaportal.. I have fixt them in the attachted file..

    About the string field you say, I think they are right.. In the original language file it's:

    <string Field="SubtitleS">Subtitle(s)</string>
    <string Field="Subtitle">Subtitle</string>
    <string Field="Subtitles">Subtitles</string>

    So they are set twice.. Only one time with a big S at the end, and one time with a small s.. In the Dutch translation file it is now:

    <string Field="SubtitleS">Ondertitel(s)</string>
    <string Field="Subtitle">Ondertitel</string>
    <string Field="Subtitles">Ondertitelingen</string>

    Right?

    Best regards, and thanks for your support.

    EDIT: A more strange thing is that the language file isn't work at all.. :s Have no idea why.. I can't find anything wrong in the file.. Whe I try to open the file I get this:

    Alle providers Alle gekozen providers Over Alle ({0}) ondertitelingen gedownloaded. Alle ({0}) ondertiteldownloads geannuleerd. Alle Alle ({0}) ondertitelingen verwijderd. SubCentral is een standalone ondertitelplug-in voor de HTPC-applicatie MediaPortal. Het doel van de plug-in is om de gebruiker de mogelijkheid te geven om ondertitelingen te zoeken en te downloaden voor films en TV-series welke worden beheerd middels de MovingPictures en MP-TVSeries plug-ins. Het biedt ook een eenvoudige interface die het mogelijk maakt op in andere toepassingen en plug-ins te worden gebruikt. De beste manier om deze plugin te gebruiken is door naar de MovingPictures of MPTVSeries plugin te navigeren en daar te kiezen voor 'Download ondertitelingen'. Bij MovingPictures (vereist is versie 1.0.3 of nieuwer), zal deze optie, afhankelijk van de gebruikte skin, zijn terug te vinden in het scherm of een menu. Bij MP-TVSeries (vereiste is versie 2.6.0 of nieuwer) is in het contextmenu de optie 'Download...' te vinden en vervolgens 'Ophalen ondertitel'. Indien gewenst kunnen de zoekopdrachten van deze plugin worden aangepast om zo eigen zoekopdrachten en websites te ondersteunen. Wanneer de plugin wordt gestart vanuit het Home Screen (zoals momenteel het geval is), is het mogelijk een handmatige zoekactie uit te voeren. Daarmee kan de gebruiker zijn eigen aangepaste zoekopdrachten uitvoeren voor de films of TV-series. Om de taal in te stellen waarin de ondertitelingen moeten worden gezocht moet het menu gebruikt worden. Gebruik de MediaPortal Configuratie om geavanceerde instellingen te wijzigen (selecteren, sorteren en hernoemen van groepen/provider, selecteren en sorteren van talen en het kiezen van de downloadlocatie). Wanneer de zoekopdracht is uitgevoerd kunnen de resultaten via het menu worden gesorteerd en uiteraard worden gedownload. Bezoek onze Google Code SubCentral projectpagina voor meer informatie! Terug Het laden van het skinbestand \voor SubCentral is niet gelukt. Annuleren Bevestigen Leeg bestanden Leeg media Download geannuleerd. Contextmenu Handmatig zoeken niet mogelijk omdat er \ngeen downloadmappen zijn ingesteld.\nGebruik de configuratie om deze in te stellen. Mediabestanden legen niet mogelijk omdat er \ngeen downloadmappen zijn ingesteld.\nGebruik de configuratie om deze in te stellen. Voltooid Standaard voor: {0} Downloadmap bestaat niet. Aanmaken? Download Download naar... Standaardmap {0} is niet beschrijfbaar! Maak een andere aan. Standaard downloadmap:\n{0}\nbestaat niet.\nAanmaken? Standaard Verwijder ondertitelingen Fout Externe plugin Fout(en) bij het downloading van ondertitelingen! Fout bij het downloading van ondertitelingen: {0} Fout(en) bij het ophalen van ondertitelingen! Fout(en) bij het ophalen van ondertitelingen: {0} Fout(en) bij het aanmaken van een map. Ondertitelingen gevonden Van: {0}
     

    Attached Files:

    • nl.xml
      File size:
      11.9 KB
      Uploaded:
      December 9, 2011
      Views:
      115
    • Like Like x 2
  9. SilentException
    • Premium Supporter

    SilentException Retired Team Member

    Joined:
    October 27, 2008
    Messages:
    2,617
    Likes Received:
    1,125
    Gender:
    Male
    Location:
    Rijeka, Croatia
    Ratings:
    +1,129 / 0
    Home Country:
    Croatia Croatia
    Thanks I will re-check the XML file soon. I think you did the first NL translation, but you can check it in configuration (About tab). All translators are listed there ;)

    SubtitleS and Subtitles are OK, they are not the same strings. It won't throw error anymore.

    If you open XML in Internet Explorer, that's how it will look. If you select "view source" or open it in text editor it should look OK.
     
  10. powermarcel10
    • Premium Supporter

    powermarcel10 Retired Team Member

    Joined:
    November 30, 2010
    Messages:
    2,839
    Likes Received:
    789
    Gender:
    Male
    Occupation:
    Callcenter Agent
    Location:
    Groningen
    Ratings:
    +1,028 / 4
    Home Country:
    Netherlands Netherlands
    Show System Specs
    I know about how it have to look like.. But open it in your webbrowser is a way to see if the file is corrupt or not.. If the file is okay, I looks different than when it is not.. But I have installed subcentral on my main machine, and that subcentral file works.. So I'm no adding the new stringfiles again.. So, let's see what happend.. ;)

    Well, the translated file was made by Henkie Flits.. So, not my mistake!! :p I'm busy with the new one, checking every string by hand..

    I'll post the new file this afternoon.. :)
     
  11. powermarcel10
    • Premium Supporter

    powermarcel10 Retired Team Member

    Joined:
    November 30, 2010
    Messages:
    2,839
    Likes Received:
    789
    Gender:
    Male
    Occupation:
    Callcenter Agent
    Location:
    Groningen
    Ratings:
    +1,028 / 4
    Home Country:
    Netherlands Netherlands
    Show System Specs
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!