System.NullReferenceException Error when opening or closing Mediaportal configuration (1 Viewer)

Messor

New Member
February 25, 2018
3
1
47
Germany Germany
System.NullReferenceException Error when opening or closing Mediaportal configuration AND 'Invalid File Handle 32' during installation.

Operating System Win 10 pro 64 bit with all updates
Intel Core I5
My problem is that cant save changes in the settings of the media portal configuration becouse of this error:

the input string has the wrong format

System.NullReferenceException: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.
bei MediaPortal.InputDevices.irremote.GetHCWPath()
bei MediaPortal.Configuration.Sections.Remote.LoadSettings()
bei MediaPortal.Configuration.SettingsForm.LoadSectionSettings(TreeNode currentNode)
bei MediaPortal.Configuration.SettingsForm.SettingsForm_Load(Object sender, EventArgs e)
bei System.Windows.Forms.Form.OnLoad(EventArgs e)
bei System.Windows.Forms.Form.OnCreateControl()
bei System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
bei System.Windows.Forms.Control.CreateControl()
bei System.Windows.Forms.Control.WmShowWindow(Message& m)
bei System.Windows.Forms.Control.WndProc(Message& m)
bei System.Windows.Forms.ScrollableControl.WndProc(Message& m)
bei System.Windows.Forms.Form.WmShowWindow(Message& m)
bei System.Windows.Forms.Form.WndProc(Message& m)
bei System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
bei System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
bei System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

mscorlib
Assembly-Version: 4.0.0.0.
Win32-Version: 4.7.2633.0 built by: NET471REL1LAST_C.
CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll.
----------------------------------------
Configuration
Assembly-Version: 1.18.100.0.
Win32-Version: 1.18.100.0.
CodeBase: file:///C:/Program%20Files%20(x86)/Team%20MediaPortal/MediaPortal/Configuration.exe.
----------------------------------------
System.Windows.Forms
Assembly-Version: 4.0.0.0.
Win32-Version: 4.7.2556.0 built by: NET471REL1.
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll.
----------------------------------------
System
Assembly-Version: 4.0.0.0.
Win32-Version: 4.7.2556.0 built by: NET471REL1.
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll.
----------------------------------------
System.Drawing
Assembly-Version: 4.0.0.0.
Win32-Version: 4.7.2556.0 built by: NET471REL1.
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll.
----------------------------------------
System.Configuration
Assembly-Version: 4.0.0.0.
Win32-Version: 4.7.2556.0 built by: NET471REL1.
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll.
----------------------------------------


(here come a lot more) stuff...

I already completly de/ reinstalled Mediaportal and also tryed the Pre-release Version and de/reinstalled Visual C++ (all of them), Msql ...
Next step would be setting up Windows but ... I don´t want to :-(
This Problem is accouring couple of month ago but i don´t mind. Now i bought a new 4kTV and wanted to try some new settings but as i said above, i can´t save the changes..
Sorry for my english, hope of some good ideas :unsure:
 

azzuro

Test Group
  • Team MediaPortal
  • May 10, 2007
    9,367
    4,994
    France - IDF
    France France
    Country flag
    hello, @Messor
    please can you provide wachtdog log ?

    about the file32 error during installation, we are aware of this, don't worry about that it's only error for installing font already present in system.
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,434
    10,256
    France
    France France
    Country flag
    Can you try to copy the folder to c:\MP for example ?
    Also just to confirm that MP can start, you can try to extract this folder to where you want like C:\MPTEST and see if it start :)

    Release_V465.zip :)

    I have also seen those crash on my laptop and not sure why but it seems related to anti-virus that broke something on install, i have excluded from Defender / MalwareBytes :p
     

    Messor

    New Member
    February 25, 2018
    3
    1
    47
    Germany Germany
    Hi sorry for having to wait ...
    I tested the zipped files and mediaportal starts without errors. (ok i cant start to look TV of course) but the configuration.exe throws out the same mistake as before. (screenshoots ) first picture is at the starting of the program and 2nd is when i try to close it.
     

    Attachments

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    B Overhaul IMDb+ rating system IMDb+ 5
    bta489 [solved] System goes to Standby during Amazon Prime Playback OnlineVideos 2
    high [unanswered] front end system for the aviation industry as an in flight entertainment system contactform feedback and requests 6
    J Mediaportal Standby prevented by Mediaportal system/ active ports General Support 13
    C Drive Type is not supported by system Allgemeines Support- und Diskussionsforum 3
    azzuro [Info] Full Windows 10 on ARM system Team Lounge 0
    T My trusted TBS 6922 DVB-S2 card won't work in new system....any ideas please!!? General Support 3
    A My HTPC+NAS setup aka extending my single seat system ;) Team Lounge 8
    Lehmden Sehr stromsparendes System mit 6 x SATA und 3 x PCIe, gibt es sowas? Mainboards/CPU/RAM 5
    U IR Blaster doesn't work after system wake/resume General Support 6
    morpheus_xx Downsizing my single seat system... Team Lounge 4
    J MP2 2.1.3 client network broadcast crippling other systems on network Submit: Bug Reports 29
    M 1.25.0 Tv Server Configuration Italian Dvb-t2 test channel preview error Television (MyTV frontend and TV-Server) 2
    G [solved] timeshift error Newcomers Forum 2
    C Can't install any extensions - DLL error Installation, configuration support 19
    horned_reaper Errors in FH log ... Fanart Handler 1
    joecrow 1.25.0 5031: Error on Install. Bugreports 24
    M MediaPortal2 TV Config Error on Install (0x80004005) General 7
    J Blue Screen Error Submit: Bug Reports 0
    G Q about scheduling weekly series when epg lists duplicate back to back episodes each week General Support 2
    Rob Hexenmeister Dependency error on install v2.3.2.0 OnlineVideos 28
    catavolt [WiP] When changing theme in my skins, I always get this error message in logs MediaPortal 1 9
    F Error invoking action 'GetNowNextProgramForGroup' Submit: Bug Reports 3
    B MP 2.2.3 Error playing videos from NAS Submit: Bug Reports 2
    vvulture UNKNOWN ERROR when starting live TV General Support 6
    Similar threads

























    Top Bottom