TBS: CI/CAM support and other improvements (6 Viewers)

vuego

Documentation Group
  • Team MediaPortal
  • August 5, 2006
    1,597
    746
    Göteborg
    Sweden Sweden
    Country flag
    Thanks, I'll be using DVB-S2 but It might be a mess as well if it doesn't work well with DVB-C. Yes, I'm out of PCIe slots so I'd have to get a new motherboard and PC case to get more slots :cautious:
     

    tvo81

    New Member
    April 6, 2021
    14
    0
    Great Britain (UK) Great Britain (UK)
    Country flag
    Hi there,

    Hoping someone can help me. I have a TBS S2 dual tuner (6910) and am trying to use it with a CI module. Ironically, after lots of tinkering I managed to get it working back in December (although only for one tuner), but after a recent hardware upgrade I'm back to square one....

    Issues:
    • When I scan for channels, the encrypted channels do not appeart (only a handful, instead of >250). Scanning FTA channels works fine.
    • I can't open the CAM menu.
    • (when I recently did manage to find scrambed channels - since lost functionality again), I could not watch the scrambled channels

    I have tried versions 1.22, 1.26 (which worked previously) and 1.27, in combination with the patch from page 81, without any luck. I've also tried the patch from page 51, again with no luck. Finally, I've tried quite a few versions of TbsCIapi.dll, to no avail.

    I would be very grateful if someone can give me some pointers as I haven't got a clue where I'm going wrong.

    Thanks for your feedback.
     

    te3hpurp

    Retired Team Member
  • Premium Supporter
  • September 23, 2008
    910
    231
    Rovaniemi
    Finland Finland
    Country flag
    HI.

    Im not 100% sure, but I think you should not use page 81 patch anymore. Code is merged to few latest releases, so in my opinion 1.27 shoudl work without patch. Only make sure TbsCIapi.dll is available in tvserver installation folder, and in tcservice setup make sure that cam is enabled.

    I have an old tbs dvb-c card and it works without patching, at least from version 1.26 onwards.

    ps. logs are mandatory to get help here :)
     

    tvo81

    New Member
    April 6, 2021
    14
    0
    Great Britain (UK) Great Britain (UK)
    Country flag
    Thanks a lot for your feedback te3hpurp!

    I'll try a clean install of 1.27 with only TbsCIapi.dll added to the install folder (and CAM ticked in the setup) and post the logs here. Sorry about not posting logs earlier, forum newbie here :)

    Thanks again
     

    tvo81

    New Member
    April 6, 2021
    14
    0
    Great Britain (UK) Great Britain (UK)
    Country flag
    So I installed 1.27, added TbsCIapi.dll. When scanning for channels first time it crashed. Second time it found <20 channels and after I got the pop up 'TV service not started'

    Logs attached :)
     

    Attachments

    te3hpurp

    Retired Team Member
  • Premium Supporter
  • September 23, 2008
    910
    231
    Rovaniemi
    Finland Finland
    Country flag
    I can't check logs right now, but you could also try to change setting of card,. If it is paused or stopped between tunes. If I remember right I had to change it
     

    te3hpurp

    Retired Team Member
  • Premium Supporter
  • September 23, 2008
    910
    231
    Rovaniemi
    Finland Finland
    Country flag
    Hi.

    No obivius reasons found for crash of tvserver. There are some things to check. For example tuning parameters your try to scan are missing:
    Error loading tuningdetails: System.IO.FileNotFoundException: Could not find file 'C:\ProgramData\Team MediaPortal\MediaPortal TV Server\TuningParameters\dvbs\1.9°E BulgariaSat 1.xml
    timestamp for that error is a bit confusing as it seems that scan is still going on as seen from tvservice log.

    Anyway there are quite a lot of:
    LockInOnSignal could not lock onto channel - no signal or bad signal

    So, maybe you should check signal quality and or tuning parameters you try to use. Second things to try is to increase timeout pat/pmt waiting during tune request. They can be alteredf in tvsetup. I cant remeber where though.

    Br,
     

    tvo81

    New Member
    April 6, 2021
    14
    0
    Great Britain (UK) Great Britain (UK)
    Country flag
    Great thanks a lot for checking. It seems it's scanning the wrong satellites then? As I'm trying to scan 23.5E.

    I'll dig a bit deeper tonight and see if I can make some progress.

    Thanks again!
     

    tvo81

    New Member
    April 6, 2021
    14
    0
    Great Britain (UK) Great Britain (UK)
    Country flag
    Update: I tried another clean install of MP 1.27, added TbsCIapi.dll, bearing in mind your points above.

    I scan 23.5E (Astra B), again only getting a handful of channels. I should point out that I always usually scan like this, thus not using the advanced tuning options. Until very recently, I would get all channels on 23.5E. When I had my dish installed back in November, the company placed a diseqc switch so that I can also watch 28.2E & 19.2E. When I scan those two, it works fine. When I use DVBViewer, scanning for channels works as it should.

    When you say "tuning parameters your try to scan are missing", should I be doing something prior to scanning? I did update the satellite list. I'm not sure why it finds 1.9°E BulgariaSat 1.xml to be missing, I'm not scanning for this satellite. I had a look in the folder C:\ProgramData\Team MediaPortal\MediaPortal TV Server\TuningParameters\dvbs and 158 files were updated when I refreshed the satellite list.

    Finally I also tried scanning just one transponder, and this time I did get all channels on that transponder. But after when I scanned for all of 23.5E, the same issue as before.

    Signal quality should be good, especially as it works with DVBViewer and because I could watch scrambled channels on 23.5E until 2 weeks ago.

    I'm really at a loss here, any feedback is much appreciated. Logs attached.
     

    Attachments

    tvo81

    New Member
    April 6, 2021
    14
    0
    Great Britain (UK) Great Britain (UK)
    Country flag
    Good news: I found the issue that was causing problems whilst scanning channels. So I can now scan properly. Next step: getting the CAM module to work. I'll have another crack at it tomorrow and post logs depending on how it goes.

    Thanks for your help so far, to be continued :)
     

    Users who are viewing this thread

    Similar threads
    OP Title Forum Replies Date
    N Tswriter Watch / Listen Media 51
    S External player in MP2 and see videos made with my cam? General 8
    C Digital Devices Cascading Cam Feature Requests 2
    rsbrux 1.27.0 Supported SQL Server version(s) / TV Service dependency on SQL Server / Wait for TV Server startup Installation, configuration support 4
    T [solved] WMA support General 22
    M Native Unicable Support Newcomers Forum 4
    R MP Support of Transparent Thumbs General Support 1
    J no TV support on 1.25 download Installation, configuration support 1
    horned_reaper [solved] HID commands are not processed when multiple applications with HID support are open General Support 16
    horned_reaper [solved] Add support for Bluetooth events Improvement Suggestions 2
    CyberSimian Support for control.isvisible() in expressions MediaPortal 1 8
    morpheus_xx [WiP] OnlineVideos: New browser based playback support using WebDriver, new Amazon siteutil MediaPortal 2 14
    M 2nd (Touch-)Display Support on MediaPortal 2 such MPDisplay++? General 5
    J Support waipu TV TV-Server 2
    doskabouter WebDAV support OnlineVideos 0
    K Multichannel audio and subtitles for TV not properly supported General Support 4
    CyberSimian Support pack for Ortek VRC-1100 and Hama 00052451 Remotes 6
    cbr954rr [Finished] [MP2-801] Support for tag image extraction Archive 7
    catavolt [solved] FanartHandler - Skin - Holiday and Spotlight support Fanart Handler 51
    C Drive Type is not supported by system Allgemeines Support- und Diskussionsforum 3
    raffe [solved] Export tool and import support from MP-TVSeries & Moving Pictures to MP2 General 23
    morpheus_xx General Testing TVE 3.5 Sat>IP support (MP2 only) TV Engine 47
    E M3U Playlist and EPG Support/Configuration Installation, configuration support 1
    G Mediaportal2 supported formats General 1
    M [solved] Stub Support General 11

    Similar threads

    Top Bottom