The DeleteRecordingOnDisk() runs forever if the file is not exist on the disk. (1 Viewer)

wouter1971

MP Donator
  • Premium Supporter
  • November 19, 2008
    911
    143
    Purmerend, Holland
    Netherlands Netherlands
    Country flag
    Hi,

    I get in the TVservice.log a forever running scheduler activity:
    This episode does not exist anymore and is deleted from the NAS.
    How can i fix this? I found a "Won't Fix " jira issue.
    If it's not gonna be fixed, how can i stop this?


    02-16 18:26:51,943] [Log ] [scheduler thread] [INFO ] - diskmanagement: Delete episode TvDatabase.Channel Divorce zondag 30 maart 2014 20:58:00
    [2015-02-16 18:26:51,943] [Log ] [scheduler thread] [INFO ] - diskmanagement: Delete episode TvDatabase.Channel Divorce zondag 30 maart 2014 20:58:00
    [2015-02-16 18:26:51,953] [Log ] [scheduler thread] [INFO ] - diskmanagement: Delete episode TvDatabase.Channel Divorce zondag 30 maart 2014 20:58:00
    [2015-02-16 18:26:51,953] [Log ] [scheduler thread] [INFO ] - diskmanagement: Delete episode TvDatabase.Channel Divorce zondag 30 maart 2014 20:58:00
    [2015-02-16 18:26:51,953] [Log ] [scheduler thread] [INFO ] - diskmanagement: Delete episode TvDatabase.Channel Divorce zondag 30 maart 2014 20:58:00
    [2015-02-16 18:26:51,953] [Log ] [scheduler thread] [INFO ] - diskmanagement: Delete episode TvDatabase.Channel Divorce zondag 30 maart 2014 20:58:00
    [2015-02-16 18:26:51,963] [Log ] [scheduler thread] [INFO ] - diskmanagement: Delete episode TvDatabase.Channel Divorce zondag 30 maart 2014 20:58:00
    [2015-02-16 18:26:51,963] [Log ] [scheduler thread] [INFO ] - diskmanagement: Delete episode TvDatabase.Channel Divorce zondag 30 maart 2014 20:58:00
    [2015-02-16 18:26:51,963] [Log ] [scheduler thread] [INFO ] - diskmanagement: Delete episode TvDatabase.Channel Divorce zondag 30 maart 2014 20:58:00
    [2015-02-16 18:26:51,963] [Log ] [scheduler thread] [INFO ] - diskmanagement: Delete episode TvDatabase.Channel Divorce zondag 30 maart 2014 20:58:00
    [2015-02-16 18:26:51,973] [Log ] [scheduler thread] [INFO ] - diskmanagement: Delete episode TvDatabase.Channel Divorce zondag 30 maart 2014 20:58:00


    https://issues.team-mediaportal.com/browse/MP1-4568
     

    morpheus_xx

    Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,482
    7,015
    Germany Germany
    Country flag
    Funny, I stumbled upon same bug :p

    My solution was to create the missing folder structure in explorer. Once I got it up to recording folder, it got immediately deleted and message was gone. No need to place a file, folders were enough for my case.

    Stupid bug...
     

    disaster123

    MP Donator
  • Premium Supporter
  • May 14, 2008
    3,546
    432
    Germany Germany
    Country flag
    $ git show dea90a5530e9a22aa81608
    commit dea90a5530e9a22aa81608692c964d44c6ac33b6
    Author: Stefan Priebe <stefan@prie.be>
    Date: Sat Sep 14 20:30:40 2013 +0200

    RecordingFileHandler: do not loop when recording dir does not exist

    diff --git a/TvEngine3/TVLibrary/TvService/DiskManagement/RecordingFileHandler.cs b/TvEngine3/TVLibrary/TvService/DiskManagement/Recordi leHandler.cs
    index 7ea94f4..e3b0402 100644
    --- a/TvEngine3/TVLibrary/TvService/DiskManagement/RecordingFileHandler.cs
    +++ b/TvEngine3/TVLibrary/TvService/DiskManagement/RecordingFileHandler.cs
    @@ -63,6 +63,10 @@ namespace TvService
    }
    filesDeleted = true;
    }
    + else {
    + Log.Debug("DeleteRecordingOnDisk: Directory does not exist!: '{0}'", Path.GetDirectoryName(fileNameForRec));
    + filesDeleted = true;
    + }
    }
    catch (Exception ex)
    {
     

    wouter1971

    MP Donator
  • Premium Supporter
  • November 19, 2008
    911
    143
    Purmerend, Holland
    Netherlands Netherlands
    Country flag
    Funny, I stumbled upon same bug :p

    My solution was to create the missing folder structure in explorer. Once I got it up to recording folder, it got immediately deleted and message was gone. No need to place a file, folders were enough for my case.

    Stupid bug...
    Thanks Morpheus for putting me in the right direction. I created the previous dir's and it looks like it doesn't come back. Thanks!
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom