Thumbnails - where are they stored | Page 2

Discussion in 'Installation, configuration support' started by Anthony Vaughan, September 13, 2018.

  1. Anthony Vaughan
    • Premium Supporter

    Anthony Vaughan MP Donator

    Joined:
    June 25, 2015
    Messages:
    222
    Likes Received:
    27
    Gender:
    Male
    Ratings:
    +44 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    I'll try to explain this issue in more detail.

    Prior to 1.20.0, when I went into Videos and selected a folder, any videos that had already been processed would create and display a thumbnail both to the left of the video name and in the section to the right:

    upload_2018-9-14_18-56-10.png

    as you can see above.

    However, in 1.20.0, what I get is the following:

    upload_2018-9-14_18-57-36.png

    No thumbnails.

    However, in 1.20.0, when I go to a folder that contains films that have been scanned into the VideoDatabaseV5.db3, then thumbnails do appear next to the films:

    upload_2018-9-14_19-16-19.png

    I have noticed one problem in 1.19.0; namely that the thumbnailer does not process .wtv files correctly. For .wtv files, thumbnails only seem to appear when the files are scanned. 1.19.0 does process .dvr-ms files correctly.

    I hope this helps.



    Tony
     
    • Thank You! Thank You! x 1
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. regeszter
    • Premium Supporter

    regeszter Retired Team Member

    Joined:
    October 29, 2005
    Messages:
    5,335
    Likes Received:
    2,863
    Ratings:
    +5,152 / 18
    Home Country:
    Hungary Hungary
    Please step out from ".." and upload the screenshot again.
     
  4. Anthony Vaughan
    • Premium Supporter

    Anthony Vaughan MP Donator

    Joined:
    June 25, 2015
    Messages:
    222
    Likes Received:
    27
    Gender:
    Male
    Ratings:
    +44 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Hi CyberSimian

    The issue I am trying to describe does not depend on how the files are imported into MediaPortal.

    In 1.19.0, just going into a folder automatically instigates processing to add thumbnails to video files in the folder (that have not already been given thumbnails).

    This no longer happens, for whatever reason, under 1.20.0. Weirdly though, in both versions, .dvr-ms files do get thumbnails!!!

    Tony
     
  5. Anthony Vaughan
    • Premium Supporter

    Anthony Vaughan MP Donator

    Joined:
    June 25, 2015
    Messages:
    222
    Likes Received:
    27
    Gender:
    Male
    Ratings:
    +44 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Hi regeszter

    Not sure what you mean. Are you not seeing the screenshots?

    Tony
     
  6. regeszter
    • Premium Supporter

    regeszter Retired Team Member

    Joined:
    October 29, 2005
    Messages:
    5,335
    Likes Received:
    2,863
    Ratings:
    +5,152 / 18
    Home Country:
    Hungary Hungary
    Please try this early 1.21 Pre Release.
     

    Attached Files:

  7. Anthony Vaughan
    • Premium Supporter

    Anthony Vaughan MP Donator

    Joined:
    June 25, 2015
    Messages:
    222
    Likes Received:
    27
    Gender:
    Male
    Ratings:
    +44 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Hi CyberSimian

    I think I should have pointed out that 1.20.0 is processing thumbnails for .dvr-ms files as expected, but not for .ts or .wtv files.

    Tony
     
  8. regeszter
    • Premium Supporter

    regeszter Retired Team Member

    Joined:
    October 29, 2005
    Messages:
    5,335
    Likes Received:
    2,863
    Ratings:
    +5,152 / 18
    Home Country:
    Hungary Hungary
    Képkivágás.PNG
     
  9. Anthony Vaughan
    • Premium Supporter

    Anthony Vaughan MP Donator

    Joined:
    June 25, 2015
    Messages:
    222
    Likes Received:
    27
    Gender:
    Male
    Ratings:
    +44 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Hi regeszter

    I've downloaded the pre-release file and will get back to you tomorrow with the results.

    Off to have my dinner now.

    Everyone: thank you very much for all the attention to this issue.

    Tony
     
    • Thank You! Thank You! x 1
  10. Anthony Vaughan
    • Premium Supporter

    Anthony Vaughan MP Donator

    Joined:
    June 25, 2015
    Messages:
    222
    Likes Received:
    27
    Gender:
    Male
    Ratings:
    +44 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Okay. Put dinner off and installed the pre-release version on my development machine.

    All is now working as in 1.19.0. It is automatically processing .dvr-ms and .ts files, but not .wtv files. Shouldn't thumbnails be produced for all allowed extensions?

    upload_2018-9-14_19-53-41.png

    regeszter: below is one level up from the screenshot:

    upload_2018-9-14_19-58-1.png

    Have really got to go now.

    Will resume checking progress tomorrow.

    Tony
     
    • Thank You! Thank You! x 1
  11. Anthony Vaughan
    • Premium Supporter

    Anthony Vaughan MP Donator

    Joined:
    June 25, 2015
    Messages:
    222
    Likes Received:
    27
    Gender:
    Male
    Ratings:
    +44 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Okay. I think I have finally worked out what is going on.

    Under 1.19.0, thumbnails were generated for .dvr-ms and .ts files, but not for .wtv files - the latter were being sent to the VideoThumbBList table and were thus excluded from thumbnail processing.

    Under the pre-release 1.20.0 version, the behaviour was the same as for 1.19.0.

    The final release of 1.20.0 processes .dvr-ms to correctly produce thumbnails, but both .ts and .wtv files are sent to the VideoThumbBList table.

    upload_2018-9-15_7-38-49.png

    I think this explains all of the issues I have been listing above. In reality, the logic of the thumbnail processing has not changed, it is just that the file types allowed for thumbnail processing have changed.

    Does this now make sense?

    Please let me know if you want me to do any further testing.

    Tony
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!