[Bug] #totalduration not calculated when loading existing playlist (1 Viewer)

pilehave

Community Skin Designer
  • Premium Supporter
  • April 2, 2008
    2,566
    521
    Hornslet
    Denmark Denmark
    • Thread starter
    • Moderator
    • #1
    MediaPortal Version: SVN 27097
    MediaPortal Skin: Blue3Wide
    Windows Version: Windows 7 x64

    Hi!

    #totalduration is not set when navigating playlist in some situations.

    It works if you go to My Music, press F9 to show contextmenu, choose first option to add the album or track to playlist. Then #totalduration is filled.

    If you instead load an existing playlist, #totalduration is never calculated.

    From what I can tell, this is (or should be) called in GUIMusicBaseWindow.cs around line 668 or so. I added logging to check this:

    Code:
            GUIListItem item = facadeLayout[i];
            MusicTag tag = (MusicTag)item.MusicTag;
            if (tag != null)
            {
              Log.Info("Testing tag"); //This is never logged when loading a playlist. The underlying code is then never executed.
    #totalduration is supposed to replaced #itemcount for music, so this should definately be fixed.
     

    pilehave

    Community Skin Designer
  • Premium Supporter
  • April 2, 2008
    2,566
    521
    Hornslet
    Denmark Denmark
    • Thread starter
    • Moderator
    • #3
    That would be great, I really like how flexible the whole skin-engine is turning out to be, after all the work put into it :)
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom