tsreader.ax not registered (1 Viewer)

Feelgood1

Portal Member
March 6, 2012
13
1
47
Germany Germany
Country flag
After installing 1.16 PreRelease on server and client, I stumbled over a problem on my Win7 client, where the server under Win10 is running+playing without any problem. Starting live-TV on the client always leads to "Abspielen nicht möglich: stream3". Trying to play any recorded TV leads to a similar error "Abspielen nicht möglich: " + different 8-digit code. Connection and network problems have been checked and where excluded as source of the problem.

I hunted down the problem to the new tsreader.ax.

[2016-12-29 09:08:25,204] [Error ] [FilterChecker] [ERROR] - TVHome: *** WARNING *** Unable to detect registered filter: TsReader.ax!
[2016-12-29 09:08:34,741] [Error ] [MPMain ] [ERROR] - TSReaderPlayer: Exception while creating DShow graph Die COM-Klassenfactory für die Komponente mit CLSID {B9559486-E1BB-45D3-A2A2-9A7AFE49B23F} konnte aufgrund des folgenden Fehlers nicht abgerufen werden: 80040154 Klasse nicht registriert (Ausnahme von HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).
[2016-12-29 09:08:34,757] [Error ] [MPMain ] [ERROR] - TSReaderPlayer:GetInterfaces() failed

Now trying to register the library leads to the following message.

upload_2016-12-29_9-37-38.png


While the installation a message "Invalid file handle 32" comes up twice but ends with a "congratulations" dialogue. The instalaltion log does not give a hint about what went wrong.

As I expected a missing dependency for tsreader.ax might be the problem, I checked installed packages and re-installed
  • Microsoft Visual C++ 2008/2010/2012/2013/2015
  • Microsoft .NET 3.5/4.5
but had no luck. The problem remains. Could you give me a hint? Thanks in advance!
 

mm1352000

Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    As I expected a missing dependency for tsreader.ax might be the problem, I checked installed packages and re-installed
    • Microsoft Visual C++ 2008/2010/2012/2013/2015
    Yeah, this is a good idea.
    Just to make sure: did you install the 32 bit (x86) versions?
    (MP doesn't use/recognise 64 bit (x86_64) versions.)
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Hmmm, strange.
    The main new requirement with MP 1.16 PR is the C++ 2015 redistributable... but you said you already reinstalled the x86 version of that redistributable, so... :confused:

    Please try to check for missing dependencies for TsReader using Dependency Walker:
    http://www.dependencywalker.com/

    Make sure to use the x86/32 bit version again.
     

    Feelgood1

    Portal Member
    March 6, 2012
    13
    1
    47
    Germany Germany
    Country flag
    Thanks for the hint. I checked the dependencies and found some libraries (API-MS-WIN-CRT...) not existing. So I removed the C++2015 redistributable, as provided by MS and re-installed MP from scratch, which did the trick, even is there are still some unresolved dependencies reported by Dependency Walker.

    API-MS-WIN-APPMODEL-RUNTIME-L1-1-0.DLL
    API-MS-WIN-CORE-WINRT-ERROR-L1-1-0.DLL
    API-MS-WIN-CORE-WINRT-L1-1-0.DLL
    API-MS-WIN-CORE-WINRT-ROBUFFER-L1-1-0.DLL
    API-MS-WIN-CORE-WINRT-STRING-L1-1-0.DLL
    API-MS-WIN-SHCORE-SCALING-L1-1-1.DLL
    DCOMP.DLL
    GPSVC.DLL
    IESHIMS.DLL

    As MP is now back running, I expect this is no problem. Thanks for your quick and efficient support.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom