TVserver looses HDHR tuners

Discussion in 'General Support' started by chaosmstr, June 19, 2016.

  1. chaosmstr

    chaosmstr Portal Member

    Joined:
    February 25, 2016
    Messages:
    11
    Likes Received:
    1
    Gender:
    Male
    Ratings:
    +1 / 0
    Home Country:
    United States of America United States of America
    I have MP1.14 running properly as a backend for Kodi 16 with the 3 tuner HDHR prime.
    Win7 64, 8Mb memory, 120Gb flash drive for OS and programs, 8Tb spinning disks for storage. Latest drivers for everything.
    Took me a while to get TVServer working properly, but now that I have, It's wonderful.
    Much better video quality through Kodi than the WMCServer plugin.

    Occasionally, I will have one or more tuners suddenly go from ATSC to "unknown" in the servers window of the tvserver service.
    Simply restarting the service does not always bring them back up.
    I have to uncheck the tuner in the servers tab, restart service, recheck the tuner and restart service again.
    I can be watching live TV in one room, and go to start watching in another room and that machine will come back with "no tuners available" while the first is still playing just fine.

    What would cause the service to suddenly lose the tuner config?


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    Hi

    Let's take the question first:
    The service is not losing the tuner config. Rather, it's losing contact with the tuners themselves.

    It's not possible to give an answer to the "what would cause..." part without log files and more details. The possibilities - ranging from network issues, firewall configuration issues, tuner issues, TV Server issues... and the list goes on - are just too numerous to give a specific and correct response.

    As previously hinted, this means that TV Server has lost contact with those tuners.

    When you say "restart" do you mean restart via TV Server config -> "manual control" section or Windows service managment... or do you mean TV Server's automatic restart which occurs when you change configuration?
    (There's a subtle but important difference.)

    Also, are you aware that it can take up to 1 minute (10 minutes if you haven't installed -->this<-- patch) for TV Server to detect CableCARD tuners after restarting?
    While the tuners are being detected they'll be marked as "unknown". If you wait one minute then restart TV Server Configuration (because the tuner list under servers doesn't update on-the-fly) you may well see that the tuners have been detected (ie. changed from "unknown" to "ATSC") in that time.

    Again, there are several possible explanations for this. Log files would be needed in order to begin trying to understand what's going on.
     
  4. chaosmstr

    chaosmstr Portal Member

    Joined:
    February 25, 2016
    Messages:
    11
    Likes Received:
    1
    Gender:
    Male
    Ratings:
    +1 / 0
    Home Country:
    United States of America United States of America
    I'm referring to TvServer.. I will find and post logs for you.
    I've done a manual restart and not had all the tuners show up.
    When I deselect tuners, any other tab selection auto-restarts the service.

    The patch mentioned is from 2014. Is this not already included in the latest version of MP1?
     
  5. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    Nope. The instructions in the first post of that thread are still correct for MP1.14 as of today.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!