Umschalt Zeiten Live-TV werden immer schlechter! (1 Viewer)

PrivotSponge

MP Donator
  • Premium Supporter
  • October 20, 2009
    276
    6
    BaWü
    Home Country
    Germany Germany
    Hi,

    ich habe mein System Anfang September neu aufgesetzt (neue Hardware)
    Seit dem lief eigentlich alles recht flüssig was MP angeht.
    Gestern ist mir allerdings aufgefallen, dass die Umschaltzeiten bei 8-9 sek liegen!
    (wird bei TV-Config unter testing channels bei geschlossenem MP auch angezeigt
    --> liegt also am TV-Server oder Datenbank.)
    Installiert ist MP, sowie auch win7 auf einer flotten 128 GB SSD (siehe specs)
    Timeshifting, 2 GB, liegt auf einer Ramdisk (Dataram)

    Abhilfe schaffte auch nicht, dass ich die Datenbank mit MySQL GUI tools überprüft und repariert habe.
    Es wurden keine Fehler gefunden. (Tut siehe hier: https://forum.team-mediaportal.com/threads/mysql-datenbank-reparieren.74668/ )
    Die verwendeten Codecs haben auch keine Einfluss darauf (MS DTV, LAV und DIVX)

    Darauf hin, habe ich meine Kanal-Liste mit der Exportfunktion des TVservers gesichert, dann den TVserver sowie MySQL deinstalliert. Anschließend habe ich noch die TV-Server Datenbank gelöscht.
    Dann hab ich alles wieder installiert und die Kanalliste importiert.
    Jetzt lagen die Umschaltzeiten bei sage und schreibe 800-900 ms !!
    Nun habe ich wieder das EPG eingerichtet (~80 Sender: 90% über MC2xml / 10% DVC-C / 10% WebEPG)

    Dummerweise liegen die Umschaltzeiten jetzt wieder bei 3 sek :(
    Wäre schon nett wenn sie dauerhaft unter 1 Sek wären!


    Liegt das jetzt nun an der Menge der Daten und/oder an MySQL? (Ordner der Datenbank MPTVdb ist 7,1 MB groß)
    Wäre vlt MS SQL 2005 ,oder ne andere Datenbak besser(schneller) ?

    P.S.: ich brauche nicht unbedingt 80 sender mit vollem EPG, leider schaffe ich es nicht, bei XMlTV die unnötigen, z.b. 3x QVC und anderer Mist, rauszuschmeißen. Ist wohl ein bug des Plugins.

    Hat jemand für mich einen Rat?

    Gruß Privot Sponge
     
    Last edited:

    KDaddy

    Portal Member
    October 23, 2010
    8
    1
    Home Country
    Germany Germany
    Hallo,
    eine Lösung suche ich auch, zumal ich in einer Multiseat Umgebung fernsehe und 10 Sekunden Umschaltzeit krass sind. Anfangs hatte ich auch 1-3 Sekunden.
    Ich benutze ebenfalls MySQL aber als EPG Anwendung TVMovie.

    Eine Neuinstallation scheue ich, es ist eigentlich ansonsten alles perfekt eingerichtet. Vielleicht kann jemand die Ursache identifizieren, dann kann ich gerne Gegenmaßnahmen treffen.

    Viele Grüße
     

    PrivotSponge

    MP Donator
  • Premium Supporter
  • October 20, 2009
    276
    6
    BaWü
    Home Country
    Germany Germany
    Hat denn keiner Erfahrung mit MS SQL? Gibt hier zwar schon ein paar Threads dazu, die betreffen aber nicht direkt die Umschaltzeiten...

    Oder weiß jemand, wie man dem XMTV-Plugin beibringt, nicht alle gefundenen Seder automatisch zu mappen?
    Gibt es vlt ein zusätzliches (besseres) XMLTV plugin? (Mal von TVMovie abgesehen)?
     

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,544
    3,932
    Lehmden
    Home Country
    Germany Germany
    Hi.
    Ich nutze MSSQL 2005 Express seit einiger Zeit, da MySQL bei mir extreme Performance Probleme verursacht hat (80-100% CPU Load bei DB Aktivitäten). Allerdings hatte ich nie Probleme mit den Umschaltzeiten, weder mit MySQL noch jetzt mit MSSQL, von daher kann ich nicht viel dazu beitragen. Meine Umschaltzeiten liegen und lagen stets unter 1 Sekunde. Ich nutze mc2xml in Kombination mit dem XMLTV plugin für ca 80% aller Sender, für die ich EPG haben will. Der Rest ist dabei leider nicht vorhanden. Für den Rest habe ich das "normale" DVB- EPG im Einsatz und für AnixeHD und ServusTVHD das "normale" WebEPG Plugin... Gibt für mich ein vollwertiges EPG ohne Probleme... QVC und ähnliches hat dabei natürlich kein EPG, logisch... Ich habe viel eher das Problem, das XMLTV viel zu wenig Sender automatisch mapped, ich muss da viel mit der Hand nachhelfen.

    Beim "messen" der Umschaltzeiten darf man die in MP konfigurierte Verzögerung allerdings nicht mit messen, da diese ja gewünscht ist (um z.B. mehrstellige Kanalnummern eintippen zu können) Und diese kann man ja bis auf 0 zurück schrauben. Ich hab hier 1 Sekunde stehen, so das der komplette Umschaltvorgang ca 2 Sekunden braucht. Eine Sekunde, bis das System reagiert und eine weitere, damit der Tuner umschalten kann. Geht sogar beim Wechsel von HD auf SD Sender und vice versa. Nur beim ersten Tunen (also beim Start des Live TV) dauert es etwas länger, so 3-4 Sekunden, bis Bild kommt. Da muss halt erst die Verbindung zum TV Server hochgefahren werden, der Tuner initialisiert werden, usw... Das kann schon mal ein bisschen dauern und ist nicht schlimm. Ein "normaler" TV braucht nach dem Einschalten auch etwas, bis er Bild liefert...
     

    PrivotSponge

    MP Donator
  • Premium Supporter
  • October 20, 2009
    276
    6
    BaWü
    Home Country
    Germany Germany
    Danke für die Antworten!

    Werde mal MS SQL 2005 austesten (obwohl ich keine Probleme mit der CPU-Last habe)

    Auf meinem alten System hatte ich auch SQL 2005 drauf, habe aber keinen Unterschied bemerkt (ok, hab auch nicht darauf geachtet)
    Ich versuch ausserdem noch via MC2XML einen andere Liste zu nehmen. Ich glaube, ich habe Astra Ost ausgewählt und dort werden die ganzen Shoppingkanäle mit gemappt (insg. 66 sender)
     

    KDaddy

    Portal Member
    October 23, 2010
    8
    1
    Home Country
    Germany Germany
    Hallo,

    vielleicht hilft es ja weiter, ich konnte mein Problem lösen: Bei waren es die Protokolle. Sie waren mittlerweile 1 GB groß. Nach dem Löschen der Protokolldateien konnte ich wieder auf meine gewohnten Umschaltzeiten vertrauen.

    Viele Grüße
     

    PrivotSponge

    MP Donator
  • Premium Supporter
  • October 20, 2009
    276
    6
    BaWü
    Home Country
    Germany Germany
    Hallo KDaddy,

    meinst du die logs aus \programdata\team mediaportal\mediaportal TV server\log ? Oder noch weitere?
     

    gurken

    MP Donator
  • Premium Supporter
  • August 7, 2009
    954
    105
    Home Country
    Austria Austria
    Hallo,

    vielleicht hilft es ja weiter, ich konnte mein Problem lösen: Bei waren es die Protokolle. Sie waren mittlerweile 1 GB groß. Nach dem Löschen der Protokolldateien konnte ich wieder auf meine gewohnten Umschaltzeiten vertrauen.

    Viele Grüße
    welche Protokolle?
     

    Users who are viewing this thread

    Top Bottom