"Unable to create graph for this device" message with WinTV HVR-950Q

Discussion in 'Installation, configuration support' started by rafty99, September 14, 2008.

  1. rafty99

    rafty99 New Member

    Joined:
    September 14, 2008
    Messages:
    1
    Likes Received:
    0
    Ratings:
    +0 / 0
    Home Country:
    Canada Canada
    MediaPortal Version: 1.0 RC2 with SVN 0.9.2.20143
    MediaPortal Skin: BlueTwo
    Windows Version: Windows XP Pro (SP2)
    CPU Type: Intel P4 3.2GHz
    HDD: Western Digital 500GB
    Memory: 2GB
    Motherboard: P4C800-E
    Motherboard Chipset: i975
    Motherboard Bios: Phoenix Bios
    Video Card: ATI Radeon X1600
    Video Card Driver: Catalyst 06.3
    Sound Card: Audigy 2 ZS Planitum Pro
    Sound Card Driver: 1.82
    1. TV Card: Hauppage WinTV HVR-950Q
    1. TV Card Type: Hybrid NTSC/ATSC/QAM
    1. TV Card Driver: 1.84 (4.6A CD Version)
    MPEG2 Video Codec: MainConcept (MCE) MPEG Encoder
    MPEG2 Audio Codec: MainConcept (MCE) MPEG Encoder
    HTPC Case: Rackmount
    Cooling: Air
    Power Supply: 550W
    Remote: Hauppauge 21-button device
    TV: Viewsonic 24" Wide
    Software: All the recommended patches was applied and the .NET 3.5, WMP 11.0 installed.


    Hello,

    I'm new to this forum and media center stuff in general. I try to configure my
    WinTV HVR-950Q with MediaPortal but so far don't have any succes doing it. I
    try the TV-Server first but ran in too many problems and I had to re-install
    everything at the end. :)

    Now I just want to get the analog tuner working with the built-in TV module.
    I read the wiki and the forum to learn how to configure the tuner manualy and
    was able to get passed the "No video capture card(S) were found..." but been
    stuck at "Unable to create graph for this device" but I think I'm not that far
    of a solution.

    I found on this forum many people using the WinTV HVR-900/950 without any
    problem so I thought the graph used by the HVR-950 model would be similar to
    the 950Q but to my surprise they don't use the same filters.

    Here's a picture of my graph attached and the XML conversion added to
    CaptureCardDefinitions.xml

    Code (Text):
    1.  
    2.   <capturecard commercialname="Hauppauge HVR-950Q (NTSC)" capturename="WinTV HVR-950 Capture" devid="vid_2040&amp;pid_7200">
    3.     <capabilities tv="true" radio="false" mpeg2="true" mce="false" sw="false" bda="false"></capabilities>
    4.     <tv>
    5.       <interface cat="encoder" video="" audio="" mpeg2="0"></interface>
    6.       <filters>
    7.         <filter cat="tvtuner" name="WinTV HVR-950 Tuner" checkdevice="true"></filter>
    8.         <filter cat="tvaudio" name="WinTV HVR-950 TV Audio" checkdevice="true"></filter>
    9.         <filter cat="crossbar" name="WinTV HVR-950 Xbar" checkdevice="true"></filter>
    10.         <filter cat="capture" name="WinTV HVR-950 Capture" checkdevice="true"></filter>
    11.         <filter cat="encoder" name="MainConcept (MCE) MPEG Encoder" checkdevice="false"></filter>
    12.       </filters>
    13.       <connections>
    14.         <connection sourcefilter="tvtuner" sourcepin="0" sinkfilter="crossbar" sinkpin="0"></connection>
    15.         <connection sourcefilter="tvtuner" sourcepin="1" sinkfilter="tvaudio" sinkpin="0"></connection>
    16.         <connection sourcefilter="tvaudio" sourcepin="0" sinkfilter="crossbar" sinkpin="3"></connection>
    17.         <connection sourcefilter="crossbar" sourcepin="0" sinkfilter="capture" sinkpin="0"></connection>
    18.         <connection sourcefilter="crossbar" sourcepin="1" sinkfilter="capture" sinkpin="1"></connection>
    19.         <connection sourcefilter="capture" sourcepin="0" sinkfilter="encoder" sinkpin="0"></connection>
    20.         <connection sourcefilter="capture" sourcepin="2" sinkfilter="encoder" sinkpin="1"></connection>
    21.       </connections>
    22.     </tv>
    23.   </capturecard>
    24.  
    When I play the graph from GraphEdit everything work perfectly and I'm
    able to record a mpeg file without any problem using the "MainConcept
    (MCE) MPEG Encoder". Filter's name and pin connection in the XML are
    well translated I guest but when I take a look at the configuration.log
    file I get this:

    Code (Text):
    1.  
    2. 2008-09-13 12:24:55.640625 [Info.][Config Main]: device:WinTV HVR-950 Capture id:@device:pnp:\\?\usb#vid_2040&pid_7200&mi_00#7&2cb2d6d3&0&0000#{65e8773d-8f56-11d0-a3b9-00a0c9223196}\{da11afe0-4c27-11dc-beb4-00a0c9f21fc7}
    3. 2008-09-13 12:24:55.640625 [Info.][Config Main]: device:Hauppauge PVR Capture (PCI) id:@device:sw:{860BB310-5D01-11D0-BD3B-00A0C911CE86}\Solo Capture
    4. 2008-09-13 12:24:55.640625 [Info.][Config Main]: device:RLVirCam id:@device:sw:{860BB310-5D01-11D0-BD3B-00A0C911CE86}\{0D04D564-08A6-4763-992F-F61D7A324ADF}
    5. 2008-09-13 12:24:55.640625 [Info.][Config Main]: device:WinTV HVR-950 BDA Capture id:@device:pnp:\\?\usb#vid_2040&pid_7200&mi_03#7&2cb2d6d3&0&0003#{fd0a5af4-b41d-11d2-9c95-00c04f7971e0}\{da11afe4-4c27-11dc-beb4-00a0c9f21fc7}
    6. 2008-09-13 12:24:55.656250 [Info.][Config Main]: Adding name:Hauppauge HVR-950Q (NTSC) id:vid_2040&pid_7200 type:Analog
    7. 2008-09-13 12:24:55.656250 [Info.][Config Main]: TVCapture.CreateGraph() Card:1
    8. 2008-09-13 12:24:55.671875 [Warn.][Config Main]: VMR9: ctor() - DX9Device == null!
    9. 2008-09-13 12:24:55.671875 [Debug][Config Main]: VMR9: ctor() _renderFrame == null
    10. 2008-09-13 12:24:55.671875 [Info.][Config Main]: SinkGraphEx:CreateGraph() IN
    11. 2008-09-13 12:24:55.703125 [Info.][Config Main]:         key:SYSTEM\CurrentControlSet\Enum\PCI\vid_2040&pid_7200&mi_00\7&2cb2d6d3&0&0000
    12. 2008-09-13 12:24:55.703125 [Info.][Config Main]: LoadDefs for device at
    13. 2008-09-13 12:24:55.703125 [Info.][Config Main]:         key:SYSTEM\CurrentControlSet\Enum\PCI\vid_2040&pid_7200&mi_00\7&2cb2d6d3&0&0000
    14. 2008-09-13 12:24:55.703125 [Info.][Config Main]: defs loaded for device at
    15. 2008-09-13 12:24:55.703125 [Info.][Config Main]:  CaptureCard WinTV HVR-950 Capture NOT supported, no definitions found
    16. 2008-09-13 12:24:55.703125 [ERROR][Config Main]:  CaptureCard WinTV HVR-950 Capture NOT supported, no definitions found
    17. 2008-09-13 12:24:55.703125 [Info.][Config Main]: SinkGraphEx:card does not contain filters?
    18. 2008-09-13 12:24:55.703125 [ERROR][Config Main]: SinkGraphEx:card does not contain filters?
    19. 2008-09-13 12:24:55.703125 [Info.][Config Main]: TVCapture.DeleteGraph() Card:1
    20. 2008-09-13 12:24:57.156250 [Info.][Config Main]: TVCapture.CreateGraph() Card:1
    21. 2008-09-13 12:24:57.156250 [Warn.][Config Main]: VMR9: ctor() - DX9Device == null!
    22. 2008-09-13 12:24:57.156250 [Debug][Config Main]: VMR9: ctor() _renderFrame == null
    23. 2008-09-13 12:24:57.156250 [Info.][Config Main]: SinkGraphEx:CreateGraph() IN
    24. 2008-09-13 12:24:57.156250 [Info.][Config Main]: SinkGraphEx:card does not contain filters?
    25. 2008-09-13 12:24:57.156250 [ERROR][Config Main]: SinkGraphEx:card does not contain filters?
    26. 2008-09-13 12:24:57.171875 [Info.][Config Main]: TVCapture.DeleteGraph() Card:1
    27. 2008-09-13 12:25:03.234375 [Info.][2]: SQLiteClient: Closing database: RadioDatabase4.db3
    28. 2008-09-13 12:25:03.234375 [Info.][2]: SQLiteClient: Closing database: TVDatabaseV21.db3
    29. 2008-09-13 12:25:03.250000 [Info.][2]: SQLiteClient: Closing database: MusicDatabaseV10.db3
    30.  
    Looks like The WinTV HVR-950 Capture module is not supported. How can I fix that?



    Regards
     

    Attached Files:

  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Malebolgia

    Malebolgia Portal Member

    Joined:
    September 4, 2005
    Messages:
    6
    Likes Received:
    0
    Location:
    Ridgewood, NJ USA
    Ratings:
    +0 / 0
    I am looking to solve this too.
     
  4. Malebolgia

    Malebolgia Portal Member

    Joined:
    September 4, 2005
    Messages:
    6
    Likes Received:
    0
    Location:
    Ridgewood, NJ USA
    Ratings:
    +0 / 0
    Is there any way to get the 950q to work?
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!