"Unable to create graph" Twinhan DVB-S (1 Viewer)

HACH

Portal Member
September 10, 2005
26
0
Zurich
Home Country
Switzerland Switzerland
Country flag
Area: Media Portal Program MP Version: 0.2.0 RC1 with mediaportal-cvs-09-10-2005--08-41
Skin: MCE
Windows Version: XP SP2
CPU Type: Intel P4 3 GHZ
Memory: 1 GB
Motherboard Chipset: manufacturer and model
Video Card: Radeon X300
Video Card Driver: driver version you used for testing
Video Render Type: VMR9 or Overlay
Video Codec Type & Version: video codec you used for testing
Audio Codec Type & Version: audio codec you used for testing
TV Card: Digital Rise (Twinhan) PCI SAI CI (1032A)
TV Card Type: software / hardware / DVB
TV Card Driver: Twinhan BDA Capture and Tuner Driver 1.2.2.0
Optional Log: see below
Optional References: any reference

Synopsis: While adding the TV card the message "unable to create a graph for this device!!" appears.

The card worked with TwinhanDTV including CAM Viacess for Swiss TV. (The Twinhan drivers were replace by the BDA afterwards).

Capture Log:
0.09.2005 13:28:11 LoadDefinitions() card:0
10.09.2005 13:28:11 video device moniker :mad:device:pnp:\\?\pci#ven_109e&dev_0878&subsys_00011822&rev_11#4&5855be9&0&11f0#{fd0a5af4-b41d-11d2-9c95-00c04f7971e0}\{4f9853cf-2b2c-4d2a-b66f-35812f833014}
10.09.2005 13:28:11 captureDeviceDeviceName:mad:device:pnp:\\?\pci#ven_109e&dev_0878&subsys_00011822&rev_11#4&5855be9&0&11f0
10.09.2005 13:28:11 filter networkprovider=Microsoft DVBS Network Provider
10.09.2005 13:28:11 filter tunerdevice=TwinHan PCI BDA Tuner Filter
10.09.2005 13:28:11 Filter tunerdevice not found in definitions file
10.09.2005 13:28:11 Card:1 CreateGraph
10.09.2005 13:28:11 DVBGraphBDA:CreateGraph().
10.09.2005 13:28:11 DVBGraphBDA: Added filter <Microsoft DVBS Network Provider> with moniker <@device:sw:{71985F4B-1CA1-11D3-9CC8-00C04F7971E0}\Microsoft DVBS Network Provider>
10.09.2005 13:28:11 DVBGraphBDA: setupTuningSpace()
10.09.2005 13:28:11 DVBGraphBDA: check available tuningspaces
10.09.2005 13:28:11 DVBGraphBDA: found 1 tuning spaces
10.09.2005 13:28:11 DVBGraphBDA: used tuningspace:0 Mediaportal DVB-S Mediaportal DVB-S
10.09.2005 13:28:11 DVBGraphBDA: Unable to create graph Es wurde kein Tunerbereich gefunden, der der Anforderung entspricht.
at System.Runtime.InteropServices.Marshal.MkParseDisplayName(UCOMIBindCtx pbc, String szUserName, UInt32& pchEaten, UCOMIMoniker& ppmk)
at System.Runtime.InteropServices.Marshal.BindToMoniker(String monikerName)
at MediaPortal.TV.Recording.DVBGraphBDA.CreateGraph(Int32 Quality)
10.09.2005 13:28:11 Card:1 DeleteGraph
10.09.2005 13:28:11 Card:1 CreateGraph
10.09.2005 13:28:11 DVBGraphBDA:CreateGraph().
10.09.2005 13:28:11 DVBGraphBDA: Added filter <Microsoft DVBS Network Provider> with moniker <@device:sw:{71985F4B-1CA1-11D3-9CC8-00C04F7971E0}\Microsoft DVBS Network Provider>
10.09.2005 13:28:11 DVBGraphBDA: setupTuningSpace()
10.09.2005 13:28:11 DVBGraphBDA: check available tuningspaces
10.09.2005 13:28:11 DVBGraphBDA: found 1 tuning spaces
10.09.2005 13:28:11 DVBGraphBDA: used tuningspace:0 Mediaportal DVB-S Mediaportal DVB-S
10.09.2005 13:28:11 DVBGraphBDA: Unable to create graph Es wurde kein Tunerbereich gefunden, der der Anforderung entspricht.
at System.Runtime.InteropServices.Marshal.MkParseDisplayName(UCOMIBindCtx pbc, String szUserName, UInt32& pchEaten, UCOMIMoniker& ppmk)
at System.Runtime.InteropServices.Marshal.BindToMoniker(String monikerName)
at MediaPortal.TV.Recording.DVBGraphBDA.CreateGraph(Int32 Quality)
 

gigabass

New Member
December 19, 2005
2
0
Same problem

Same problem for me.
I installed the current 0.2.0 RC2 (first time) yesterday but can't get the twinhan vision dtv dvb-s running.

Windows XP Pro, SP2, WindowsXP-KB896626-v2-x86-DEU.exe patch installed.
i searched this forum and tried every hint given, used lates bda drivers (1.2.1.9, somewhere there was a link to a 1.2.2.0 which is dead ?) played around with several capturecard.xml settings posted here - the result is always the same.
i see the card in MP, but get the 'unable to create graph' message, andin the last tab of the card setup 'this is only for dvb-s cards'

card is running fine with the twinhan drivers and twinhan program, progdvb or dvbviewer.

does anyone have this card running in 0.2.0 ? any additional tipps / configuration links for drivers / .xml ....
somewhere i've seen that maybe driver / mp version & .xml entries may not match, but every combination i've tried did not work (spend a few hours yesterday and then gave up)

ps. i'm a newbie to MP so i may have not tried everything possible, but at least i tried every hint given in this forum.
 

Koschel

Retired Team Member
  • Premium Supporter
  • April 6, 2005
    1,044
    68
    Stuttgart
    Home Country
    Germany Germany
    The latest driver is 1.2.2.9, available at twinhan.com.
    With these drivers thetwinhan should work.
     

    rolfkunst

    Portal Member
    October 25, 2005
    32
    0
    Netherlands
    Koschel said:
    The latest driver is 1.2.2.9, available at twinhan.com.
    With these drivers thetwinhan should work.

    Should work, have you tried it? I can't get it working either. I'm gonna reïnstall my system complete again, windows, updates framework etc. and install RC2 afterwards, I'm going to use 1.2.2.9. Should I add or change something in the MP directory? Like carddefenitions.xml or anything like that?

    Greetings Rolf
     

    gigabass

    New Member
    December 19, 2005
    2
    0
    Koschel said:
    The latest driver is 1.2.2.9, available at twinhan.com.
    With these drivers thetwinhan should work.
    oops. typo. i had the 1.2.2.9 drivers already. just seen that there is a 1.2.3.0. tried to use this but system hangs during install - and during reboot so i had to use a 'last working winxp configuration'.
    back to 1.2.2.9 - same result with the 'unable to create graph' problem
     

    bwilli2

    New Member
    December 16, 2005
    2
    0
    Same Issue, what worked for me

    I had the same issue with my Twinhan 1020a.

    What allowed me to clear the filter errors and select the DVB-S tab to configure the card:

    Installed MP 0.2 RC 2

    Downloaded and installed the Microsoft Patch:
    http://www.microsoft.com/downloads/...6D-198C-4197-82AD-28251F9C50A5&displaylang=en

    Rebooted (not prompted, but did anyway)

    Downloaded and installed the Twinhan BDA 1.2.2.9 Drivers
    (I've not tried the new 1.2.3.0 drivers yet.)
    *Note I didn't have success 'upgrading' the driver via device manager, I needed to actually run THDrvSetup.exe

    Rebooted. (not prompted, but did anyway)

    Then copied the CaptureCardDefinitions.xml file that was included in the MediaPortal directory of the Twinhan 1.2.2.9 driver package.

    After that, MediaPortal setup correctly ID'd my card, and no more 'direct show graph' error. I could then also select the DVB-S tab.

    As always, YMMV.

    Good luck.
     

    rolfkunst

    Portal Member
    October 25, 2005
    32
    0
    Netherlands
    Then copied the CaptureCardDefinitions.xml file that was included in the MediaPortal directory of the Twinhan 1.2.2.9 driver package.

    What do You mean with this. There is a capturecarddef.xml included in the driver package? I've downloaded the driver too, but never seen such file. I've just checked it once more, but didn't find anything like it. Could You please help me out here?

    Thanks and greetings.
     

    bwilli2

    New Member
    December 16, 2005
    2
    0

    Users who are viewing this thread

    Similar threads

    Hello Support for the Twin CI slots requires much more than just the name change. The Twin is supported in TVE 3.5 already... mm
    Hello Support for the Twin CI slots requires much more than just the name change. The Twin is supported in TVE 3.5 already... mm
    In GlobeTV (the Software delivered by KNCOne), the CAM ist detected and works. In Mediaportal, it doesn't. I searched the source...
    Replies
    2
    Views
    2K
    Yay!! I got my internetstreams working in MePo by modding vodserver. What I do is,I tune to a vodserver channel in mepo, that will start vlc or other external player playing whatever stream or file you want to see 'in mepo' then I feed mepo a picture endlessly looped and a silent mp3 with ffmpeg in mpeg2 so it won't give me errors...
    Yay!! I got my internetstreams working in MePo by modding vodserver. What I do is,I tune to a vodserver channel in mepo, that will...
    Situation: Multiseat MP1.11 Network tuner Anysee N7 (single tuner that outputs http streams) Sometimes when changing channels we...
    Replies
    17
    Views
    4K
    The watchdog is not available on the server unless MP is installed. So, I expect you would run the watchdog on the client to get a zip of the client logs; then zip all the logs in the server log directory to get a second zip; finally, post/attach both zip files here.
    The watchdog is not available on the server unless MP is installed. So, I expect you would run the watchdog on the client to get a...
    Hello, i've got the problem, that after changing to another channel the new channel is running for roughly 2 seconds and then the...
    Replies
    6
    Views
    833
    Hallo zusammen, ich versuche jetzt schon seit Stunden die Technisat SkyStar 2 HD CI unter Windows 2008 Server in Verbindung mit MP TV Server zu installieren. Gerät (BDA) Treiber ist installiert und erkannt. TechniSat Software (DVBViewer TE2) ist installiert. Der Viewer zeigt an das kein Gerät zur Verfügung steht und MediaPortal...
    Hallo zusammen, ich versuche jetzt schon seit Stunden die Technisat SkyStar 2 HD CI unter Windows 2008 Server in Verbindung mit...
    Hallo zusammen, ich versuche jetzt schon seit Stunden die Technisat SkyStar 2 HD CI unter Windows 2008 Server in Verbindung mit...
    Replies
    0
    Views
    1K
    Hab heute den neuen Sender RTL-Nitro versucht in meine DB per Channel-Scan zu bekommen. Dabei ist mir aufgefallen das nach dem Scan der neue Sendername nur in der dbo.tuningdetail aktualisiert wird. In der dbo.channel bleibt der alte Sendername (hier VOX CH) im Feld "displayname". Blöd weil dadurch in der TV-Server Config in der...
    Hab heute den neuen Sender RTL-Nitro versucht in meine DB per Channel-Scan zu bekommen. Dabei ist mir aufgefallen das nach dem Scan...
    Hab heute den neuen Sender RTL-Nitro versucht in meine DB per Channel-Scan zu bekommen. Dabei ist mir aufgefallen das nach dem Scan...
    Replies
    0
    Views
    1K
    Top Bottom