Unable to play 96KHz audio with Pure Audio (1 Viewer)

Hypertone

Portal Member
September 22, 2009
15
0
Pure Audio is not changing the sample rate of my audio card when I try to play a 24/96 file. Here is what shows in the error log:


2009-09-22 10:19:33.093750 [ERROR][PureAudio.Main]: PureAudio: _ASIOEngine.Driver.SetSampleRate failed: setSampleRate: active channels (-995).
2009-09-22 10:19:39.718750 [ERROR][PureAudio.Main]: PureAudio: _ASIOEngine.Driver.SetSampleRate failed: setSampleRate: active channels (-995).

Is anyone else able to play back 96K files without resampling? I can get it to work if I set 44.1K for the max sample rate, even though I recorded these files on this card with Wavelab, and it also played them back. The card is an Aardvark Direct Pro 24/96. It's an ancient card and the company is defunct, so I'm stuck with this driver.
 

Symphy
Country flag

Retired Team Member
  • Premium Supporter
  • August 25, 2007
    495
    137
    Groningen
    Home Country
    Netherlands Netherlands
    Pure Audio is not changing the sample rate of my audio card when I try to play a 24/96 file.
    Hypertone,
    Could you post the entire (debuglevel) logfiles here? Just to see what exactly is happening. In the meantime i'll see if i can do something with that errormessage.
     

    Hypertone

    Portal Member
    September 22, 2009
    15
    0
    Hi Symphy,

    I just installed the latest MP 1.1.0 Beta today and the appropriate Pure Audio plugin. Now it is working! I fooled with the BASS engine first, and it would play the 96K files like a chipmunk (wouldn't switch the sample rate), so I manually set my card to 96K and switched to Pure Audio, and it played the 96K files fine, then I switched to a 44.1K file and it played fine. I checked to make sure the card was changing, and it's good to go! :)

    The only problem is that I don't have any volume control. It seems MP changes the volume setting in the Windows mixer, but my card doesn't even route through the mixer, so I'm left without a volume control. Would you know of a work around for that?

    Thanks
     

    edterbak
    Country flag

    Test Group
  • Team MediaPortal
  • March 4, 2008
    2,114
    1,176
    Home Country
    Netherlands Netherlands
    There is only one work-around for the volume thing... Use the receivers to controle the volume. (I programmed a Logitech Harmony remote to do that... easy and elegant solution.. though a bit pricey)
    The reason why pureaudio works is that it makes sure that windows doesnt touch the audiostream in any way (through ASIO). The datastream goes directly to your receiver like that in 100% ok condition. If windows does touch it, things always go wrong. Often resulting is jitters, white-noise.. or no sound at all. Now the sound works but the downside is that volume controle is also not possible from the OS side....
     

    Symphy
    Country flag

    Retired Team Member
  • Premium Supporter
  • August 25, 2007
    495
    137
    Groningen
    Home Country
    Netherlands Netherlands
    I will inplement a volume control in the upcoming new version which is a major rewrite. it will be an option that can be switched off for the real audio purists.

    It is true that digital volume control can affect quality, but in a full 24 bit environment (PureAudio -> ASIO -> 24 bit audio device) it is fairly acceptable, especially when playing 16 bit sources. And when WASAPI is supported, we even have 24 bit precision without ASIO.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom