"Unable to play" error with AVC codec (1 Viewer)

Martoonster

New Member
May 10, 2012
4
0
53
United States of America United States of America
Whenever I attempt to play any H264 video files in MediaPortal, I get an error saying, "Unable to play: blahblahfilename, Video codec: AVC, Audio codec: AAC VERSION 4L" (clips off edge of window after "4L", so there may be more).

An example file I'm trying to play:
Video:
Codec: H264 - MPEG-4 AVC (part 10) (avc1)
Resolution: 720x404
Frame rate: 23.976023
Decoded format: Planar 4:2:0 YUV
Audio:
Codec: MPEG AAC Audio (mp4a)
Channels: Stereo
Sample rate: 48000 Hz

I'm using the Media Player Classic codecs. In my MediaPortal configuration, my H.264 Video decoder is MPC Video Decoder, and my AAC Audio Decoder is MPC - MPA Decoder Filter. These were recommended codecs in the MediaPortal wiki.

I have the latest driver for my video card.

The files all play fine in other player apps on the same system (VLC Media Player, Media Player Classic, etc.), and non-H264 files play fine in MediaPortal. It only has the problem when I attempt to play H264 files in MediaPortal.

Any suggestions on what I should try next?
 

Martoonster

New Member
May 10, 2012
4
0
53
United States of America United States of America
Hang on, just got a H264 file with AC3 audio to play. So it appears the problem is the audio codec, not the video.

Any tips on what I should do for an AAC audio codec?
 

Paranoid Delusion

Moderation Manager
  • Premium Supporter
  • June 13, 2005
    13,062
    2,978
    Cheshire
    United Kingdom United Kingdom
    Try the Lav filters available from the desktop MP extensions installer, these work a treat for most formats, this includes all current HD audio.

    ps. you would need to uninstall any other filters, ie haali, before installing.
     

    Martoonster

    New Member
    May 10, 2012
    4
    0
    53
    United States of America United States of America
    Try the Lav filters available from the desktop MP extensions installer, these work a treat for most formats, this includes all current HD audio.

    ps. you would need to uninstall any other filters, ie haali, before installing.
    Thanks, I'll try that. Stupid question: How do I tell what other filters I currently have installed (that I need to uninstall)?
     

    Martoonster

    New Member
    May 10, 2012
    4
    0
    53
    United States of America United States of America
    Woot! Thank you! I installed the Lav filters, and everything plays perfectly now!
     

    Nebraskaguy

    New Member
    May 24, 2012
    1
    0
    40
    El Salvador El Salvador
    As for me, i will get a video or audio codec from moviecodecdotcom if my player can play the video file ...
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    T [solved] "Unable To Play" (Videos) rears it's head again. Logs not possible... WatchDog error attached!! :( General Support 1
    M MP 2.2.3 Unable to play .ts recordings and MediaPortal stops working for TV viewing General 31
    H Unable to play stream - again... Television (MyTV frontend and TV-Server) 2
    B Suddenly MP is unable to play anything Watch / Listen Media 6
    porky996t Still Unable to play Live or Recorded TV General Support 4
    B Unable to play: Live3-0.ts issue General Support 7
    A Unable to play :stream 3 Television (MyTV frontend and TV-Server) 1
    badboyxx Unable to play BD-Iso watch/edit Videos 7
    Steve.Rayner61 TV "Unable to play" on Client - Working until Win 10 Server upgraded to Version 1803 Television (MyTV frontend and TV-Server) 5
    P [solved] MP2 new install, 2 x hdhomerun tuners, client on same PC unable to view TV & recordings Newcomers Forum 8
    R [solved] Unable to delete single recording General 2
    D Unable to install 1.22 on Win 10 Newcomers Forum 9
    V Unable to stream : 10 General Support 0
    M Unable to map virtual sent keys in the input device management General 6
    megahorst Unable to delete unseen recording while TV runs in the background 1.19 11
    gibman MP2 - V2.1 unable to playback new movie? Older releases 3
    M Unable To Record Series General 0
    M WTV Files does not play on client, MPEG files works well General 0
    A [solved] How to Play All Videos in a List watch/edit Videos 3
    horned_reaper [solved] When playing music Fanart does not shuffle Fanart Handler 20
    horned_reaper [solved] No Fanart when playing Fanart Handler 115
    horned_reaper [solved] When playing music Fanart does not appear immediately after downloading Fanart Handler 272
    B MP 2.2.3 Error playing videos from NAS Submit: Bug Reports 2
    N Play a TV recording needs a double selection - twice ok on remote Television (MyTV frontend and TV-Server) 2
    Z Error when attempting to play Blu Ray General 1
    Similar threads

























    Top Bottom