[TV] Unable to record/watch consecutive shows on the same channel (1 Viewer)

riksmith

Portal Pro
April 18, 2009
1,856
322
Netherlands Netherlands
Let me clarify and THANKS for all your help! The test.dll patch was a TVLibrary.dll (in the form of a .zip attachment) that was made available after RC1 was published. Folks evaluated test versions of TVLibrary.dll from this and the other thread and found the changes got ATSC tuners working... then on 4/14/10 RC2 was published. Since no one generated a bugfix the 'testing' done by folks on both of these threads has no way to get incorporated into the next RC, namely RC3.

I can see why it's difficult to pull these patches together - we post the issues on many different sub-groups and sometimes arrive at the same conclusion. I'm tring to speak out for ATSC users and asking for a bugfix so this can be fixed without having to use the ResetGraph Debug option.
As mentioned further on in the topic: It was fixed and commited in SVN before RC2. See this issue: 0002807: A/V detection for recordings is not working correctly - MediaPortal Bugtracker.

Well the rest of my previous post stands, if you still have a problem: Post all logs and test with clean RC2.

If it is the same issue i will move this thread to the RC forum to prevent this from getting lost, if it is not the same problem we have to start a new thread in the RC forum.
 

riksmith

Portal Pro
April 18, 2009
1,856
322
Netherlands Netherlands
I'm tring to speak out for ATSC users and asking for a bugfix so this can be fixed without having to use the ResetGraph Debug option.
Are you saying it is working with the reset graph option? If so, what is the problem with using that? Only as long as all ATSC users are required to use that option it would make sense to code it as default.
 

jaymode

Portal Pro
July 31, 2008
58
1
United States of America United States of America
I will try to get logs tonight/tomorrow. Basically the issue with RC2 on Windows 7 is that we need to enable the Reset Graph in DebugOptions in order to tune the same ATSC Channel/SubChannel combination consecutively.

Prior to RC2, a patch was required that changed one line in the ATSC tuning code. Mantis issue 2733 changed the ATSC tuning code so that we no longer need the changes in the ATSC tuning code, but still require the DebugOptions in order to have proper functionality.

Hope that helps.
 

whurlston

Portal Pro
March 4, 2007
82
10
United States of America United States of America
I would recommend starting a new thread to avoid confusion. As jaymode said, the patch that I posted on page 5 is no longer needed.
 

riksmith

Portal Pro
April 18, 2009
1,856
322
Netherlands Netherlands
Ok, well as stated earlier i don't really see a problem with having to use the debug option as long as not all ATSC users need to use it. So if you start a new thread i cannot guarantee that it will lead to something.
 

riksmith

Portal Pro
April 18, 2009
1,856
322
Netherlands Netherlands
BTW, with the clean logs we can also investigate if the resetgraph is the real problem, or if it is just a workaround.
 

Users who are viewing this thread

Similar threads
OP Title Forum Replies Date
P [solved] MP2 new install, 2 x hdhomerun tuners, client on same PC unable to view TV & recordings Newcomers Forum 8
R [solved] Unable to delete single recording General 2
M MP 2.2.3 Unable to play .ts recordings and MediaPortal stops working for TV viewing General 31
porky996t Still Unable to play Live or Recorded TV General Support 4
doskabouter 1.26.0 Codec question (unable to play video, lv50 codec) Codecs, External Players 24
D Unable to install 1.22 on Win 10 Newcomers Forum 9
H Unable to play stream - again... Television (MyTV frontend and TV-Server) 2
V Unable to stream : 10 General Support 0
B Suddenly MP is unable to play anything Watch / Listen Media 6
M Unable to map virtual sent keys in the input device management General 6
T [solved] "Unable To Play" (Videos) rears it's head again. Logs not possible... WatchDog error attached!! :( General Support 1
D Free text recording TV-Server 1
Peter PROMS MediaPortal2 V2.3.1 Crash in Recorded TV playback Newcomers Forum 13
R HDHomeRun CONNECT QUATRO - can MP record more than 4 channels MediaPortal 1 Talk 2
F Completed Delete recordings fail. HTPC Projects 0
R Deadlock in TV Server if recording while importing EPG TV-Server 10
C MP2 - V2.3 Nereus: doesn't show a recording in extended scheduling option General 5
404 Recording problems Television (MyTV frontend and TV-Server) 6
D wintv doesn’t stop recording on time Newcomers Forum 6
P [solved] Blocking TV recordings on client? General 10
1gkar [solved] LiveTV Records Causing 100% Drive Activity Television (MyTV frontend and TV-Server) 10
toricred Recordings Change : to _ in Series Name General 0
P Recording films that have an "intermission" General 3
H MP2 database won't keep in synch with recordings General 8
toricred Only Show Actual Recordings General 1

Similar threads

Top Bottom