[fixed] Unable to use DirectVobSub as subtitle renderer (MP freezes) (1 Viewer)

khelbenaru

Portal Member
October 11, 2007
1
0
Italy Italy
MediaPortal Version: MP 1.2.0 Beta
MediaPortal Skin: Default Skin Wide
Windows Version: Windows 7 Home Basic x86
CPU Type: INTEL Core i3-2100 3,1GHz
HDD: WD 5000AADS 500GB
Memory: Corsair SO-DIMM DDR3 4GB / 1333Mhz
Motherboard: ZOTAC 1155 Z68-ITX WiFi Supreme
Video Card: NVIDIA GeForce GT 430 (integrated)
Video Card Driver:
Sound Card: Realtek
Sound Card AC3:
Sound Card Driver:
1. TV Card:
1. TV Card Type:
1. TV Card Driver:
2. TV Card:
2. TV Card Type:
2. TV Card Driver:
3. TV Card:
3. TV Card Type:
3. TV Card Driver:
4. TV Card:
4. TV Card Type:
4. TV Card Driver:
MPEG2 Video Codec:
MPEG2 Audio Codec:
h.264 Video Codec:
Satelite/CableTV Provider:
HTPC Case:
Cooling:
Power Supply:
Remote: HP MCE Remote
TV:
TV - HTPC Connection: VGA


Hello.

I am basically unable to use DirectVobSub whenever I play mkv files with embedded subtitles, as MP freezes after selecting the file.

How to reproduce:

- choose DirectVobSub as subtitle renderer, with or without "Auto load subtitles" selected (no other settings changed)
- try to play file with embedded subtitles, MP freezes


MPC-HC subtitle renderer works fine though (with just a brief stutter whenever it tries to load animated subtitles after playing "normal" styled subtitles for a few minutes), while selecting FFDShow subtitle renderer (settings as suggested on wiki) just plays the video without any subtitles.
Problem showed either when using CoreAVC w/CUDA or FFDShow as H.264 decoder.

DirectVobSub loads normally when used with MPC-HC.


I had almost the same problem with MP 1.1.3; the one difference was that MP didn't freeze, but produced "Unable to play file" errors whenever DirectVobSub was selected.
 

Paranoid Delusion

Moderation Manager
  • Premium Supporter
  • June 13, 2005
    13,062
    2,978
    Cheshire
    United Kingdom United Kingdom
    There is a problem with the current version of directvobsub, use a older version or MP's internal MPC subs

    You need to be using 1.2 beta for forced subs to be active by default.
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,447
    10,273
    France
    France France
    Country flag
    Hi,
    I can confirm something wrong and didn't work well when using LAVSplitter.
    I have fixed it on my side, need to make few test.
    Ps : For now i have tested with VSFilterMod so i will test on VSFilter normal version.
    Thanks.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    P [solved] MP2 new install, 2 x hdhomerun tuners, client on same PC unable to view TV & recordings Newcomers Forum 8
    R [solved] Unable to delete single recording General 2
    M MP 2.2.3 Unable to play .ts recordings and MediaPortal stops working for TV viewing General 31
    D Unable to install 1.22 on Win 10 Newcomers Forum 9
    H Unable to play stream - again... Television (MyTV frontend and TV-Server) 2
    V Unable to stream : 10 General Support 0
    B Suddenly MP is unable to play anything Watch / Listen Media 6
    M Unable to map virtual sent keys in the input device management General 6
    T [solved] "Unable To Play" (Videos) rears it's head again. Logs not possible... WatchDog error attached!! :( General Support 1
    porky996t Still Unable to play Live or Recorded TV General Support 4
    B Unable to play: Live3-0.ts issue General Support 7
    A Unable to play :stream 3 Television (MyTV frontend and TV-Server) 1
    badboyxx Unable to play BD-Iso watch/edit Videos 7
    Steve.Rayner61 TV "Unable to play" on Client - Working until Win 10 Server upgraded to Version 1803 Television (MyTV frontend and TV-Server) 5
    mickb Subtitles My TVSeries 9
    M.Hulot Blu-ray: Es werden nicht nur Forced Subtitles angezeigt Allgemeines Supportforum 1
    J How to change y position of subtitles General 3
    R [will not fix] [MP2-832] MP2.2.2 subtitles not shown for WTV files Submit: Bug Reports 7
    S Remote button to change audio and subtitle on / off General 10
    P [solved] ATSC subtitles not fixed yet? General 2
    E Swedish subtitles problem General 2
    ratata Someone stole my subtitles... General Support 0
    Dark Eyes Display subtitles on a separate display or device MediaPortal 1 Plugins 0
    R [solved] Command / Shortcut for changing subtitles or audio Archive 5
    K Multichannel audio and subtitles for TV not properly supported General Support 4
    Similar threads

























    Top Bottom