Update error: "Automatic update disabled. Check your internet connection" (1 Viewer)

Rob Hexenmeister

MP Donator
  • Premium Supporter
  • May 12, 2011
    190
    42
    Slaithwaite
    Home Country
    United Kingdom United Kingdom
    Country flag
    Good evening all,

    I am getting an error dialog when Online Videos opens : "Error in update: "Automatic update disabled. Check your internet connection"". I believe I am not the first to have this.

    I've had this a while - months rather than weeks. I would consider upgrading my version of MP and Online Videos but that sets off compatibility issues elsewhere, particularly with iMON so I am stuck with what I have for now. I am also on Windows 7 still.

    If it is anything to do with adding the TLS 1.2 key into the registry, I have already done that (and I am not sure that has done anything at all anyway)

    Can anyone offer some help on this, or perhaps post some configuration files for a direct cut and paste?

    Many thanks
    RH
     

    Rob Hexenmeister

    MP Donator
  • Premium Supporter
  • May 12, 2011
    190
    42
    Slaithwaite
    Home Country
    United Kingdom United Kingdom
    Country flag
    do you have an onlinevideos.log for me to check if I can see anything?

    Many thanks for taking the time and trouble to get back to me.
    Attached log.

    The url opens fine on that machine if pasted into Internet Explorer but according to the log there is an error when OnlineVideos tries to open it.

    Also, as you will see, the videos are opening without a hitch.

    Kind regards
    RH
     

    Attachments

    • OnlineVideos.log
      12.6 KB · Views: 0

    doskabouter

    Development Group
  • Team MediaPortal
  • September 27, 2009
    4,028
    2,265
    Nuenen
    Home Country
    Netherlands Netherlands
    Country flag
    Hm, I think I spoke too soon...
    That url is indeed redirecting to https and after that failing on tls stuff.
    Videos with http urls will indeed play fine, but https probably don't work...
    Somehow you have to enable tls1.2 on that machine....
    Sadly for me it's a loong time ago I did that on my win7 machines so can't remember how I did that.
    If you ever find out, perhaps its good to share that in the faq?
     

    Rob Hexenmeister

    MP Donator
  • Premium Supporter
  • May 12, 2011
    190
    42
    Slaithwaite
    Home Country
    United Kingdom United Kingdom
    Country flag
    Somehow you have to enable tls1.2 on that machine....


    The attached link is very helpful on this matter. Unfortunately I am still encountering the same problem, and I wonder if some kind soul who is operating Online Videos on Windows 7 might kindly screenshot their Advanced Internet Options from Control Panel, for me to compare with mine?... Just in case it is something stupidly obvious that I have done... ... the relevant bit I think is the Security section right at the bottom on the Advanced tab

    Many thanks
    RH
     

    doskabouter

    Development Group
  • Team MediaPortal
  • September 27, 2009
    4,028
    2,265
    Nuenen
    Home Country
    Netherlands Netherlands
    Country flag
    I think this part is the most interesting:
    1621965113623.png


    kb3140245 is not installed (but perhaps a different one which includes this patch)
    exact version:
    1621965327938.png


    Let me know if you need more...
     

    Rob Hexenmeister

    MP Donator
  • Premium Supporter
  • May 12, 2011
    190
    42
    Slaithwaite
    Home Country
    United Kingdom United Kingdom
    Country flag
    Let me know if you need more...

    Thank you for spending your time on this. I have added TLS 1.1 and 1.2 apparently successfully but am still tripping over. I have SP1 installed, the patch and have even copied your settings.

    I have stumbled over this article:

    The bit about ciphers is what I have just been looking at. I have looked at my registry for the registry value....
    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Cryptography\Configuration\SSL\00010002:Functions

    ...
    and it doesn't even exist !
    So much for creating the registry keys to remove the 'DisabledByDefault' issue, it looks like there may be more to it.

    Please would you have a look for that cipher key in your registry if you can and tell my what the DWORD/QWORD values are for Functions?

    I will try adding them and see if that gets me over the hurdle.

    Thanks again
    RH
     

    Users who are viewing this thread

    Similar threads

    you're welcome :)
    you're welcome :)
    Hi, Automatic Updates is failing when starting Online Videos with the message "Automatic update disabled. Check your internet...
    Replies
    10
    Views
    2K
    Hi, maybe someone can give me some advice. I have two PCs (A and B) and each is equipped with a TV card for recording. I record to a shared folder, which works fine. All recordings and XMLs are stored correctly. Both on latest MP1, Win10 x64. My challenge is the following. If I record with PC(A), the files are correctly stored and...
    Hi, maybe someone can give me some advice. I have two PCs (A and B) and each is equipped with a TV card for recording. I record to...
    Hi, maybe someone can give me some advice. I have two PCs (A and B) and each is equipped with a TV card for recording. I record to...
    Replies
    0
    Views
    458
    It is looking and working very well now and I am almost at the point of switching my HTPC to MP2, madvr would definitely push me over the edge for sure.;)
    It is looking and working very well now and I am almost at the point of switching my HTPC to MP2, madvr would definitely push me...
    We are proud to present MediaPortal 2.3 MediaPortal 2.3 is a full-blown media center software that addresses the most common user...
    Replies
    4
    Views
    2K
    We are proud to present MediaPortal 2.2.3 MediaPortal 2.2.3 is a full-blown media center software that addresses the most common user requirements out of the box. Besides its TV and Radio services it is also offering a complete media management for movies, series and music, including posters, album and fan art as well as additional...
    We are proud to present MediaPortal 2.2.3 MediaPortal 2.2.3 is a full-blown media center software that addresses the most common...
    We are proud to present MediaPortal 2.2.3 MediaPortal 2.2.3 is a full-blown media center software that addresses the most common...
    Replies
    0
    Views
    1K
    Yes that's exactly it Joe.
    Yes that's exactly it Joe.
    So this is driving me silly and soo regret 'up'grading to Win10 :) All has been working great. MP1 server on a W10 box and...
    Replies
    5
    Views
    2K
    Top Bottom