Upgrade from 1.2 to 1.3 (1 Viewer)

caveman

Portal Pro
August 2, 2007
225
15
Home Country
Denmark Denmark
I just did the upgrade to the version 1.3 but unfortunatly when i now try to start the TV Server it just stopes.
I did stop the TV Server when i did the upgrade.
However i did not the "enable the "all users" option" most because i couldnt find it..

Hope somebody can help me so i can see some TV again :)

Error:
The only thing in the log folder for TV Server
2013-03-16 15:03:15.389239 [(4)]: Setting up EventWaitHandle with name: Global\MPTVServiceInitializedEvent
2013-03-16 15:03:15.701257 [(6)]: Tvservice stopped due to an unhandled app domain exception System.TypeLoadException: Method 'StartRecording' in type 'TvService.TVController' from assembly 'TvService, Version=1.3.0.0, Culture=neutral, PublicKeyToken=null' does not have an implementation.
at TvService.TvServiceThread.OnStart()
at System.Threading.ThreadHelper.ThreadStart_Context(Object state)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Threading.ThreadHelper.ThreadStart()
 

caveman

Portal Pro
August 2, 2007
225
15
Home Country
Denmark Denmark
Any way i can try to reinstall only the TVServer just to check if that is the problem?
Or would that "just" be a clean install of only a TV Server?
But i do not whant to delete my DB.
 

Holzi

Super Moderator
  • Team MediaPortal
  • April 21, 2010
    7,934
    2,235
    Ba-Wü
    Home Country
    Germany Germany
    Any way i can try to reinstall only the TVServer just to check if that is the problem?
    Or would that "just" be a clean install of only a TV Server?
    But i do not whant to delete my DB.

    You can install the TVServer seperatly by running package-tvengine.exe which you will find in C:\Users\<yourusername>\AppData\Local\Temp\MediaPortal Installation\deploy

    Settings should be saved.

    AppData is a hidden folder, so you need to make all folder visible.
     

    caveman

    Portal Pro
    August 2, 2007
    225
    15
    Home Country
    Denmark Denmark
    Did try..
    Got 2 errors
    1 from Power Scheduler ++ (Error opening file for writing) powerscheduler.interfaces.dll
    Same error on the YVControle.dll
    YTVLibrary.interfaces.dll

    Renamed them both manualy
    Then at least it instaledd
     

    Users who are viewing this thread

    Top Bottom