Operating System Upgraded to Windows 7 from XP (1 Viewer)

bigfella78

New Member
December 28, 2009
4
0
I'm not sure if this is the right area to be posting this. But I need some help.

My motherboard died on my HTPC. So I took advantage to do some upgrades.
So I did a clean install of Windows 7 and the lastest media portal. But I want to copy across the old TV Series database..

I tried to cut and paste the database in. But media portal cracked it and wouldn't load the tv shows..
I have over 7000 episodes and most of which I have entered manually over time. I did have a heap of parsing expressions I have also lost.

Is there a guide to restoring mediaportal from a operating system upgrade?

Because I have installed a new motherboard, GPU & Hdd I don't think I can boot from the old HDD, but I can access the files as I have kept the old drive.
 

kiwijunglist

Super Moderator
  • Team MediaPortal
  • June 10, 2008
    6,746
    1,749
    New Zealand
    New Zealand New Zealand
    Country flag
    you need to install the same version of my tv series that you were running on the old PC, then copy the database then upgrade to the latest version.
     
    Last edited:

    bigfella78

    New Member
    December 28, 2009
    4
    0
    I'm an idiot.. I should of thought of that.. I will have to uninstall My TV first...shouldn't cause any dramas?

    I guess the same goes for Moving Pictures?
     

    superferoza

    Portal Member
    February 17, 2012
    6
    0
    47
    Italy Italy
    Dear All,
    I'm planning to upgrade my PC (win xp to win 7) and if possible i'd avoid to download again movies & series data (i have 1000+ titles in usb drives).
    If i undertand well, I just have to install the same version of the moving pictures and then copy the database but I have some doubts about the file thumbs locations. Normally, every time I had to reinstall MP, I copied the database and also the folder thumbs after a new installation of moving pictures end everything works fine. But in this case, if I'm not mistaken, the location of the user file is different from that of windows xp. Don't you think that I can have problems with the link to the database? Any suggestions would be appreciated.
     

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,069
    3,681
    Lehmden
    Germany Germany
    Country flag
    Hi.
    Don't you think that I can have problems with the link to the database?
    As long as the path to your movies!!! (drive letter(s) of your external drive(s) ) are the same than before upgrade to Win7, all is fine... MP knows where to look after the DB files. Just copy database and thumb folder to new place in C:\Program Data\... (it's a hidden folder, so be sure you have access to it, I do an "unhide" on whole Program Data Folder right after installing Win7, as this helps a lot for much more than MP) after! installing MP on Win7, all will be found as usual.
    If you want to upgrade plugins to use with Win7 it's best to do this before you backup your DB and thumbs...
     

    superferoza

    Portal Member
    February 17, 2012
    6
    0
    47
    Italy Italy
    Hi.
    Don't you think that I can have problems with the link to the database?
    As long as the path to your movies!!! (drive letter(s) of your external drive(s) ) are the same than before upgrade to Win7, all is fine... MP knows where to look after the DB files. Just copy database and thumb folder to new place in C:\Program Data\... (it's a hidden folder, so be sure you have access to it, I do an "unhide" on whole Program Data Folder right after installing Win7, as this helps a lot for much more than MP) after! installing MP on Win7, all will be found as usual.
    If you want to upgrade plugins to use with Win7 it's best to do this before you backup your DB and thumbs...
    Thank you very much, this is a good thing and also easy for me to do (i'm not a db expert sure).
    I am currently using MP. 1.3 on win XP, any suggestions about MP version to install at the beginning on win 7?
     

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,069
    3,681
    Lehmden
    Germany Germany
    Country flag
    Hi.
    The recent version is 1.6 stable or 1.7 Pre Release. As there is a huge break between 1.6 and 1.7 I would recommend to use the 1.7 pre. But then it will be a bit difficult to upgrade all of your plugins as some of them aren't working on XP. I would do an update in config to get all your plugins at most recent state and the "hope" the DB will work with the plugin versions for 1.7... Normally this should work, but no guarantee...
    I'm not completely familiar with the differences between 1.6 and 1.7 as my main focus is on MP2. Maybe someone else can add further information if needed.
     

    superferoza

    Portal Member
    February 17, 2012
    6
    0
    47
    Italy Italy
    Hi.
    The recent version is 1.6 stable or 1.7 Pre Release. As there is a huge break between 1.6 and 1.7 I would recommend to use the 1.7 pre. But then it will be a bit difficult to upgrade all of your plugins as some of them aren't working on XP. I would do an update in config to get all your plugins at most recent state and the "hope" the DB will work with the plugin versions for 1.7... Normally this should work, but no guarantee...
    I'm not completely familiar with the differences between 1.6 and 1.7 as my main focus is on MP2. Maybe someone else can add further information if needed.
    Everything works fine!
    Tried clean installation of MP 1.3, copied all the database & thumbs and finally update to MP 1.6.
    Also I followed same approach with JMM server & myanime 3 plugin, and it works great.
    Thank you very much for your support.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    W Playback stuttering after upgrade from MP1 on Windows 7 to MP2 on Windows 10 General 2
    A [solved] DiseqC problems after upgrade to 1.25 General Support 1
    DHosein 1.25 Upgrade and movie covers/backdrops General Support 9
    cerberus Erfahrungsbericht Upgrade Win 10.1909 MP 1.24 Installationsprobleme? 2
    G [solved] Black Screen on all videos after upgrading to either 1.23 or 1.24 from 1.22 General Support 4
    404 [solved] EPG problem after Win10 'upgrade' General Support 1
    F [solved] Could not find the MediaPortal.Common.Logging.ILogger service after upgrading from 2.2.2 to 2.2.3 General 2
    G MP1 TV Server "failed to upgrade the database" using MS Sql Server Installation, configuration support 3
    T Upgrading HTPC for 4K General 5
    joecrow Online Videos fails after MP 1.23 upgrade. 1.23 Pre Release 37
    johns11 Multiple programs responding to IR commands since upgrade from 1.12 Remotes 3
    D PC rebuild & MP2 upgrade - how to preserve database and settings? General 1
    R [solved] TV Server after upgrading from MP 1.18 to MP 2.2 General 14
    caveman Upgrade from Mediaportal 1.X to 2.2 General 6
    B Is it Feasible to upgrade a working Mediaportal 1.20.100.0 to V2? Newcomers Forum 1
    T [further infos missing] MP2.2 client crashes on open (after upgrade) 2.2 Archive 34
    J Things I noticed with MP2.2 almost within minutes after upgrading it over the 2.13 version General 6
    D Upgrade to MP2.2 pre release fails with failure to start service 2.2 Archive 32
    C Upgrade from ancient MP Installation, configuration support 12
    Steve.Rayner61 TV "Unable to play" on Client - Working until Win 10 Server upgraded to Version 1803 Television (MyTV frontend and TV-Server) 5
    J upgraded to mp2 but have a few queries! General 17
    Undel MediaPortal 1.1 upgrade Installation, configuration support 3
    M TV Server Preview Window is blank, sounds works Television (MyTV frontend and TV-Server) 0
    vvulture Using Windows 10 MediaPortal 1 Talk 8
    Golf4 Nach Windows-Updates läuft TV-Plugin nicht mehr Allgemeines Support- und Diskussionsforum 0
    Similar threads

























    Top Bottom