[confirm] Video: errors in "error.log" after stopping video (1 Viewer)

rivera

Retired Team Member
  • Premium Supporter
  • December 1, 2008
    237
    21
    Russian Federation Russian Federation
    MediaPortal Version: 1.1.RC2
    MediaPortal Skin: Blue-3
    Windows Version: WinXP-SP3
    CPU Type: Intel Core 2 Duo E8400 3.0GHz
    HDD: WD 1000Gb
    Memory: 2x1024 DDR2
    Motherboard: ASUS P5K premium
    Video Card: ASUS EN9600GT Silent/HTDI 512
    Video Card Driver: 196.21
    Sound Card: internal
    MPEG2 Video Codec: Cyberlink Video/SP Decoder (PDVD 8)
    MPEG2 Audio Codec: MPC Audio decoder
    h.264 Video Codec: Cyberlink H264 decoder
    HTPC Case: Silverstone CW03
    Cooling:
    Power Supply: Corsair VX450W
    Remote: Soundgraph
    TV: Pioneer PDP-5080XA
    TV - HTPC Connection: DVI-HDMI

    Sometimes I see errors in "error.log" file after stopping playback of video in standard plugin.
    According to the log, it happens during "Cleanup DShow graph":
    Code:
    2010-05-11 06:29:03.718750 [Info.][MPMain(1)]: VideoPlayer9: Cleanup DShow graph
    2010-05-11 06:29:03.734375 [Info.][(32)]: Exception   :System.UriFormatException: Недопустимый URI: URI пуст.
       в System.Uri.CreateThis(String uri, Boolean dontEscape, UriKind uriKind)
       в System.Uri..ctor(String uriString)
       в MediaPortal.Util.Utils.SetThumbnails(GUIListItem& item)
       в MediaPortal.GUI.Video.GUIVideoOverlay.SetCurrentFile(String fileName)
       в MediaPortal.GUI.Video.GUIVideoOverlay.DoesPostRender()
       в MediaPortal.GUI.Video.GUIVideoOverlay.ShouldRenderLayer()
       в MediaPortal.GUI.Library.GUILayerManager.Render(Single timePassed)
       в MediaPortalApp.RenderFrame(Single timePassed)
    2010-05-11 06:29:03.734375 [Info.][(32)]: Exception   :Недопустимый URI: URI пуст.
    2010-05-11 06:29:03.734375 [Info.][(32)]:   site      :Void CreateThis(System.String, Boolean, System.UriKind)
    2010-05-11 06:29:03.734375 [Info.][(32)]:   source    :System
    2010-05-11 06:29:03.734375 [Info.][(32)]:   stacktrace:   в System.Uri.CreateThis(String uri, Boolean dontEscape, UriKind uriKind)
       в System.Uri..ctor(String uriString)
       в MediaPortal.Util.Utils.SetThumbnails(GUIListItem& item)
       в MediaPortal.GUI.Video.GUIVideoOverlay.SetCurrentFile(String fileName)
       в MediaPortal.GUI.Video.GUIVideoOverlay.DoesPostRender()
       в MediaPortal.GUI.Video.GUIVideoOverlay.ShouldRenderLayer()
       в MediaPortal.GUI.Library.GUILayerManager.Render(Single timePassed)
       в MediaPortalApp.RenderFrame(Single timePassed)
    2010-05-11 06:29:03.734375 [Info.][(32)]: RenderFrame exception Недопустимый URI: URI пуст. System    в System.Uri.CreateThis(String uri, Boolean dontEscape, UriKind uriKind)
       в System.Uri..ctor(String uriString)
       в MediaPortal.Util.Utils.SetThumbnails(GUIListItem& item)
       в MediaPortal.GUI.Video.GUIVideoOverlay.SetCurrentFile(String fileName)
       в MediaPortal.GUI.Video.GUIVideoOverlay.DoesPostRender()
       в MediaPortal.GUI.Video.GUIVideoOverlay.ShouldRenderLayer()
       в MediaPortal.GUI.Library.GUILayerManager.Render(Single timePassed)
       в MediaPortalApp.RenderFrame(Single timePassed)
    2010-05-11 06:29:03.765625 [Debug][MPMain(1)]: VMR9: Dispose
    2010-05-11 06:29:03.765625 [Debug][MPMain(1)]: SubtitleRenderer: starting cleanup
    2010-05-11 06:29:03.765625 [Debug][MPMain(1)]: SubtitleRenderer: cleanup done
    2010-05-11 06:29:03.765625 [Debug][MPMain(1)]: VMR9: Inactive
    2010-05-11 06:29:03.765625 [Debug][MPMain(1)]: Remove filter from graph: 0001 0
    2010-05-11 06:29:03.765625 [Debug][MPMain(1)]: Remove filter from graph: Default DirectSound Device 0
    2010-05-11 06:29:03.765625 [Debug][MPMain(1)]: PlaneScene: PresentImage() dispose surfaces
    2010-05-11 06:29:03.781250 [Debug][MPMain(1)]: Remove filter from graph: Video Mixing Renderer 9 1
    2010-05-11 06:29:03.781250 [Debug][MPMain(1)]: Remove filter from graph: TextPassThru120987cc 0
    2010-05-11 06:29:03.781250 [Debug][MPMain(1)]: Remove filter from graph: MPC - MPA Decoder Filter 0
    2010-05-11 06:29:03.781250 [Debug][MPMain(1)]: Remove filter from graph: CyberLink Video Decoder (PDVD10) 0
    2010-05-11 06:29:03.796875 [Debug][MPMain(1)]: Remove filter from graph: F:\Video\Movies\Amelie\Amelie.mkv 0
    2010-05-11 06:29:03.796875 [Info.][MPMain(1)]: VideoPlayerVMR9: Disabling DX9 exclusive mode
    2010-05-11 06:29:03.796875 [Debug][MPMain(1)]: Main: Received DX exclusive mode switch message. Fullscreen && maximized == False
    2010-05-11 06:29:03.796875 [Debug][MPMain(1)]: Main: Goto windowed mode: False
    2010-05-11 06:29:03.796875 [Debug][MPMain(1)]: D3D: Switch to windowed mode - Playing media: False
    2010-05-11 06:29:03.921875 [Debug][MPMain(1)]: D3D: Switched to windowed mode successfully
    While making the attached test logs, I started same movie several times on the same conditions and in some cases I observed accumulating errors in "error.log".
     

    rivera

    Retired Team Member
  • Premium Supporter
  • December 1, 2008
    237
    21
    Russian Federation Russian Federation
    I checked lot of times on TWO different PCs.
    The bug happens with these decoders & splitters:
    - ffdshow audio decoder
    - MPC audio decoder
    - Cyberlink audio decoder
    - ffdshow video decoder
    - Cyberlink Video/SP decoder
    - Cyberlink video decoder (PD10)
    - CoreAVC
    - Haali splitter - for avi, mkv, m2ts
    - Matroska splitter (Gabest) - for mkv
    - Mpeg Splitter (Gabest) - for m2ts
    - MPEG2 demultiplexor - for mpg

    Renderer - VMR9.
    I am using WinXP-SP3.
     

    elliottmc

    Retired Team Member
  • Premium Supporter
  • August 7, 2005
    14,927
    6,061
    Cardiff, UK
    United Kingdom United Kingdom
    Country flag
    Hi,

    Is this still a problem with RC3? If so, I think it is best to re-report it in the RC3 section so that it does not get lost.

    Thanks,

    Mark



    I checked lot of times on TWO different PCs.
    The bug happens with these decoders & splitters:
    - ffdshow audio decoder
    - MPC audio decoder
    - Cyberlink audio decoder
    - ffdshow video decoder
    - Cyberlink Video/SP decoder
    - Cyberlink video decoder (PD10)
    - CoreAVC
    - Haali splitter - for avi, mkv, m2ts
    - Matroska splitter (Gabest) - for mkv
    - Mpeg Splitter (Gabest) - for m2ts
    - MPEG2 demultiplexor - for mpg

    Renderer - VMR9.
    I am using WinXP-SP3.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    B MP 2.2.3 Error playing videos from NAS Submit: Bug Reports 2
    T [solved] "Unable To Play" (Videos) rears it's head again. Logs not possible... WatchDog error attached!! :( General Support 1
    A [solved] How to Play All Videos in a List watch/edit Videos 3
    O 1.25.0 Codecs and Video Format for PlayStation 2 Codecs, External Players 0
    g0rsq Info box randomly popping up when watching TV or other video MediaPortal 2 Newcomers Forum 1
    I Video Playback Stuttering General Support 45
    B some videos jerky Television (MyTV frontend and TV-Server) 0
    T Kurze Tonaussetzter bei Videos und TV Allgemeines Supportforum 1
    mrmojo666 [Tv Server Plugin ]Direct Show Video Control Plugin 0.0.0.1 for Hauppauge PVR cards MediaPortal 1 Plugins 0
    ajs [Proposal] Video embedded cover MediaPortal 1 1
    G [solved] Black Screen on all videos after upgrading to either 1.23 or 1.24 from 1.22 General Support 4
    H random black screen live tv and videos (amended) General Support 0
    404 [solved] Live TV...video and audio freeze General Support 20
    R kein Ton bei TV, Video, Aufnahme, Musik Allgemeines Support- und Diskussionsforum 0
    U [solved] Dynamic Refresh Rate for 23fps video Watch / Listen Media 1
    J Debug OnlineVideos, How To? OnlineVideos 1
    A MP2.2.2, understanding movies/videos/tv and WTV recordings. General 16
    C Problem playing videos created on IPhone X and Samsung S9 General Support 2
    H [solved] Video database genres, sort titles and collection thumbnails Newcomers Forum 12
    M How to Watch my videos from my Media Portal to My TV without TV Tuner Newcomers Forum 1
    cbr954rr Issue BOOTSUWRNQ with online videos? Plugin Development 1
    A Working server, no video playback on client General 5
    Megane [Configuration] Be more specific in Video Codec Improvement Suggestions 0
    M Online Video Plugin V.2.32 keine Installtion unter MediaPortal 1.22 ? TV / Streaming 3
    C where is the Online Videos plugin General Support 1
    Similar threads

























    Top Bottom