1.25.0 Videos in HEVC UHD 2160p don't play good (1 Viewer)

Idro

Portal Pro
February 13, 2015
70
13
46
Home Country
Italy Italy
Country flag
Hello everyone,

recently I tried to reproduce a video coded in HEVC UHD 2160p into MePo.
The video is not smooth, it stumbles and asynchronous with audio.

I tried to use MPC-BE video player onmy HTPC and the same video is nice smooth and very fluid.

So I think is not a hardware issue.

After that I went into codecs and renderer of MePo configuration changing all settings: I tried to change hardware decoder (NVIDIA Cuvid, DXVA2 copy-back, DXVA2 native etc.), I tried to use MadVR rather then EVR etc., also other settings, but the result is always the same

I attached the logs with the settings I normally use for other videos: EVR as renderer and NVIDIA cuvid as hardware decoder.

If you need other infos about my settings let me know.

The video I wan to reproduce is the pilot of the show The last dance.
 

Attachments

  • MediaPortalLogs_13_08_20__11_00_info.zip
    1.2 MB · Views: 0
  • MediaPortalLogs_13_08_20__11_25_debug.zip
    1.4 MB · Views: 0

joecrow

Test Group
  • Team MediaPortal
  • August 9, 2012
    1,910
    1,358
    Home Country
    Germany Germany
    Country flag
    If you have not already done so please try setting up MPC-BE to use External Lav filters, by default it uses an internal set, and check the playback again. That way both MP and MPC-BE will be using the same setup so we can then decide if it is the player or Lav settings.
    In the screenshots below untick all the internal filters (even those not shown) and select and add/enable the external Lav filters as shown.

    lav-2.jpg lav-1.jpg
     

    Idro

    Portal Pro
    February 13, 2015
    70
    13
    46
    Home Country
    Italy Italy
    Country flag
    Hello joecrow,

    tonight I had time to do the test: well, I done what you suggested and the video into mpc-be is still smooth and nice even if it uses lav filters as external filters.

    So which could be the issue?
     

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    1,910
    1,358
    Home Country
    Germany Germany
    Country flag
    So which could be the issue?
    I think it would be good to know how your HTPC is performing. If possible please check both CPU and GPU usage during playback on both players , Task Manager/Performance is one way, and let us know. Just for comparison I am seeing aprox 8% CPU and just under 50% GPU (AMD RX 460) playing a HD HEVC video (sorry no 4K tV), pretty much the same for both MP 1 and MPC-BE x64
    From the logs I see you have a GTX 970 I am not familiar with that GPU can you confirm it supports HEVC(H265) decoding?
    Also is the MPC-BE you use the 64 bit or 32 bit version?
     

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    1,910
    1,358
    Home Country
    Germany Germany
    Country flag
    On further research (google GTX 970 HEVC) it does not look like your GPU has a HEVC(H265) hardware decoder, there is a bunch of stuff in various forums reporting much the same results as you when trying to play HEVC 4K content with it! My guess is that as a result your CPU usage is very high and the slightly higher need of MP pushes it over the top but please let us know. If you do decide to look for a new video card bear in mind Nvidia new hardware and drivers no longer support Blu Ray frame packed 3D, AMD still does.
     
    Last edited:

    Idro

    Portal Pro
    February 13, 2015
    70
    13
    46
    Home Country
    Italy Italy
    Country flag
    I think you're right, it's a reasonable observation: using only player I have a percentage use of cpu, using player+MePo the use is higher.
    If I figure out some time I will do test, but anyway I found a post in which is written this about the nvidia GPU:

    Feature Set E
    Similar to feature set D but added support for decoding H.264 with a resolution of up to 4096 × 4096 and MPEG-1/MPEG-2 with a resolution of up to 4080 × 4080 pixels. GPUs with VDPAU feature set E support an enhanced error concealment mode which provides more robust error handling when decoding corrupted video streams. Cards with this feature set use a combination of the PureVideo hardware and software running on the shader array to decode HEVC (H.265) as partial/hybrid hardware video decoding.
    GeForce GTX 745, GTX 750, GTX 750 Ti, GTX 850M, GTX 860M,GeForce 830M, 840M,GeForce GTX 970, GTX 980, GTX 970M, GTX 980M,GeForce GTX TITAN X, GeForce GTX 980 Ti

    Feature Set F
    Introduced dedicated HEVC Main (8-bit) & Main 10 (10-bit) and VP9 hardware decoding video decoding up to 4096 × 2304 pixels resolution.
    GeForce GTX 750 SE, GTX 950, GTX 960

    Feature Set H are capable of hardware-accelerated decoding of 8192x8192 (8k resolution) H.265/HEVC video streams
    GeForce GTX 1070, GTX 1080, GeForce GTX 1060, NVIDIA TITAN XP, GeForce GTX 1050, GTX 1050 Ti


    I stumble in set E unfortunately, and it seems that if I choose one GPU card among set F ones, or better set H I could solve the issue.
     

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    1,910
    1,358
    Home Country
    Germany Germany
    Country flag
    Feature Set H are capable of hardware-accelerated decoding of 8192x8192 (8k resolution) H.265/HEVC video streams
    GeForce GTX 1070, GTX 1080, GeForce GTX 1060, NVIDIA TITAN XP, GeForce GTX 1050, GTX 1050 Ti


    I stumble in set E unfortunately, and it seems that if I choose one GPU card among set F ones, or better set H I could solve the issue.
    I had a GTX 1050 Ti for a while which is a nice card worked well with HEVC vids/live TV for me and not too expensive at the moment although I always had trouble getting it to play 3D reliably . The fans run at minimum speed of 30% at low temperatures which is very quiet although I prefer AMD and the zero fan speed option of the RX range.
     

    Idro

    Portal Pro
    February 13, 2015
    70
    13
    46
    Home Country
    Italy Italy
    Country flag
    Well, the issue with 3D is less important for me, since I don't have a 3D TV at the moment and sincerely I don't think to buy one.
    Very interesting the price of the gtx 1050, right now I don't feel like to spend too much in case I decide to change the gpu card.

    So, since the components of my HTPC are based on "mini" concept to save spaces, also my gpu is the gtx970 mini itx version.

    Do you know if exist a gtx 1050 mini itx version?
    Second: just to compare, which is your AMD card you choose? And, as I written above, there are AMD gpu card mini itx versions?
     

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    1,910
    1,358
    Home Country
    Germany Germany
    Country flag
    Do you know if exist a gtx 1050 mini itx version?
    Second: just to compare, which is your AMD card you choose? And, as I written above, there are AMD gpu card mini itx versions?
    Ah that could be a problem. I took a look at the Gigabyte website, they offer the 1050 and Ti version in a "low profile" format, not sure if that works with mini itx though, all the AMD RX cards are listed as ATX format. Another consideration is power Gigabyte recommend a 300W psu for the 1050Ti and 500W+ for the AMD RX range.
    There is a mini itx version of the Nvidia GTX 1650 from Gigabyte and others and although not on your list above I believe it does support HEVC hardware decoding. See here.
     
    Last edited:

    Users who are viewing this thread

    Similar threads

    Yes, I used UNC paths (for some reason, I couldn't type them in and had to use on-screen keyboard). By using UNC paths, the stuttering was gone and playback was smooth but later, I had encountered a plethora of problems: 1. Captions and subtitles were slightly out of sync (about 500 ms) 2. MP2 client was not shutting down correctly...
    Yes, I used UNC paths (for some reason, I couldn't type them in and had to use on-screen keyboard). By using UNC paths, the...
    In previous versions of MP2, I experienced black screen during HEVC playback. Versions 2.3 and 2.3.1 appears to have addressed this...
    Replies
    21
    Views
    1K
    Problem fixed.:) The working implementation will be rolled out in the next release 2.3.
    Problem fixed.:) The working implementation will be rolled out in the next release 2.3.
    MediaPortal 2 Version: 2.1.3 Description With more videos coming out in 4k and using HEVC 10 bit I started looking into why MP2...
    Replies
    93
    Views
    8K
    @Owlsroost @mm1352000 Just wanted to clear this up finally. The Nvidia GTX 1050Ti is now installed in my Desktop PC, and if I play the problem recording there I still get a green screen etc. with the Hardware Decoder set to DXAV2 Copy-Back and Native, however with Lav 0.70.0 the Nvidia Cluvid decoder now supports HEVC and when I use...
    @Owlsroost @mm1352000 Just wanted to clear this up finally. The Nvidia GTX 1050Ti is now installed in my Desktop PC, and if I play...
    I have recently begun to experience green screens very intermittently when watching live DVBT2 HD (HEVC) TV and yesterday evening I...
    Replies
    11
    Views
    4K
    MP1 MP2 Help with subtitles DE
    Hi guys, I've a few issues with subtitles and I'd like to have a few suggestions on how to set up things properly (if possible). Current video codecs are: - LAV Video for all formats (except HVEC using Lentoid), with DXVA native decoding - LAV Splitter Source - LAV Audio - MPAR as audio renderer - EVR as video renderer (not enough...
    Hi guys, I've a few issues with subtitles and I'd like to have a few suggestions on how to set up things properly (if possible)...
    Hi guys, I've a few issues with subtitles and I'd like to have a few suggestions on how to set up things properly (if possible)...
    Replies
    0
    Views
    2K
    and you may try to repair your sql database Repair SQLite Database - MediaPortal 1 - MediaPortal Wiki it looks corrupt to me
    and you may try to repair your sql database Repair SQLite Database - MediaPortal 1 - MediaPortal Wiki it looks corrupt to me
    Media Portal version: 1.16.0 MP-TVSeries version: 4.3.0.0 LAV Filters: 0.69.0 madVR: 0.91.8 Operating System: Windows 10...
    Replies
    7
    Views
    1K
    Top Bottom