What happens on "Send to Importer" in Db? (1 Viewer)

Bernard

Portal Pro
March 5, 2012
103
25
39
Centurion
Home Country
South Africa South Africa
I was wondering what actually happens when you use the "send to Importer" option in the Config or GUI, in the Db. Because I have just used the option in the GUI, while a movie was playing near the end, and then when the movie finished, the importer was still busy, and MePo just bombed out. I then restarted MePo to just send the file to the Importer again, then realised it is not in the list. So I went to config and it is not in that list either. But now also the Importer don't seem to "find" it again, to add it.

So I'm thinking it is still in the DB just in a state that makes it not list in the interface, but also cause the Importer to ignore the file.

The logs is of no help, because it looks like they get cleared on each start of MePo. So they contain only my last restart log entries.

I will see if I can reproduce the bug, and keep the log entries, but I'm currently more interested in why the file is not being picked up again by the Importer.
 

kiwijunglist

Super Moderator
  • Team MediaPortal
  • June 10, 2008
    6,746
    1,751
    New Zealand
    Home Country
    New Zealand New Zealand
    Sounds like your trying to make moving pictures crash :eek:

    Send to importer is basically sending it back to the importer/scraping for matching the movie + downloading movie details/images. Probably not good to do this while watching the movie, sounds like you found a bug :D

    If your moving pictures database is now corrupt then there is a backup inside the database folder. Just click Start -> All Programs -> Team MP -> MP -> User Files.

    Under MovPic Config there is also an option to unignore previously ignored files, I would also try that too, just in case the video file has been set to ignore mode.

    I'm pretty sure that when you run MP watchdog it should package up all the old previous logs that have been present since the last run the watchdog. If you have since run the watchdog and created a fresh set then the old set might not be available (I think). there are also .bak files in the user files:logs directory
    =DebugMode3.png
     
    Last edited:

    Edalex

    Community Plugin Dev
  • Premium Supporter
  • January 3, 2008
    2,955
    1,264
    Saratov
    Home Country
    Russian Federation Russian Federation
    find sqlitebrowser in google and open movpics db in it ;)
    As I remember you can see your film in db only if it was succesfully imported. Pending movies are not stored in db. But if file was ignored you could see it in table local_media.
     
    Last edited:

    RoChess

    Extension Developer
  • Premium Supporter
  • March 10, 2006
    4,434
    1,897
    Regarding log files, do not (re)start MePo after a crash, but first collect log files. The 'previous' ones are normally renamed to .old, but this does not always yield the right results.

    Now for the ignored movie; inside MovPic config use the gear icon to unignore the movie. If it does not show there, then more then likely you have database corruption indeed, but MovPic is pretty good at auto-repair and verified the integrity each time it starts.
     

    Bernard

    Portal Pro
    March 5, 2012
    103
    25
    39
    Centurion
    Home Country
    South Africa South Africa
    Hi guys, thanks for all the advice.

    I have just downloaded SQL Lite Browser from the SourceForge website. And I viewed the content of the db, an I found my movie. it was added today after I ran MePo again. So it would seem that the file was not really being ignored, it was just not "picking up" when I would expect it to be picked up, like after the local sources was scanned.

    it is maybe worthwhile to note that the movie is on a removable disc (aka DVD). So maybe the timing to start scanning/monitoring the removable drive is a bit later or random. Not after local sources was refreshed.
     

    RoChess

    Extension Developer
  • Premium Supporter
  • March 10, 2006
    4,434
    1,897
    It can also be due to 'locked' status. This is why there is a new option inside advanced movpic settings to delay import when that happens.
     

    Users who are viewing this thread

    Top Bottom