Winamp opening in front of Media Portal

Jordan83

New Member
December 7, 2015
6
1
36
Hello there. I have winamp configured as my audio player and I am having this issue. Whenever I start a song Winamp opens in front of Media Portal and the taskbar shows up. I can't figure out how to get winamp to stay in the background and have Media Portal run interrupted. Can anyone help me out?
 

mm1352000

Development Group
  • Team MediaPortal
  • September 1, 2008
    21,541
    113
    Country flag
    Hello and welcome Jordan :)

    I'm a Winamp user myself. I'm not sure which version you're using, but in the version I use (5.666) there is an "always on top" option in the "options menu". Please ensure that option is not enabled:
    upload_2015-12-7_13-24-44.png


    MediaPortal also has an "keep MediaPortal always on top" in MediaPortal Configuration -> General -> Startup/resume settings, as shown here:
    http://wiki.team-mediaportal.com/1_MEDIAPORTAL_1/141_Configuration/MediaPortal_Configuration/11_General/5_Startup_Resume_Settings

    You may want to ensure that option is enabled if you want MediaPortal to be on top of everything else.
     

    Jordan83

    New Member
    December 7, 2015
    6
    1
    36
    Well, that helped a little. Now Winamp and the taskbar flash for a split second then go away. Do you have any other suggestions?
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,541
    113
    Country flag
    Do you have any other suggestions?
    No. I don't think you can do better than that.
    When you open a program on Windows, it normally takes the focus from the previously focussed program (...unless it is specifically designed to do otherwise). The flashing is because Winamp temporarily takes the focus when it starts up, then MediaPortal takes the focus back (because you enabled the "keep MediaPortal always on top option").
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,541
    113
    Country flag
    Winamp has a splash screen that you could disable (options -> preferences -> general preferences):
    upload_2015-12-7_13-45-59.png


    Disabling that splash screen may (or may not) help.

    Also, Winamp seems to remember whether it was minimised when last closed. So, try to open Winamp, minimise it, then close it (so Winamp will start minimised next time) and see if that helps for the next time.

    Finally, you could try hiding the Windows task bar.
     

    Jordan83

    New Member
    December 7, 2015
    6
    1
    36
    Thanks for the suggestions. I think I will either have winamp start at startup or live with the one time split second winamp pop up.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom