Wizard keeps crashing at step 5/7 (1 Viewer)


New Member
December 19, 2005
Hi guys,

First off, i want to say MediaPortal rocks! Keep up the good work.

Please excuse me for creating a new topic, but i couldn't find another one decribing the same problem i have. I installed MediaPortal a few days ago and it worked fine for me! At one point, i decided to re-configure the tv channels because i screwed up the order. The easiest way was to re-download the config for my region (The Netherlands, UPC Leeuwarden). It worked fine before, but when i tried the wizard crashed.

First, i thought it might be a problem with my install. I completely uninstalled and reinstalled MP. It still crashed. After that i uninstalled MP, uninstalled .NET Framework 1.1 + SP1, uninstalled my hauppauge drivers, booted, reinstalled the drivers like usual, reinstalled NET Framework 1.1, reinstalled MP, and guess what.. Yes, it still crashed. Tried the same but now also installed .NET Framework 2.0. Also, that didn't help.

It's always at the same step, 5/7, just after scanning for media.

Is there anyone who has a fix, or knows what is the source of this error? It's with both RC1 as with the RC2 release. I'm pretty sure it isn't my card (Hauppauge PVR500MCE) because that still works fine with other apps. Also, i didn't make any (big) systemchanges.

Here's the errorlog i got:

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.Xml.XmlException: Expected DTD markup was not found. Line 1, position 3.
at System.Xml.XmlTextReaderImpl.Throw(Exception e)
at System.Xml.XmlTextReaderImpl.DtdParserProxy.System.Xml.IDtdParserAdapter.Throw(Exception e)
at System.Xml.DtdParser.Throw(Int32 curPos, String res, String arg)
at System.Xml.DtdParser.ScanSubsetContent()
at System.Xml.DtdParser.GetToken(Boolean needWhiteSpace)
at System.Xml.DtdParser.ParseSubset()
at System.Xml.DtdParser.ParseExternalSubset()
at System.Xml.DtdParser.ParseInDocumentDtd(Boolean saveInternalSubset)
at System.Xml.DtdParser.Parse(Boolean saveInternalSubset)
at System.Xml.XmlTextReaderImpl.ParseDoctypeDecl()
at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
at System.Xml.XmlTextReaderImpl.Read()
at System.Xml.XmlLoader.Load(XmlDocument doc, XmlReader reader, Boolean preserveWhitespace)
at System.Xml.XmlDocument.Load(XmlReader reader)
at System.Xml.XmlDocument.Load(String filename)
at MediaPortal.Configuration.Sections.Wizard_AnalogTV.OnSectionActivated()
at MediaPortal.Configuration.WizardForm.ActivateSection(SectionSettings section)
at MediaPortal.Configuration.WizardForm.ShowNextPage()
at MediaPortal.Configuration.WizardForm.nextButton_Click(Object sender, EventArgs e)
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnClick(EventArgs e)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Loaded Assemblies **************
Assembly Version:
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///C:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
Assembly Version: 1.0.2177.20397
Win32 Version: 1.0.2177.20397
CodeBase: file:///C:/Program%20Files/Team%20MediaPortal/MediaPortal/configuration.exe
Assembly Version: 1.0.2176.40647
Win32 Version: 1.0.2176.40647
CodeBase: file:///C:/Program%20Files/Team%20MediaPortal/MediaPortal/Core.DLL
Assembly Version:
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/
Assembly Version:
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System/
Assembly Version:
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Drawing/
Assembly Version: 1.0.2177.20386
Win32 Version: 1.0.2177.20386
CodeBase: file:///C:/Program%20Files/Team%20MediaPortal/MediaPortal/TVCapture.DLL
Assembly Version:
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.ServiceProcess/
Assembly Version:
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Xml/
Assembly Version:
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Runtime.Serialization.Formatters.Soap/
Assembly Version: 1.0.2177.20390
Win32 Version: 1.0.2177.20390
CodeBase: file:///C:/Program%20Files/Team%20MediaPortal/MediaPortal/RemotePlugins.DLL
Assembly Version:
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///C:/WINDOWS/assembly/GAC_32/System.Data/
Assembly Version:
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/Accessibility/
Assembly Version: 1.1.1007.26951
Win32 Version: 1.1.1007.26951
CodeBase: file:///C:/Program%20Files/Team%20MediaPortal/MediaPortal/TaskScheduler.DLL
Assembly Version:
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Configuration/

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging

For example:

<system.windows.forms jitDebugging="true" />

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

Hope someone can enlighten me! ;)

Kind regards,



New Member
December 19, 2005
The same for me. It was working well be one day, I don't remember exactly what I did, but since that day I have always this error message at the same step as you.
I removed MP and try to reinstal MP 0.1.3, doesn't work, 0.2 RC1, doesn't work, last CVS build, doesn't work ... always the same. I removed my PVR150 to try with a PCTV310i ... always the same.
Don't know what to do.

Please help us,
Thanks a lot.

btw thanks for that great thing that is MP. Hope to be able to use RC2 soon.


Portal Member
December 18, 2005
DTD Markup not FOUND...

Hi All,

I just installed 1.3.0 base..first time wizards configured generated same error complaint right after scaning for media. when hitting next...I am offered a choice to continue and if I do so, I am able to finish the Wizards.

I thought...ok, maybe I am missing something...I went and read up on xmltv and decided to upgrade to the latest .53 I want to say (sorry, at work now but pretty sure this was the version??)...anyway, goto my Zap2it line-up going and imported, no problem...retested Wizrd..."same DTD markup not found error". I then applied the 8-26-2005 cvs snap shot to my install, ran start.bat to reg the dll's etc...and then ran configure (or setup program) and went back and updated my program guide for xmltv...ran Wizard again and still errors....

I have googled and looked here...I am at a loss.

I am running XP SP2 with .net framework plus service patches and have all OS patches in place.

Inside MP 1.3.0 + cvs, I have a working program guide and setups menus...it seems to be working (mostly) but I would like to know the cause of the failure?

Thanks in advance for any insight.




Retired Team Member
  • Premium Supporter
  • September 15, 2004
    Home Country
    New Zealand New Zealand
    Not sure if it's related, but when I didn't have an internet connection the Wizard died with a .net error, as it was trying to connect to the website to get the latest channel lists. Connected to the internet and it ran through it fine...


    New Member
    December 19, 2005
    That's what i thought too, at first, but i'm allways connected without a firewall or any other restrictions.

    Guess what: I got it to work! Not through the wizard though, but during the normal setup. When i clicked 'lookup' under 'television' before, it would crash. Now i just imported all my channels again, without any pain!

    I just deleted some files under my profile directory. Not sure wich did the trick, but here's what i did:

    Start -> Run -> %userprofile% (hit enter). I deleted:

    Re-ran the configuration.exe file, wich gave me the normale setup procedure instead of the wizard, clicked television, clicked lookup and got all my channels back. Hope this helps!

    Users who are viewing this thread

    Top Bottom