working on new MP Upnp Renderer process plugin (1 Viewer)

azzuro

Test Group
  • Team MediaPortal
  • May 10, 2007
    9,601
    5,224
    France - IDF
    France France
    Country flag
    Hi hierl,
    your plugin can work only in client mode ? for connected with Mediatomb server ?
     

    hierl_w

    Portal Member
    February 15, 2010
    30
    34
    Germany Germany
    Hi hierl,
    your plugin can work only in client mode ? for connected with Mediatomb server ?
    yes, this plugin is a upnp renderer (client). You can't browse with this plugin through your mediafiles on mediatomb server.
    For this you need a upnp controller like

    Android Tablet or Handy:
    bubbleUpnp, iMediashare, upnpPlay...

    Windows:
    WMP

    iOS (Mac, IPhpne, IPad):
    not tested with airplay or other upnp apps, I haven't an apple device.

    I have not tested with mediatomb server, but I think it will work.

    If you want to browse the mediafiles directly in the music plugin, you can connect the mediadrive in windows and add the drive to mediaportal medialibrary at music configuration...

    bye.
     

    hierl_w

    Portal Member
    February 15, 2010
    30
    34
    Germany Germany
    Does this also work with iOS? What controller to use there?
    Hi aal,

    I don't have an iOS device but take a look here and see if any of these help.

    iMediaShare is listed as a working controller in hierl_w's test matrix (see post #42 above)

    Are you looking to use your iOS device as a controller only or server and controller?

    Regards,

    Mick.

    Thanks. I have it installed as well as your MP plugin but it does not detect MP as display device. I am running Win7. Do i need to start WMP as well besides the MP plugin or am i missing something?
    please set the logging to debug and append a logfile.
    It is a problem of bubbleUpnp, I think. Now there was an update to bubbleUpnp for showing pictures.
    Now I have to test again.
    If picture work with wmp, upnplay or iMediaShare,
    all is fine. Then you have to speak with the bubbleupnp guys.

    If all works correcly no wmp is needed for this plugin.
    WMP ist only to use for testing as "upnp controller".

    bye.
     
    Last edited:

    gruijter

    Portal Member
    August 4, 2008
    5
    0
    Netherlands Netherlands
    I cannot get the plugin to work :(. After installing it there is no upnp renderer that can be found on the network. I also tried it locally on the PC (with MP running in windowed mode, and using windows mediaplayer as upnp controller), but also mediaplayer doesn't show the mp renderer. Other renderers (like my Philips TV) can be found and work without a problem.

    I've tried it on Windows 7 (MP 1.2.3.0) and on XP (MP 1.2.1.0), both without luck. I have tried several controllers (on PC, Android and iOS), all without any succes.

    I would like MP upnp renderer to work though, since it seems to support more mediatypes..........

    ***********************************
    Edit: just found out that the problem is related to the used skin. I had streamedmp, and after reverting to the standard bluewide skin it worked! :)
     
    Last edited:

    hierl_w

    Portal Member
    February 15, 2010
    30
    34
    Germany Germany
    Could you create a logfile in debugmode with active streamedmp skin, please?
    I`m wondering that a process plugin get a problem with some skins. I think the problem comes from an additional plugin of streamedmp...

    bye.
     

    jdark

    Portal Member
    December 27, 2010
    8
    0
    Hello, great plugin. Playing mp3 files on htpc from Android device works well. But when i try to show jpegs from device, media portal says: Error, Unable to play. Im using bubbleUpnp app. Do you need some logs or it is something known?
     

    Dragy

    Portal Pro
    April 27, 2009
    778
    333
    28
    Netherlands Netherlands
    Hello, great plugin. Playing mp3 files on htpc from Android device works well. But when i try to show jpegs from device, media portal says: Error, Unable to play. Im using bubbleUpnp app. Do you need some logs or it is something known?
    It's a problem with BubbleUPNP, other servers do work with pictures.
     

    Dragy

    Portal Pro
    April 27, 2009
    778
    333
    28
    Netherlands Netherlands
    I have a feature request, which will hopefully solve some issues when playing media:

    I want to be able to only start media with UPNP when there is nothing already playing in MediaPortal (non UPNP material). I had some issues with this in the past :).
     

    hierl_w

    Portal Member
    February 15, 2010
    30
    34
    Germany Germany
    I have a feature request, which will hopefully solve some issues when playing media:

    I want to be able to only start media with UPNP when there is nothing already playing in MediaPortal (non UPNP material). I had some issues with this in the past :).
    Good idea! I will check, if I can add an option for it in next version.

    Can you reproduce the error in debug-mode and send me a logfile, please?
     

    hierl_w

    Portal Member
    February 15, 2010
    30
    34
    Germany Germany
    New Version 2.2.0.3 with new Setting in configuration dialog (in common) released:
    if a media is already playing within mediaportal, the renderer don't starts playing a track send over upnp
    (requirement from Dragy)

    Please try new version (see 1. post) and give me feedback...
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    N [not reproducible] Online videos not working at all Submit: Bug Reports 1
    M.Hulot After Update 1.25 internal blu-ray-player doesn't work General Support 8
    M TV Server Preview Window is blank, sounds works Television (MyTV frontend and TV-Server) 3
    C Hauppauge HVR-1265 -- does it work with MP1? MediaPortal 1 Talk 1
    Rob Hexenmeister ITV Player still not working for me OnlineVideos 2
    V Do you have to have a smart tv for it to work? Newcomers Forum 4
    M [solved] WTV Files does not play on client, MPEG files works well General 1
    D Does Schedules Direct work with mp 1.24? General Support 3
    J [solved] Blu-ray disc playback does not work. Bugreports 15
    P MP2: US user, OTA - can NOT get SchedulesDirect plugin to work on MP1 or MP2 --> how do I get OTA schedule? General 5
    ratata [solved] Can't get two virtual IPTV cards to work side by side... General Support 6
    S TV-Server MP1 - Automatic search doesn't work Installation, configuration support 2
    T [solved] Green Button start MP not working....but box ticked in config. General Support 1
    mickb [solved] Mediaportal Stops working General Support 5
    C Importer works super slow My TVSeries 5
    D [solved] Movie artwork download stopped working Submit: Bug Reports 9
    A 1.24.0 CD art grabber not working in Shares view 1.24-1.26 Pre Release 17
    RoChess Random GPU crash leads to MePo restart, but works fine afterwards MediaPortal 1 14
    Dark Eyes Updated to Windows 10, now TVServer won't work Installation, configuration support 1
    D [solved] EPG Buddy for MP2 - Does it work? General 5
    D Please help with getting Schedules Direct to work Newcomers Forum 10
    B MP 1.23 First time click TV or Recorded TV fails, 2nd ... it will work General Support 5
    M MP 2.2.3 Unable to play .ts recordings and MediaPortal stops working for TV viewing General 31
    rsbrux IR has stopped working Remotes 4
    thepahakurki TVDB import not working My TVSeries 3
    Similar threads

























    Top Bottom