1.10.0 - Wrong song selected when playlist is available in directory

Discussion in 'Archive' started by killer8, February 24, 2015.

  1. killer8

    killer8 Portal Pro

    Joined:
    July 29, 2012
    Messages:
    378
    Likes Received:
    113
    Ratings:
    +186 / 2
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Hi,

    I'm running 1.11 pre release(with another fix from https://forum.team-mediaportal.com/threads/mp1-4578-crashes-after-standby.128997/) but got an issue with selecting songs. I think this problem was also in previous releases but it wasn't really clear to me what exactly caused it.

    When a directory with music contains both a playlist(m3u) and some mp3 files(also included in that playlist) the wrong mp3 file is selected/playing when not using the playlist. Always the mp3 file below the one selected starts playing when selecting a mp3. This problem doesn't occur when I just start playing the playlist and choose from the songs within the playlist.

    For example. When a directory contains:

    playlist.m3u(which contains song1.mp3, song2.mp3, song3.mp3, song4.mp3)
    song1.mp3
    song2.mp3
    song3.mp3
    song4.mp3

    When I select song1.mp3 to play it will start playing song2.mp3, same for song3.mp3 which starts playing song4.mp3.



    The problem doesn't occur when there is no playlist available in the specific folder or the playlist is used to play the songs. I also noticed when a folder contains 2 playlists the problem is a bit different. In the above example when 2 playlists are available and I will play song1.mp3, song3.mp3 will start playing. So it seems like it changes one spot.

    My system is running
    Windows 8.1 x64
    Music is located on my nas

    I've included logs(don't think it will help but played some songs before making the zip). I've also included screenshots of the settings how my music part is configured. If any additional information is needed I will be glad to provide this.
     

    Attached Files:

    • Knipsel2.PNG
      Knipsel2.PNG
      File size:
      144.5 KB
      Uploaded:
      February 24, 2015
      Views:
      99
    • Knipsel3.PNG
      Knipsel3.PNG
      File size:
      193.9 KB
      Uploaded:
      February 24, 2015
      Views:
      103
    • Knipsel.PNG
      Knipsel.PNG
      File size:
      196.8 KB
      Uploaded:
      February 24, 2015
      Views:
      95
    • Knipsel4.PNG
      Knipsel4.PNG
      File size:
      206.7 KB
      Uploaded:
      February 24, 2015
      Views:
      105
    • Thank You! Thank You! x 1
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,239
    Likes Received:
    6,202
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,201 / 9
    Home Country:
    France France
    Show System Specs
    Could you test with official 1.11 pre release, you can reinstall MP1-4578 build over it after. ?
    If it didn't happen, it mean the fix for M3U is not in MP1-4578 build (i think it should be in but maybe i did something wrong lol)
    Thanks :)
     
  4. killer8

    killer8 Portal Pro

    Joined:
    July 29, 2012
    Messages:
    378
    Likes Received:
    113
    Ratings:
    +186 / 2
    Home Country:
    Netherlands Netherlands
    Show System Specs
    I just installed the official 1.11 pre release and have the same issue as described above.
     
    • Thank You! Thank You! x 1
  5. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,239
    Likes Received:
    6,202
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,201 / 9
    Home Country:
    France France
    Show System Specs
    Ok :)
    So the logic to fix issue need to be reworked lol
    Will try to see that maybe next week but not sure :p
     
    • Thank You! Thank You! x 1
  6. killer8

    killer8 Portal Pro

    Joined:
    July 29, 2012
    Messages:
    378
    Likes Received:
    113
    Ratings:
    +186 / 2
    Home Country:
    Netherlands Netherlands
    Show System Specs
    If you ask me someone made a little mistake with an index in a list or something where the playlist is excluded in one and not excluded in the other. But would be nice if you can take a look.
     
  7. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,239
    Likes Received:
    6,202
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,201 / 9
    Home Country:
    France France
    Show System Specs
    It's me, i have reproduce an issue about it wrong item selected and fixed it at least on my testing folder that contain m3u and mp3 but it seems to failed in your case so the fix is not correct :)
     
  8. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,239
    Likes Received:
    6,202
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,201 / 9
    Home Country:
    France France
    Show System Specs
    I have something to test :)
    Could you try the future uploaded bin ?
    Thanks :)

    Ps : you can copy it over official or MP1-4578 build.
     
  9. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,239
    Likes Received:
    6,202
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,201 / 9
    Home Country:
    France France
    Show System Specs
    Here we go :)
     

    Attached Files:

    • Thank You! Thank You! x 2
  10. edterbak
    • Team MediaPortal

    edterbak Test Group

    Joined:
    March 4, 2008
    Messages:
    2,114
    Likes Received:
    736
    Gender:
    Male
    Occupation:
    Researcher
    Ratings:
    +1,178 / 5
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Seb, I noticed this behaviour yesterday as well. Weird and missed it during testing.

    I will test this as well for you. Tonight possibly.
     
    • Thank You! Thank You! x 1
  11. killer8

    killer8 Portal Pro

    Joined:
    July 29, 2012
    Messages:
    378
    Likes Received:
    113
    Ratings:
    +186 / 2
    Home Country:
    Netherlands Netherlands
    Show System Specs
    I can confirm the fix from @Sebastiii is working correct now. Well done:)
     
    • Thank You! Thank You! x 1
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!