? XmlTV Bug with "time compensation" check box unable to be unchecked... (1 Viewer)

Neville

Portal Pro
July 21, 2008
136
13
Hamilton
Home Country
New Zealand New Zealand
MediaPortal Version: 1.3.0

Description
Hi
In MP 1.2.3 I was grabbing epg data using EPG Grabber and importing TVGuide.xml via XmlTV plugin. When first set up times were incorrect so checke "apply time zone compensation" ("13" Hours - New Zealand).
With MP 1.3.0 my data was now 13 hours out. EPG grabber does have the correct format ie time with "+1300" in the appropriate spot. So I assumed that this is now "working" in the latest version of MP as nothing had changed. I this removed the check box in the XmlTV plugin server setup. Nothing happened and I went around in circles for a week.

Eventually I rechecked the box and changed the numbers for the compensation to "0" and this then fixed the times in EPG


I assume this is a bug and the previous data is not overwritten when removing the check?

No logs as not sure where XmlTV setup and usage log is found
Neville

Steps to Reproduce:
set time compensation to a number eg 13. Import TvGuide.xml. Time is added Uncheck box. No change in EPG times. Time is not removed.

Check box and apply zero hours compensation as work around
 

HomeY

Test Group
  • Team MediaPortal
  • February 23, 2008
    6,475
    4,645
    48
    ::1
    Home Country
    Netherlands Netherlands
    We need at least updated System Specs & full debug logs after trying to reproduce this (see my signature on how to fix this).
     
    Last edited:

    hello_joe

    Portal Member
    April 2, 2013
    28
    18
    Home Country
    United States of America United States of America
    The idea of the box is that it should be a compensation from the local timezone (ie. NZ in your case) to a desired timezone. It is *not* the offset from GMT to your timezone. Hence, if your data is not in the local timezone, just check the box. You only specify a non-zero offset if you want the data to be in a non-local-timezone. For example, if you wanted to get the Australian offset then you'd use -2 or -3 or -4.

    Make sense?

    The change is noted here:
    http://wiki.team-mediaportal.com/1_MEDIAPORTAL_1/0_What's_New/1.3.x/1_UI_Related_Changes/Config_Related_Changes/XMLTV_plugin_DST_compatible

    @HomeY: perhaps the wiki could do with an update/clarification in the main XMLTV section?
    http://wiki.team-mediaportal.com/1_...tion/TV-Server_Configuration/13_Plugins/XmlTv
     
    Last edited:

    Users who are viewing this thread

    Top Bottom