XMLTV import stucks (1 Viewer)

hidalgo

Portal Member
July 6, 2014
17
2
54
Home Country
Switzerland Switzerland
Country flag
A few days ago MP2 stops to import EPG data from xmlTV

Log file says

[2016-05-11 14:18:21,723] [14978 ] [SetupTv ] [DEBUG] - plugin:xmltv importing C:\ProgramData\Team MediaPortal\MP2-Server\SlimTVCore\v3.0\xmltv\tvguide.xml
[2016-05-11 14:18:21,851] [15106 ] [SetupTv ] [ERROR] - plugin:xmltv import failed
[2016-05-11 14:18:21,851] [15106 ] [SetupTv ] [ERROR] -
System.FormatException: Exception System.FormatException: Input string was not in a correct format.
bei System.Number.StringToNumber(String str, NumberStyles options, NumberBuffer& number, NumberFormatInfo info, Boolean parseDecimal)
bei System.Number.ParseInt32(String s, NumberStyles style, NumberFormatInfo info)
bei System.Int32.Parse(String s)
bei TvEngine.XMLTVImport.Import(String fileName, Boolean deleteBeforeImport, Boolean showProgress)
bei TvEngine.XmlTvImporter.ThreadFunctionImportTVGuide(Object aparam)

And Import status: tvguide.xml:already importing …

I tried with a new and different xml files. Before it worked like a charm. I tried to delete records in the sqlite database, I reinstalled MP 2. Always the same status.

Any help? BTW EPG data from DVB-C works.
 

Lehmden

Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,361
    3,803
    Lehmden
    Home Country
    Germany Germany
    Country flag
    Hi.
    There most likely are some "bad" chars in a program description. This happens from time to time (maybe once a year) and fixes itself automatically as soon as the program description is no longer in the tvguide.xml. As a workaround you can remove the channel with the "faulty" description temporary from your xmltv setup and use DVB EPG for this channel over the next (maybe two) week(s)...

    If I would know what you are using to generate the tvguide.xml I maybe can help any further. E.G. WebGrab+Plus is moaning about the wrong chars if you try to update a guide xml file and so you can see in the command line window which channel has the faulty description.
     

    hidalgo

    Portal Member
    July 6, 2014
    17
    2
    54
    Home Country
    Switzerland Switzerland
    Country flag
    Yes, I use WebGrab+Plus. And bad chars was my first idea. So I tried different xml files, also tried xml files with less or without any program data. Always the same issue. It seems as some data is still hanging in a sort of cache.
     

    hidalgo

    Portal Member
    July 6, 2014
    17
    2
    54
    Home Country
    Switzerland Switzerland
    Country flag
    Still no success. Still Import status: tvguide.xml:already importing …

    [2016-05-13 02:54:19,864] [647956 ] [SetupTv ] [DEBUG] - plugin:xmltv importing C:\ProgramData\Team MediaPortal\MP2-Server\SlimTVCore\v3.0\xmltv\tvguide.xml
    [2016-05-13 02:54:19,864] [647956 ] [SetupTv ] [DEBUG] - Xmltv: imported 0 channels, 0 programs status:tvguide.xml:already importing...;
    [2016-05-13 02:54:19,879] [647972 ] [SetupTv ] [INFO ] - Xmltv: waiting for database to finish inserting imported programs.
    [2016-05-13 02:54:19,879] [647972 ] [SetupTv ] [DEBUG] - plugin:xmltv import done

    Any further advice?
     

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,361
    3,803
    Lehmden
    Home Country
    Germany Germany
    Country flag
    Any further advice?
    You can stop the MP2 server, delete the "MP2TVE_3.s3db" in "c:\ProgramData\Team MediaPortal\MP2-Server\Database\" and start the server again. This way a new and empty database is generated. On an uninstall the database files stay untouched. Very useful in regular cases but an issue if there is something wrong with the db.
    You should use the "Import/Export" function to save your groups, schedules and settings before! deleting the database. This way you only need to scan for channels again. It's better to do a fresh channel scan also the channels are exported too.

    No other place where some leavings of xmltv could be reside, if you are sure your tvguide.xml is not the root cause.
     

    hidalgo

    Portal Member
    July 6, 2014
    17
    2
    54
    Home Country
    Switzerland Switzerland
    Country flag
    Thanks. I tried it again. I did it before. But it doesn’t work. No, I’m not sure my tvguide.xml is not the issue. But until now it did not make any issues. And how can I test this? Is there any working tvguide.xml for downloading?
     

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,361
    3,803
    Lehmden
    Home Country
    Germany Germany
    Country flag
    Hi.
    I've uploaded mine. It's for German FTA channels, so probably some channels are identical for you in Switzerland. This guide has imported without issues this morning here...

    Edit. Don't forget to adjust the mapping inside the xmltv plugin. Most likely the channels are named different..
     

    hidalgo

    Portal Member
    July 6, 2014
    17
    2
    54
    Home Country
    Switzerland Switzerland
    Country flag
    Thank you. Unfortunately it does not work. Same errors as before

    [2016-05-13 18:31:08,623] [129297 ] [SetupTv ] [DEBUG] - Loading all channels from the database
    [2016-05-13 18:31:17,429] [138103 ] [SetupTv ] [DEBUG] - plugin:xmltv importing C:\ProgramData\Team MediaPortal\MP2-Server\SlimTVCore\v3.0\xmltv\tvguide.xml
    [2016-05-13 18:31:17,608] [138282 ] [SetupTv ] [DEBUG] - Xmltv: imported 0 channels, 0 programs status:tvguide.xml:already importing...;
    [2016-05-13 18:31:17,627] [138301 ] [SetupTv ] [INFO ] - Xmltv: waiting for database to finish inserting imported programs.
    [2016-05-13 18:31:17,627] [138301 ] [SetupTv ] [DEBUG] - plugin:xmltv import done
    [2016-05-13 18:32:15,428] [196103 ] [SetupTv ] [DEBUG] - plugin:xmltv importing C:\ProgramData\Team MediaPortal\MP2-Server\SlimTVCore\v3.0\xmltv\tvguide.xml
    [2016-05-13 18:32:15,602] [196276 ] [SetupTv ] [DEBUG] - Xmltv: imported 0 channels, 0 programs status:tvguide.xml:already importing...;
    [2016-05-13 18:32:15,609] [196283 ] [SetupTv ] [INFO ] - Xmltv: waiting for database to finish inserting imported programs.
    [2016-05-13 18:32:15,609] [196283 ] [SetupTv ] [DEBUG] - plugin:xmltv import done
    [2016-05-13 18:33:31,703] [272378 ] [SetupTv ] [DEBUG] - plugin:xmltv importing C:\ProgramData\Team MediaPortal\MP2-Server\SlimTVCore\v3.0\xmltv\tvguide.xml
    [2016-05-13 18:33:31,883] [272558 ] [SetupTv ] [DEBUG] - Xmltv: imported 0 channels, 0 programs status:tvguide.xml:already importing...;
    [2016-05-13 18:33:31,903] [272578 ] [SetupTv ] [INFO ] - Xmltv: waiting for database to finish inserting imported programs.
    [2016-05-13 18:33:31,903] [272578 ] [SetupTv ] [DEBUG] - plugin:xmltv import done

    BTW I use the same version of Webgrabplus
     

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,361
    3,803
    Lehmden
    Home Country
    Germany Germany
    Country flag
    There definitely is no other place than Database or tvguide.xml where it can hang. The "xmltv.dtd" file is on the right place and not damaged? Maybe stop Server, remove xmltv plugin (c:\Program Files (x86)\Team MediaPortal\MP2-Server\Plugins\SlimTv.Service3\Plugins\XmlTvImport.dll), start server, wait some time. Reboot and after that stop Server and add xmltv plugin again...

    Just did a manuell import:
    [2016-05-13 19:19:20,793] [45748 ] [SetupTv ] [DEBUG] - Xmltv: imported 47 channels, 15306 programs status:tvguide.xml:File imported successfully;
    So this guide definitely is working...
     

    hidalgo

    Portal Member
    July 6, 2014
    17
    2
    54
    Home Country
    Switzerland Switzerland
    Country flag
    No success. Maybe my xmltv.dtd is damaged? Where do I get a new one?
     

    Users who are viewing this thread

    Similar threads

    Hi doskabouter I only use the line jump for the description. I modify the XmlTV file from EPG-Buddy with WebGrabPlus (rex) only in the description with \n. My new description is: Genre, year of production \n Original description \n Actors
    Hi doskabouter I only use the line jump for the description. I modify the XmlTV file from EPG-Buddy with WebGrabPlus (rex) only...
    Just installed 1.28, and the new XML EPG importer refuses to import the xml spit out by EPG-Buddy. Older versions of MP1 ingest it...
    Replies
    23
    Views
    2K
    Great. :) Marking thread as "no bug".
    Great. :) Marking thread as "no bug".
    Hi all, with upgrading to 1.15 my XML TV importer throws this exception. I would be very grateful if someone could point me to...
    Replies
    3
    Views
    945
    you nailed it, it was that hours and minutes setting... the option was deselected but only seconds was set to 0. The latest import seems to have worked fine. Muchas gracias!
    you nailed it, it was that hours and minutes setting... the option was deselected but only seconds was set to 0. The latest import...
    Hey, spent a few hours scratching head and trawling the forums here, and none of the suggestions so far have helped. I've already...
    Replies
    4
    Views
    5K
    The update to the donator version worked like a charm for me. Thanks!
    The update to the donator version worked like a charm for me. Thanks!
    Windows 10, MP 1.12. Using donation version of mc2xml from microsoft to create tvguide.xml Once I switched to the donated version...
    Replies
    5
    Views
    3K
    Hi. Sorry, but I don't have any clue about this. It's something a dev must answer. And the Multishortcut dev is gone a long time now.
    Hi. Sorry, but I don't have any clue about this. It's something a dev must answer. And the Multishortcut dev is gone a long time now.
    Hi! Unfortunately i've noticed some error messages in MediaPortal-error.log with MultiShortcut -> [2014-05-18 14:43:10,576] [Log...
    Replies
    2
    Views
    5K
    Top Bottom