[solved] - XmlTv not importing programs

Discussion in 'General' started by ArdaVonWoolf, January 25, 2019.

  1. ArdaVonWoolf

    ArdaVonWoolf New Member

    Joined:
    January 25, 2019
    Messages:
    8
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +0 / 0
    Home Country:
    United States of America United States of America
    Hello,

    Looking to move my Win7 Ultimate WMC box to a Win10Pro OS and started here with MP2. Got the live TV, OTA ATSC tuning working and moved on to what the docs admit is THE most important feature of a TV tuner. The Guide.

    Followed the writeup for XmlTv, after finding WebEPG is long unfunctional, and on the last stage I am at all my channels are imported, but none of the programs. I have inspected the tvguide.xml file and it is 16MB and filled with program data, it just seems to fail to import.

    Yes I scanned for channels, did the mc2xml thing, imported and meticulously mapped channels, saved, and re-ran the import. All worked as written except that one thing--it reports the xml file was imported successfully.

    I am choosing the legacy Microsoft EPG sources, I am still getting guide data in Win7 MC. And as I mentioned, there is loads of data in the XML file--which I assume is the process.

    Where should I be looking for the issue?



    Thanks
    -AvW
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. HTPCSourcer
    • Team MediaPortal
    • Administrator

    HTPCSourcer MP2 Product Manager

    Joined:
    May 16, 2008
    Messages:
    10,513
    Likes Received:
    1,106
    Gender:
    Male
    Ratings:
    +2,374 / 21
    Home Country:
    Germany Germany
    Show System Specs
    Hello AvW,

    Did you map the xmltv channels to your own MP2 channels? You can verify the Status in the TV Configuration under Plugins/XmlTv on the Mappings tab: select your MP2 channel group and click Load/Refresh which will display your tuning and guide channel Information.
     
  4. ArdaVonWoolf

    ArdaVonWoolf New Member

    Joined:
    January 25, 2019
    Messages:
    8
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +0 / 0
    Home Country:
    United States of America United States of America
    Yes, as I said I mapped the channels. I left three without a respective mapping as blank, and they show as red, otherwise everything looked correct.
     
  5. HTPCSourcer
    • Team MediaPortal
    • Administrator

    HTPCSourcer MP2 Product Manager

    Joined:
    May 16, 2008
    Messages:
    10,513
    Likes Received:
    1,106
    Gender:
    Male
    Ratings:
    +2,374 / 21
    Home Country:
    Germany Germany
    Show System Specs
    Then we'll need logs in DEBUG mode.
     
  6. ArdaVonWoolf

    ArdaVonWoolf New Member

    Joined:
    January 25, 2019
    Messages:
    8
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +0 / 0
    Home Country:
    United States of America United States of America
    I'm looking at the XML data and they all have a "programme start" value beginning with 2015. E.g.
    <programme start="20150930183000 -500" stop=20150930190000 -500" channel="I56.26...etc...

    Does this mean these are from the year 2015, as in September 30, 2015 ?

    That would be the reason, none of the guide data is in the future.

    That would seem to be an odd result...
     
  7. ArdaVonWoolf

    ArdaVonWoolf New Member

    Joined:
    January 25, 2019
    Messages:
    8
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +0 / 0
    Home Country:
    United States of America United States of America
    full example. logs attached.

    <programme start="20150713163000 -0500" stop="20150713170000 -0500" channel="I42.27859524.microsoft.com">
    <title lang="en">5 Eyewitness News at 4:30</title>
    <category lang="en">News</category>
    <category lang="en">Other</category>
    <category lang="en">Series</category>
    <episode-num system="ms_progid">1.SH009617010000</episode-num>
    <episode-num system="dd_progid">SH00961701.0000</episode-num>
    <audio>
    <stereo>stereo</stereo>
    </audio>
    <new />
    <subtitles type="teletext" />
    </programme>
     

    Attached Files:

  8. ArdaVonWoolf

    ArdaVonWoolf New Member

    Joined:
    January 25, 2019
    Messages:
    8
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +0 / 0
    Home Country:
    United States of America United States of America
    OK. Changed the system date on the computer to July 26 2015 and ran the import--programs imported into the guide successfully. Checked in MP2 and yup, the guide has data.

    So...why am I getting 2015 data? The tvguide.xml names Zap2it as the generator, and I see current listings on zap2it.com.
     
  9. HTPCSourcer
    • Team MediaPortal
    • Administrator

    HTPCSourcer MP2 Product Manager

    Joined:
    May 16, 2008
    Messages:
    10,513
    Likes Received:
    1,106
    Gender:
    Male
    Ratings:
    +2,374 / 21
    Home Country:
    Germany Germany
    Show System Specs
    Sorry, as this is not a MP2 problem, I can’t really help you. No idea about zap2it.
     
  10. ArdaVonWoolf

    ArdaVonWoolf New Member

    Joined:
    January 25, 2019
    Messages:
    8
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +0 / 0
    Home Country:
    United States of America United States of America
    Ok, the mc2xml using the MC version is broken. I found this for working with zap2it using a different parsing tool zap2xml

    xmltv install / configure for ATSC / OTA U.S.A

    Maybe this will help the next WMC user to get the guide to work. I bet if I went with my gut to go with TitanTV instead of trying to replicate the WMC guide, I wouldn't have had any problems.

    Thanks
    -AvW
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!