xmltv plugin "No xmltv file found" (1 Viewer)

ehab

New Member
July 21, 2015
5
0
30
United States of America United States of America
Total channels imported: 0
Total programs imported: 0
Import status: tvguide.xml:No xmltv file found;

i followed all the steps in this page http://wiki.team-mediaportal.com/1_...tion/TV-Server_Configuration/13_Plugins/XmlTv

I found the hidden file "xmltv.dtd" where they said, and i copied the "guide.xml" -from WebGrab- in that folder [C:\ProgramData\Team MediaPortal\MediaPortal TV Server\xmltv]
but that's the result i got

I'm using WebGrab+Plus to generate "guide.xml"

thanks a lot
Ehab
 

mm1352000

Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Hello and welcome Ehab :)

    The file must be named "tvguide.xml". If it is "guide.xml" then it won't work.

    Regards,
    mm
     

    ehab

    New Member
    July 21, 2015
    5
    0
    30
    United States of America United States of America
    xmltv1.png xmltv2.png tvguide.png
    Hello and welcome Ehab :)

    The file must be named "tvguide.xml". If it is "guide.xml" then it won't work.

    Regards,
    mm
    Hi,
    thank you, and excuse me I don't know much about these programs
    I did that but nothing has changed!
    i get the same thing =>

    -Total channels imported: 0
    -Total programs imported: 0
    -Import status: tvguide.xml:No xmltv file found;

    here's the folder i choose for xmlTv plugin tvguide.png

    best regards,
    Ehab


    EDIT!
    i tried a to make a new guide.xml with WebGrab+Plus, then i copied everything into a new file and named it "tvguide.xml" and i saved it in that folder, and now there are 127 channels imported, but still i can't map them!
     
    Last edited:

    RonD

    Test Group
  • Team MediaPortal
  • December 20, 2011
    904
    275
    SillyValley CA
    United States of America United States of America
    Country flag
    just to confirm you have things setup, double check you have "Import new tvguide.xml" checked "on", went to the mappings page setup your channels pressed "save", and then pressed "import".

    It would help if you uploaded the log files in the "Team MediaPortal\MediaPortal TV Server\log" folder. you should also also use a web browser (firefox chrome etc) to open the tvguide.xml file, maybe something in the file is causing problems. If the tvguide.xml is real big, it could take a long time to open the file with a browser.
     

    ehab

    New Member
    July 21, 2015
    5
    0
    30
    United States of America United States of America
    just to confirm you have things setup, double check you have "Import new tvguide.xml" checked "on", went to the mappings page setup your channels pressed "save", and then pressed "import".

    It would help if you uploaded the log files in the "Team MediaPortal\MediaPortal TV Server\log" folder. you should also also use a web browser (firefox chrome etc) to open the tvguide.xml file, maybe something in the file is causing problems. If the tvguide.xml is real big, it could take a long time to open the file with a browser.
    Hi RonD, thanks for your help
    i did that and i got 127 imported channels, but nothing else, and i still cannot map!
    please take a look at these 2 screenshots
    xmltv1.png xmltv2.png

    I found many files in the log folder, i hope this is the right one

    thank you very much
    Ehab
     

    RonD

    Test Group
  • Team MediaPortal
  • December 20, 2011
    904
    275
    SillyValley CA
    United States of America United States of America
    Country flag
    have you already setup your tuner cards, done a channel scan, and see channels in the setuptv.exe "tv channels" section?
    http://wiki.team-mediaportal.com/1_...ration/TV-Server_Configuration/03_TV_Channels

    assuming you have, in xmltv > mappings, you need to use "group" to select a channel group like "All Channels" then press "load" to get the channels. After pressing "load", you should see see at least the "Tuning Channels", you may need to manually setup the "Guide Channels". the following setup guide give info on how to setup xmltv. the "channel mapping" section should apply to using WebGrabPlus.

    http://wiki.team-mediaportal.com/1_..._TV_Setup/4_TV_Guide_Setup_(EPG)/XMLTV_mc2xml
     

    ehab

    New Member
    July 21, 2015
    5
    0
    30
    United States of America United States of America
    have you already setup your tuner cards, done a channel scan, and see channels in the setuptv.exe "tv channels" section?
    http://wiki.team-mediaportal.com/1_...ration/TV-Server_Configuration/03_TV_Channels

    assuming you have, in xmltv > mappings, you need to use "group" to select a channel group like "All Channels" then press "load" to get the channels. After pressing "load", you should see see at least the "Tuning Channels", you may need to manually setup the "Guide Channels". the following setup guide give info on how to setup xmltv. the "channel mapping" section should apply to using WebGrabPlus.

    http://wiki.team-mediaportal.com/1_..._TV_Setup/4_TV_Guide_Setup_(EPG)/XMLTV_mc2xml
    Hi, thanks again RonD
    I tried to read all of these instructions, but i don't know what's going wrong with my MP
    I feel bad now!

    I tried to get "ustvnow" channels this time [I mean shorter list, only 25] but i got the same result
    xmltv3.png xmltv4.png

    and here's the tvguide.xml file that WebGrab+ generated
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    I tried to read all of these instructions, but i don't know what's going wrong with my MP
    Okay, simple question: do you have a tuner?

    From the log files that you posted earlier it looks like you don't.
    If you don't have a tuner then you can't have scanned for channels.
    If you haven't scanned for channels then you won't have any channels in the TV Server configuration "TV Channels" or "Radio Channels" sections.
    If you haven't got any channels then you won't be able to import EPG with the XMLTV plugin.

    In short: no tuner => no point in using TV Server. In such a situation (no tuner, no channels), nothing would be "wrong" with your MP. What you're seeing would be expected and normal.

    If you want to watch internet TV such as USTVNow with MediaPortal then I suggest you look at the OnlineVideos plugin:
    https://www.team-mediaportal.com/extensions/movies-videos/onlinevideos

    I'm not saying that the OnlineVideos plugin will work with USTVNow. It may not. What I do know is that TV Server can't help you access USTVNow.
     

    ehab

    New Member
    July 21, 2015
    5
    0
    30
    United States of America United States of America
    I tried to read all of these instructions, but i don't know what's going wrong with my MP
    Okay, simple question: do you have a tuner?

    From the log files that you posted earlier it looks like you don't.
    If you don't have a tuner then you can't have scanned for channels.
    If you haven't scanned for channels then you won't have any channels in the TV Server configuration "TV Channels" or "Radio Channels" sections.
    If you haven't got any channels then you won't be able to import EPG with the XMLTV plugin.

    In short: no tuner => no point in using TV Server. In such a situation (no tuner, no channels), nothing would be "wrong" with your MP. What you're seeing would be expected and normal.

    If you want to watch internet TV such as USTVNow with MediaPortal then I suggest you look at the OnlineVideos plugin:
    https://www.team-mediaportal.com/extensions/movies-videos/onlinevideos

    I'm not saying that the OnlineVideos plugin will work with USTVNow. It may not. What I do know is that TV Server can't help you access USTVNow.
    Hi, and thanks so much for your replies
    I guess, you are right, because i tried to scan for channels and nothing showed up!
    xmltv5.png xmltv7.png xmltv8.png xmltv9.png

    "ustvnow" was an example. what i really need is Arabic channel EPG from "shoofeetv"

    to be honest, I feel stupid when i use this program, and i'm about to give up! :confused:
    if you know anything i need to configure this, i will be so grateful

    thanks again
    Ehab
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    C Can the XmlTv Plugin handle 600+ channels? General 3
    J Schedules Direct - XmlTV Plugin xmlTV 6
    framug No color in TVGuide when XMLTV without DVB EPG MediaPortal 1 Talk 59
    B xmltv - cannot import tvguide.xml australia Installation, configuration support 0
    geotwticher TV Guide EPG Grabber for Australia 2020 RIP freepg.tv General 4
    P Timeshifting in XMLTV General 2
    JJDoherty 1.22.0 XMLTV not raising the following OnImportEpgPrograms event... 1.22 0
    lacanox XMLTV not writing the tv schedule Electronic Program Guide 3
    A [solved] XmlTv not importing programs General 8
    dcapslock TV Server xmltv IWakeupHandler Bug Television (MyTV frontend and TV-Server) 6
    T No data available using xmltv and mc2xml xmlTV 2
    W XMLTVImport duplicate item error xmlTV 5
    joecrow 1.25.0 Radio Time plugin fails after Resume from Sleep with MP 1.25 Bugreports 3
    P MP2: US user, OTA - can NOT get SchedulesDirect plugin to work on MP1 or MP2 --> how do I get OTA schedule? General 5
    E aktuelle englische Forums Webseite von - Showtime Plugin v3 Plugins & Erweiterungen 4
    mrmojo666 [Tv Server Plugin ]Direct Show Video Control Plugin 0.0.0.1 for Hauppauge PVR cards MediaPortal 1 Plugins 0
    joecrow MultiShortcut Plugin (Uavailable) in DWHD skin General Support 58
    vapourEyes Building TV Plugin General Development (no feature request here!) 49
    Golf4 Nach Windows-Updates läuft TV-Plugin nicht mehr Allgemeines Support- und Diskussionsforum 0
    joecrow How about a Launcher plugin for MP1? MediaPortal 1 6
    D [solved] TVServer Plugin must be missing something. General Development (no feature request here!) 1
    framug Nouveau plugin XmlTvFR pour récupérer le guide télé français Kazer / ZguideTv (WebEPGfr) 11
    emphatic Allow remote control mapping of all plugins Improvement Suggestions 0
    D Where should plugins be located on hard drive? General Support 0
    D how to disengage from one version of a plugin to use another Newcomers Forum 0
    Similar threads

























    Top Bottom