xmltv plugin "No xmltv file found"

Discussion in 'TV-Server Plugins' started by ehab, July 21, 2015.

  1. ehab

    ehab New Member

    Joined:
    July 21, 2015
    Messages:
    5
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +0 / 0
    Home Country:
    United States of America United States of America
    Total channels imported: 0
    Total programs imported: 0
    Import status: tvguide.xml:No xmltv file found;

    i followed all the steps in this page http://wiki.team-mediaportal.com/1_...tion/TV-Server_Configuration/13_Plugins/XmlTv

    I found the hidden file "xmltv.dtd" where they said, and i copied the "guide.xml" -from WebGrab- in that folder [C:\ProgramData\Team MediaPortal\MediaPortal TV Server\xmltv]
    but that's the result i got



    I'm using WebGrab+Plus to generate "guide.xml"

    thanks a lot
    Ehab
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,526
    Likes Received:
    4,735
    Ratings:
    +8,201 / 17
    Home Country:
    New Zealand New Zealand
    Hello and welcome Ehab :)

    The file must be named "tvguide.xml". If it is "guide.xml" then it won't work.

    Regards,
    mm
     
  4. ehab

    ehab New Member

    Joined:
    July 21, 2015
    Messages:
    5
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +0 / 0
    Home Country:
    United States of America United States of America
    xmltv1.png xmltv2.png tvguide.png
    Hi,
    thank you, and excuse me I don't know much about these programs
    I did that but nothing has changed!
    i get the same thing =>

    -Total channels imported: 0
    -Total programs imported: 0
    -Import status: tvguide.xml:No xmltv file found;

    here's the folder i choose for xmlTv plugin tvguide.png

    best regards,
    Ehab


    EDIT!
    i tried a to make a new guide.xml with WebGrab+Plus, then i copied everything into a new file and named it "tvguide.xml" and i saved it in that folder, and now there are 127 channels imported, but still i can't map them!
     
    Last edited: July 22, 2015
  5. RonD
    • Team MediaPortal

    RonD Test Group

    Joined:
    December 20, 2011
    Messages:
    904
    Likes Received:
    119
    Occupation:
    semi-pro slacker
    Location:
    SillyValley CA
    Ratings:
    +275 / 0
    Home Country:
    United States of America United States of America
    just to confirm you have things setup, double check you have "Import new tvguide.xml" checked "on", went to the mappings page setup your channels pressed "save", and then pressed "import".

    It would help if you uploaded the log files in the "Team MediaPortal\MediaPortal TV Server\log" folder. you should also also use a web browser (firefox chrome etc) to open the tvguide.xml file, maybe something in the file is causing problems. If the tvguide.xml is real big, it could take a long time to open the file with a browser.
     
  6. ehab

    ehab New Member

    Joined:
    July 21, 2015
    Messages:
    5
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +0 / 0
    Home Country:
    United States of America United States of America
    Hi RonD, thanks for your help
    i did that and i got 127 imported channels, but nothing else, and i still cannot map!
    please take a look at these 2 screenshots
    xmltv1.png xmltv2.png

    I found many files in the log folder, i hope this is the right one

    thank you very much
    Ehab
     
  7. RonD
    • Team MediaPortal

    RonD Test Group

    Joined:
    December 20, 2011
    Messages:
    904
    Likes Received:
    119
    Occupation:
    semi-pro slacker
    Location:
    SillyValley CA
    Ratings:
    +275 / 0
    Home Country:
    United States of America United States of America
    have you already setup your tuner cards, done a channel scan, and see channels in the setuptv.exe "tv channels" section?
    http://wiki.team-mediaportal.com/1_...ration/TV-Server_Configuration/03_TV_Channels

    assuming you have, in xmltv > mappings, you need to use "group" to select a channel group like "All Channels" then press "load" to get the channels. After pressing "load", you should see see at least the "Tuning Channels", you may need to manually setup the "Guide Channels". the following setup guide give info on how to setup xmltv. the "channel mapping" section should apply to using WebGrabPlus.

    http://wiki.team-mediaportal.com/1_..._TV_Setup/4_TV_Guide_Setup_(EPG)/XMLTV_mc2xml
     
  8. ehab

    ehab New Member

    Joined:
    July 21, 2015
    Messages:
    5
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +0 / 0
    Home Country:
    United States of America United States of America
    Hi, thanks again RonD
    I tried to read all of these instructions, but i don't know what's going wrong with my MP
    I feel bad now!

    I tried to get "ustvnow" channels this time [I mean shorter list, only 25] but i got the same result
    xmltv3.png xmltv4.png

    and here's the tvguide.xml file that WebGrab+ generated
     
  9. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,526
    Likes Received:
    4,735
    Ratings:
    +8,201 / 17
    Home Country:
    New Zealand New Zealand
    Okay, simple question: do you have a tuner?

    From the log files that you posted earlier it looks like you don't.
    If you don't have a tuner then you can't have scanned for channels.
    If you haven't scanned for channels then you won't have any channels in the TV Server configuration "TV Channels" or "Radio Channels" sections.
    If you haven't got any channels then you won't be able to import EPG with the XMLTV plugin.

    In short: no tuner => no point in using TV Server. In such a situation (no tuner, no channels), nothing would be "wrong" with your MP. What you're seeing would be expected and normal.

    If you want to watch internet TV such as USTVNow with MediaPortal then I suggest you look at the OnlineVideos plugin:
    https://www.team-mediaportal.com/extensions/movies-videos/onlinevideos

    I'm not saying that the OnlineVideos plugin will work with USTVNow. It may not. What I do know is that TV Server can't help you access USTVNow.
     
  10. ehab

    ehab New Member

    Joined:
    July 21, 2015
    Messages:
    5
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +0 / 0
    Home Country:
    United States of America United States of America
    Hi, and thanks so much for your replies
    I guess, you are right, because i tried to scan for channels and nothing showed up!
    xmltv5.png xmltv7.png xmltv8.png xmltv9.png

    "ustvnow" was an example. what i really need is Arabic channel EPG from "shoofeetv"

    to be honest, I feel stupid when i use this program, and i'm about to give up! :confused:
    if you know anything i need to configure this, i will be so grateful

    thanks again
    Ehab
     
  11. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,526
    Likes Received:
    4,735
    Ratings:
    +8,201 / 17
    Home Country:
    New Zealand New Zealand
    • Like Like x 1
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!