[solved] XMLTV tvguide.xml 'already importing' usual fixes not working

David Scott

Portal Member
Joined
April 20, 2012
Messages
8
Points
1
Age
49


Hey, spent a few hours scratching head and trawling the forums here, and none of the suggestions so far have helped.
I've already checked the database for errors using the sql command listed in another post - no errors,
tried clearing out all rows from the program table
re-checked that my mappings are configured correctly

but I get these message in my logs - and TV server config xmltv import just shows 'already importing'

Any suggestions, I'm trying to avoid a clean reinstall - about yearly I've had to do that for one reason or another, it's annoying

[2017-09-04 15:53:08,935] [Log ] [SetupTv ] [ERROR] - plugin:xmltv import failed
[2017-09-04 15:53:08,947] [Log ] [SetupTv ] [ERROR] - Exception :confused:ystem.FormatException: Input string was not in a correct format.
at System.Number.StringToNumber(String str, NumberStyles options, NumberBuffer& number, NumberFormatInfo info, Boolean parseDecimal)
at System.Number.ParseInt32(String s, NumberStyles style, NumberFormatInfo info)
at System.Int32.Parse(String s)
at TvEngine.XMLTVImport.Import(String fileName, Boolean deleteBeforeImport, Boolean showProgress)
at TvEngine.XmlTvImporter.ThreadFunctionImportTVGuide(Object aparam)


and my tvguide.xml looks like this (abridged)

XML:
<?xml version="1.0" encoding="utf-8"?>
<tv generator-info-name="DomainObjects/4.3.5838.20264">
  <channel id="1502">
    <display-name>Al Jazeera</display-name>
  </channel>
  <channel id="1501">
    <display-name>Apna Television</display-name>
  </channel>
  <channel id="2002">
    <display-name>BaseFM</display-name>
  </channel>
  <channel id="1307">
    <display-name>Bravo</display-name>
  </channel>
  <channel id="1308">
    <display-name>Bravo PLUS 1</display-name>
  </channel>
  <channel id="1412">
    <display-name>Channel North</display-name>
  </channel>
  <channel id="1403">
    <display-name>ChineseTV</display-name>
  </channel>
  <channel id="1407">
    <display-name>ChoiceTV</display-name>
  </channel>
  <channel id="1414">
    <display-name>Firstlight</display-name>
  </channel>
  <channel id="1508">
    <display-name>HGTV</display-name>
  </channel>
  <channel id="1506">
    <display-name>Hope Channel</display-name>
  </channel>
  <channel id="1411">
    <display-name>Info-Rotorua</display-name>
  </channel>
  <channel id="1600">
    <display-name>Maori Television</display-name>
  </channel>
  <channel id="1509">
    <display-name>NCTV-Chinese</display-name>
  </channel>
  <channel id="1421">
    <display-name>PandaTV</display-name>
  </channel>
  <channel id="1401">
    <display-name>Parliament</display-name>
  </channel>
  <channel id="1404">
    <display-name>PRIME</display-name>
  </channel>
  <channel id="2001">
    <display-name>Radio NZ Concert</display-name>
  </channel>
  <channel id="1507">
    <display-name>Radio NZ National</display-name>
  </channel>
  <channel id="6002">
    <display-name>Shine TV</display-name>
  </channel>
  <channel id="1417">
    <display-name>SouthernTV</display-name>
  </channel>
  <channel id="1601">
    <display-name>Te Reo</display-name>
  </channel>
  <channel id="6001">
    <display-name>Television Hawke's Bay</display-name>
  </channel>
  <channel id="1305">
    <display-name>The Edge TV</display-name>
  </channel>
  <channel id="1300">
    <display-name>Three</display-name>
  </channel>
  <channel id="1302">
    <display-name>ThreePlus1</display-name>
  </channel>
  <channel id="1505">
    <display-name>TV29</display-name>
  </channel>
  <channel id="1405">
    <display-name>TV33</display-name>
  </channel>
  <channel id="1200">
    <display-name>TVNZ 1</display-name>
  </channel>
  <channel id="1206">
    <display-name>TVNZ 1 +1</display-name>
  </channel>
  <channel id="1201">
    <display-name>TVNZ 2</display-name>
  </channel>
  <channel id="1207">
    <display-name>TVNZ 2 +1</display-name>
  </channel>
  <channel id="1205">
    <display-name>TVNZ DUKE</display-name>
  </channel>
  <channel id="1504">
    <display-name>TVSN Shopping</display-name>
  </channel>
  <channel id="1423">
    <display-name>WairarapaTV</display-name>
  </channel>
  <programme start="20170904000000 +1200" stop="20170904010000 +1200" channel="1502">
    <title>Al Jazeera World</title>
    <desc>The story of the Rwandan Genocide in 1994 when 800,000 people were killed by Hutu extremists, the major role played by the media and the road to reconciliation.</desc>
  </programme>
  <programme start="20170904010000 +1200" stop="20170904020000 +1200" channel="1502">
    <title>Newshour</title>
    <desc>In-depth global news is presented.</desc>
  </programme>
  <programme start="20170904020000 +1200" stop="20170904023000 +1200" channel="1502">
    <title>News Live</title>
    <desc>Get the latest news every evening about what is happening around the globe.</desc>
  </programme>
  <programme start="20170904023000 +1200" stop="20170904030000 +1200" channel="1502">
    <title>Listening Post</title>
    <desc>This week, we analyse how Indian media cover the so-called 'godmen' in the country. And we look at Mugabe and the Zimbabwean media.</desc>
  </programme>
 

mm1352000

Development Group
Joined
September 1, 2008
Messages
21,541
Points
113
Country flag
Hi David

I'm fairly sure the issue is somewhere within the XMLTV file. There's definitely no need to clear out the database or reinstall.

Please zip and attach the full XMLTV file so we can check it out properly.
 

mm1352000

Development Group
Joined
September 1, 2008
Messages
21,541
Points
113
Country flag
Mmmm, seems to be importing okay for me, though I haven't imported every single channel.

Please double check something else:
  1. Open TV Server Config.
  2. Navigate to the XMLTV plugin (plugins -> XmlTv).
  3. On the general tab, check that there are values in the "hours" and "minutes" boxes. If they're blank, that's the problem. As the wiki/manual explains: normally you should leave them as 0 (default) and untick "apply time compensation...".
 

David Scott

Portal Member
Joined
April 20, 2012
Messages
8
Points
1
Age
49
you nailed it, it was that hours and minutes setting... the option was deselected but only seconds was set to 0. The latest import seems to have worked fine. Muchas gracias!
 
Top