Youtube my favourites and subscriptions and support for fengyunzhibo.com

somy

Portal Pro
Joined
March 7, 2010
Messages
156
Points
18
Location
Denmark


Hi,
I'd like to view my favourites and subscriptions in Youtube. I entered my username and password in youtube channel in onlinevideos configuration, however I still cannot see them. Anything else I need to do?
I'd also like to ask how to add the streams from this site: http://www.fengyunzhibo.com/

Any help is appreciated!
Thank you!
 

somy

Portal Pro
Joined
March 7, 2010
Messages
156
Points
18
Location
Denmark
I got the following errors when I tried to open my subscription/playlist/favourite, other feeds seem to work fine:
Server stack trace:
at OnlineVideos.Sites.YouTubeUtil.DiscoverSubCategories(Category parentCategory)
at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Object[]& outArgs)
at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg)
Exception rethrown at [0]:
at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
at OnlineVideos.Sites.SiteUtilBase.DiscoverSubCategories(Category parentCategory)
at OnlineVideos.MediaPortal1.GUIOnlineVideos.<>c__DisplayClass36.<DisplayCategories>b__30()
at OnlineVideos.MediaPortal1.Gui2UtilConnector.<>c__DisplayClass5.<ExecuteInBackgroundAndCallback>b__2()
[02-12 18:01:13,226] [OnlineVideos] [INFO ] Looking for subcategories in 'Mai Sun's Subscriptions' on site 'YouTube'
[02-12 18:01:13,495] [OnlineVideos] [WARN ] OnlineVideos.OnlineVideosException: Exception message unavailable
Server stack trace:
at OnlineVideos.Sites.YouTubeUtil.DiscoverSubCategories(Category parentCategory)
at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Object[]& outArgs)
at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg)
Exception rethrown at [0]:
at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
at OnlineVideos.Sites.SiteUtilBase.DiscoverSubCategories(Category parentCategory)
at OnlineVideos.MediaPortal1.GUIOnlineVideos.<>c__DisplayClass36.<DisplayCategories>b__30()
at OnlineVideos.MediaPortal1.Gui2UtilConnector.<>c__DisplayClass5.<ExecuteInBackgroundAndCallback>b__2()
[02-12 18:01:25,747] [OnlineVideos] [WARN ] OnlineVideos.OnlineVideosException: Invalid value for parameter: username
Server stack trace:
at OnlineVideos.Sites.YouTubeUtil.parseGData(YouTubeQuery query)
at OnlineVideos.Sites.YouTubeUtil.getVideoList(Category category)
at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Object[]& outArgs)
at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg)
Exception rethrown at [0]:
at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
at OnlineVideos.Sites.SiteUtilBase.getVideoList(Category category)
at OnlineVideos.MediaPortal1.GUIOnlineVideos.<>c__DisplayClass42.<DisplayVideos_Category>b__40()
at OnlineVideos.MediaPortal1.Gui2UtilConnector.<>c__DisplayClass5.<ExecuteInBackgroundAndCallback>b__2()
 

somy

Portal Pro
Joined
March 7, 2010
Messages
156
Points
18
Location
Denmark
I got the following errors when I tried to open my subscription/playlist/favourite, other feeds seem to work fine:
Server stack trace:
at OnlineVideos.Sites.YouTubeUtil.DiscoverSubCategories(Category parentCategory)
at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Object[]& outArgs)
at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg)
Exception rethrown at [0]:
at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
at OnlineVideos.Sites.SiteUtilBase.DiscoverSubCategories(Category parentCategory)
at OnlineVideos.MediaPortal1.GUIOnlineVideos.<>c__DisplayClass36.<DisplayCategories>b__30()
at OnlineVideos.MediaPortal1.Gui2UtilConnector.<>c__DisplayClass5.<ExecuteInBackgroundAndCallback>b__2()
[02-12 18:01:13,226] [OnlineVideos] [INFO ] Looking for subcategories in 'Mai Sun's Subscriptions' on site 'YouTube'
[02-12 18:01:13,495] [OnlineVideos] [WARN ] OnlineVideos.OnlineVideosException: Exception message unavailable
Server stack trace:
at OnlineVideos.Sites.YouTubeUtil.DiscoverSubCategories(Category parentCategory)
at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Object[]& outArgs)
at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg)
Exception rethrown at [0]:
at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
at OnlineVideos.Sites.SiteUtilBase.DiscoverSubCategories(Category parentCategory)
at OnlineVideos.MediaPortal1.GUIOnlineVideos.<>c__DisplayClass36.<DisplayCategories>b__30()
at OnlineVideos.MediaPortal1.Gui2UtilConnector.<>c__DisplayClass5.<ExecuteInBackgroundAndCallback>b__2()
[02-12 18:01:25,747] [OnlineVideos] [WARN ] OnlineVideos.OnlineVideosException: Invalid value for parameter: username
Server stack trace:
at OnlineVideos.Sites.YouTubeUtil.parseGData(YouTubeQuery query)
at OnlineVideos.Sites.YouTubeUtil.getVideoList(Category category)
at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Object[]& outArgs)
at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg)
Exception rethrown at [0]:
at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
at OnlineVideos.Sites.SiteUtilBase.getVideoList(Category category)
at OnlineVideos.MediaPortal1.GUIOnlineVideos.<>c__DisplayClass42.<DisplayVideos_Category>b__40()
at OnlineVideos.MediaPortal1.Gui2UtilConnector.<>c__DisplayClass5.<ExecuteInBackgroundAndCallback>b__2()
Hi, anyone has experience with this issue? Thank you!
 

offbyone

Development Group
  • Team MediaPortal
  • Joined
    April 26, 2008
    Messages
    3,981
    Points
    113
    Location
    Stuttgart
    Country flag
    In the log it reads at some point:
    "Invalid value for parameter: username"
    Try to set your email as username and your youtube display name as account name.
     

    somy

    Portal Pro
    Joined
    March 7, 2010
    Messages
    156
    Points
    18
    Location
    Denmark
    In the log it reads at some point:
    "Invalid value for parameter: username"
    Try to set your email as username and your youtube display name as account name.
    Hi,
    Thank you for the reply!
    I tried that yesterday which didn't help......
    The feeds recommended/history work without any problem - only my subscriptions/favourites/playlist gives errors. I really look forward to getting my subscriptions feed to work......
     

    somy

    Portal Pro
    Joined
    March 7, 2010
    Messages
    156
    Points
    18
    Location
    Denmark
    I think you have to make them public or add them somewhere in your youtube profile.
    OK, i tried to delete my channel and create a new one, add some subscriptions to it.
    Now it says "Error getting dynamic categories", and even worse, I got the error for all feeds.
    I then remove my user name and logon, and it works again. So I guess it is quite difficult to get my subscriptions/favourites from YouTube. I also tried YouTube plugin in XBMC, it didn't even allow me to login.
    Is this something to do with their API?
     

    offbyone

    Development Group
  • Team MediaPortal
  • Joined
    April 26, 2008
    Messages
    3,981
    Points
    113
    Location
    Stuttgart
    Country flag
    I do not know why it is not working on your end. I can browse my YouTube sub and fav without a problem in Onlinevideos.

    It must have to do with authentication, maybe your account has some settings that don't allow it. There were posts by other people with youtube login problems. You can try searching the forum to find similar problems/solutions.
     

    AtTimesPerplexed

    MP Donator
  • Premium Supporter
  • Joined
    May 8, 2011
    Messages
    127
    Points
    28
    I had similar issues a while back.. In Online Videos I had to change my account name to the url youtube uses for my channel, youtube.com/channel/********** , just the starred bit (it looks like a series of random letters). Then the login is your Gmail address.
     

    somy

    Portal Pro
    Joined
    March 7, 2010
    Messages
    156
    Points
    18
    Location
    Denmark
    I had similar issues a while back.. In Online Videos I had to change my account name to the url youtube uses for my channel, youtube.com/channel/********** , just the starred bit (it looks like a series of random letters). Then the login is your Gmail address.
    Hi,
    Thank you for your suggestion, will give a try when I get home today.
    I think this might have something to do with integration to Google+, which automatiacally fetch the display name from Google. I remembered a while ago youtube asked me to merge my account with Google account, and that is probably the root cause.[DOUBLEPOST=1392372013][/DOUBLEPOST]
    I do not know why it is not working on your end. I can browse my YouTube sub and fav without a problem in Onlinevideos.

    It must have to do with authentication, maybe your account has some settings that don't allow it. There were posts by other people with youtube login problems. You can try searching the forum to find similar problems/solutions.
    Hi,

    Thank you for your suggestion. My display name from Google+ doesn't match the URL to my channel (https://www.youtube.com/channel/UCQx9EkOH_dTTWeYaaH2_pmA), could that cause any problem?
    Can you check what URL you get to your channel and see if it matches the display name?
    Thank you again!
     
    Top